locked
export-mailbox / import mailbox unknown error code -2147221219 RRS feed

  • Question

  • Hi all

    I'm trying to export ex2003 mailboxes in 1 forest to .pst files and import it back in a new ex2007 forest. This has to be done because I can't use move-mailbox due to several problems.

     

    I have no problems exporting to pst on the ex2003 site, outlook opens it ok.

     

    However I'm unable to do an import-mailbox on exchange 2007, the same error (below - copied from migration log) always occurr.

     

    [06-06-2008 17:45:01] [0] [ERROR] Error was found for Administrator (Administrator@someting.com) because: Error occurred in the step: Approving object. An unknown error has occurred., error code: -2147221219

     

    I tried running export-mailbox just to test and the same thing happens.

    The command used was: export-mailbox -id administrator -pstfolderpath c:\

     

    The mailboxes and users I'm working with have full exchange admin permission / mailbox permission.

    The mailboxes have been initialized and have some messages inside.

     

    Thanks for your help

     

    Friday, June 6, 2008 4:54 PM

All replies

  • Hi,

    Are you running import-mailbox on Windows 2003 32 bit server?

    Saturday, June 7, 2008 5:58 AM
  • Yes I was. Meanwhile I found out the problem (permissions).

    I added Administrator to all Exchange Admin Groups and after that I was able to run it successfully.

    Thanks

    Monday, June 9, 2008 12:51 PM
  • Hi!

    I have now the same problem with Exchange 2010.

    I added the domain administrator and the group Org Admins to all groups(roles) of Exchange 2010.

    I did everything described here: http://blogs.technet.com/sbs/archive/2009/01/13/sbs-2008-how-to-export-and-import-mailboxes-to-and-from-pst.aspx

    The mailbox export(exmerge) is from a x32 W2K SP4 Exchange 2K System. I try to import the pst in an x64 W2K8 R2 Exchange 2010.

    I appreciate any help.

    Thx




    Configuration: SCCM 2007 R2 with MDT 2008
    Sunday, December 6, 2009 9:14 PM
  • If I tried to export a mailbox I get the same error... so it has nothing to do with the pst file from the old exchange 2k.

    A manual import of the pst file works as expected.

    Configuration: SCCM 2007 R2 with MDT 2008
    Monday, December 7, 2009 11:07 AM
  • its a bug in exch2010 http://www.korneel.nl/?p=28
    Wednesday, February 24, 2010 2:57 AM
  • Does anyone knows the answer to this issue yet? I'm currently stuck with same error.


    JR
    Monday, May 10, 2010 2:25 AM
  • i believe its caused by the CAS role being on the same server as the MBX role. to fix, build another exchange server along-side but ONLY install the mailbox role as well as outlook 2010 (important: 64 bit version - NOT 32 bit - if you install the 32 bit version, you will then get an error -2147467259). then, do a local mailbox move and move any existing mailboxes to the temp exchange 2010 server. wait 5-10 minutes for it to all sync. then, run the import cmdlet, it should then work. after the PST has been imported, run the local mailbox move to move the mailbox back to the production exchange server. i have done this exact process and can confirm it works.

     

    Monday, May 10, 2010 5:24 AM
  • Wow!!! No hotfix from ms yet? Since i'm working on small scale what i've done so far is give myself a send as permission to the users mailbox then created a profile for specific user then IMPORT PST is a  long process but works temporarily!!! Thanks for the reply greatly appreciated!


    JR
    Monday, May 10, 2010 5:31 AM
  • It will be fixed in Exchange 2010 SP1 according to Microsoft...

    http://msexchangeteam.com/archive/2010/04/05/454533.aspx

    Read under "Archiving and Discovery Enhancements"...

    Beta to be released in June :-)

    Monday, May 10, 2010 5:39 AM
  • I was facing similar issue in my test lab .

    In my case I haven't configured default gateway in my single server (HT,CAS,MBX) environment because of test environment .

     

    The issue get fixed after installing outlook client on server  and putting default gateway value on server :) .

     

     

    Regards,

    Harish Kochar

     

    Tuesday, June 15, 2010 12:43 PM
  • Wednesday, June 16, 2010 7:30 AM
  • I'have tried this, but it don't work for me ?!

     

    I have still the same error !

    Thursday, June 17, 2010 7:11 PM
  • http://www.korneel.nl/?p=28#comment-19844

    http://www.thenetworkadministrator.net/index.php/2010/04/exchange-2010-error-error-code-2147221219-when-running-the-export-mailbox-command/

     

    Read these, you need to do the import export role command and then execute the import-mailbox or export-mailbox which ever you are doing in WINDOWS POWERSHELL not EMS!

    Right click windows powershell icon in task bar and import system modules first

    Good luck.

    Tuesday, July 6, 2010 4:02 AM
  • Try setting up a new email profile on the machine you are running export cmdlet from.
    Thursday, October 28, 2010 9:06 AM