locked
Error Code 8007051a during Search of Updates - Vista Ultimate RRS feed

  • Question

  •  

    Hello,

     

    i have following error code during th search of updates: 8007051A. ifound nothing anywhere abut it, please help me.

     

    elbepower.com

    Friday, February 22, 2008 5:15 PM

Answers

  • Hi,
     
    Error: Indicates two revision levels are incompatible.Which Version of Windows Vista you have installed on your machine,OEM or RTM?
     
    Please perform a cleanboot. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

     

    1) Run MSCONFIG.EXE. (MSCONFIG is a built-in tool for Windows XP\2003 systems.)

     

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

     

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

     

    4) Restart the computer. Does the problem still persist?

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     
    Also,please reintall Windows Update Agent for Windows Vista
     
    X-86:

    X-64:
     
    After that please re-start "Windows Update" services.
    You can do that by: type "services.msc" from a command prompt and find "Windows Update"
     
     
    Hope it helps.
     

    Best regards,

    Xiu Zhang - MSFT

    Microsoft Online Community Support

     
    Monday, February 25, 2008 3:20 AM

All replies

  • Hi,
     
    Error: Indicates two revision levels are incompatible.Which Version of Windows Vista you have installed on your machine,OEM or RTM?
     
    Please perform a cleanboot. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

     

    1) Run MSCONFIG.EXE. (MSCONFIG is a built-in tool for Windows XP\2003 systems.)

     

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

     

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

     

    4) Restart the computer. Does the problem still persist?

     

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

     
    Also,please reintall Windows Update Agent for Windows Vista
     
    X-86:

    X-64:
     
    After that please re-start "Windows Update" services.
    You can do that by: type "services.msc" from a command prompt and find "Windows Update"
     
     
    Hope it helps.
     

    Best regards,

    Xiu Zhang - MSFT

    Microsoft Online Community Support

     
    Monday, February 25, 2008 3:20 AM
  • Xiu, I have exactly this problem, and followed your suggestion carefully.  When reinstalling windows update with this link,

    I get the following:

     

    Windows Update Agent Installer

     Install Failed

    Install failed with following error number 
    0x8007051a

     

     Ed

    Wednesday, March 5, 2008 9:01 AM
  • Hi,
     
    Please stop "Windows Update" services, then try to reinstall Windows Update Agent from the link in my previous post.
     
    Hope it helps
     
    Xiu Zhang-MSFT
     
    Thursday, March 6, 2008 2:14 AM
  • I have the same problem.  I have tried to reinstall Windows Update Agent from the link and no luck.  Any other suggestions?

     

    Tuesday, March 11, 2008 1:27 AM
  • exactly the same! how can i solve the problem?
    • Proposed as answer by dipak1729 Wednesday, April 1, 2009 9:15 AM
    Friday, February 6, 2009 4:54 PM
  • Please check

    Locate “C:\Windows\winsxs\pending.xml“
    Take ownership of the file
    Give yourself (or a group you’re in, like Administrators) full permissions to the file
    Rename the file to something like “pending.xml.old“
    Reboot and run Windows Update
    Watch Windows Update find those updates you’ve been missing. Done

    http://vahan.com/2008/10/26/fix-for-windows-update-error-8007051a-on-vista/

    • Proposed as answer by Kobojunkie Sunday, February 7, 2010 1:23 AM
    Wednesday, April 1, 2009 9:15 AM
  • Hello dipak1729, whatever that is...
    I just wanted to tell you that I tried everything above and it did not solve the problem but when I did what you said , bingo!
    updates are loading like crazy.
    I had a little problem taking control of the "pending"file but I did and renamed it like you said and she is clicking right now.
    YOU ROCK! I have not had updates for 9 months and I think it is related to 4g ram cause that is when it started happening when i added the extra ram.
    Thanks for your time to post the answers.
    Scott
    • Proposed as answer by Kobojunkie Sunday, February 7, 2010 1:23 AM
    Friday, August 21, 2009 6:49 AM
  • Dipak1729-

    I tried this, but when i get into renaming my Pending.xml file,  it will not allow me to rename it even though I have taken ownership of the fill and given full permissions.

    It says Access Denied and that I need permission to do this.


    Do you have any solutions?  BTW...there are many other pending.xml.01c98db1ea08a260 files 

    Thanks for any help you might have.


    Monday, September 21, 2009 6:56 PM
  • Your link no longer works. Can you provide a new one?


    Thanks


    Juan 
    Monday, November 30, 2009 2:41 AM
  • For anyone having this problem, this is the fix. After searching for over 5 months, this fix worked like a charm!


    None
    Sunday, February 7, 2010 1:23 AM
  • Please check

    Locate “C:\Windows\winsxs\pending.xml“
    Take ownership of the file
    Give yourself (or a group you’re in, like Administrators) full permissions to the file
    Rename the file to something like “pending.xml.old“
    Reboot and run Windows Update
    Watch Windows Update find those updates you’ve been missing. Done

    http://vahan.com/2008/10/26/fix-for-windows-update-error-8007051a-on-vista/


    This is the fix that worked after 5 months of dealing with this problem!
    None
    Sunday, February 7, 2010 1:27 AM
  • perform a cleanboot. A Clean Boot will allow us to isolate any device drivers or programs that are loading at startup that may be causing a conflict with other device drivers or programs that are installed in your computer.

    1) Run MSCONFIG.EXE. (MSCONFIG is a built-in tool for Windows XP\2003 systems.)

    2) In the Services tab, click "Hide All Microsoft Services" and click "Disable All".

    3) In the Startup tab, click "Disable All". Click OK. (This will temporarily prevent third-party programs from running automatically during start-up.)

    4) Restart the computer. Does the problem still persist?

    If the problem does not occur, it indicates that the problem is related to one application or service we have disabled. You can use the MSCONFIG tool again to re-enable the disabled item one by one to find out the culprit.

    Also,please reintall Windows Update Agent for Windows Vista

    X-86:
    http://download.windowsupdate.com/Wi...gent30-x86.exe

    X-64:
    http://download.windowsupdate.com/Wi...gent30-x64.exe

    After that please re-start "Windows Update" services. You can do that by: type "services.msc" from a command prompt and find "Windows Update"
    For more info click here.

    Tuesday, June 22, 2010 10:50 AM
  • Dipak,

     

    Did you ever recieve an answer on how to rename this file...have tried it 50 times, and I still cannot figure it out.

     

    Thanks.

    Sunday, September 19, 2010 8:00 PM
  • After downloading X-86 a message saying fatal error was delivered.  What happened? Do you know why?

    Wednesday, October 8, 2014 8:52 PM