locked
New Exchange Server is not showing any receive connector in EMC RRS feed

  • Question

  • Today after installation of new Exchange server in our current environment, I came across a strange issue where I can only view the default and client receive connectors in powershell (EMS) and not in EMC. All the receive connectors in other exchange servers are showing perfectly fine, but for this new server only, the receive connector space is showing blank as if no connector is present at all. Even I created a new receive connector for the server, that too got created perfectly; however it is not being shown in EMC. In EMS, everything is running fine. I tried to view the receive connectors from already present servers as well, they are also not showing any connector in the receive connector space. When I tried to refresh the blank screen of receive connector space, I got below error related to Microsoft.Exchange.Data.StrongTypeFormatException. Can anyone guide me about this. I am currently running Exchange server 2010 SP3 RU16.

    Microsoft Corporation
    Microsoft® Windows® Operating System
    6.1.7600.16385
    Deserialization fails due to one SerializationException: System.Runtime.Serialization.SerializationException: The constructor to deserialize an object of type 'Microsoft.Exchange.Data.StrongTypeFormatException' was not found. ---> System.Runtime.Serialization.SerializationException: The constructor to deserialize an object of type 'Microsoft.Exchange.Data.StrongTypeFormatException' was not found.
       at System.Runtime.Serialization.ObjectManager.GetConstructor(Type t, Type[] ctorParams)
       at System.Runtime.Serialization.ObjectManager.CompleteISerializableObject(Object obj, SerializationInfo info, StreamingContext context)
       --- End of inner exception stack trace ---


    Saturday, June 3, 2017 3:17 AM

All replies

  • On what version of Windows did you install Exchange 2010 SP3 UR16?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Saturday, June 3, 2017 4:17 AM
  • Currently we have windows server 2008 R2 SP1 and the Exchange server 2010 SP3 RU16 has been installed over that only.

    The thing is that we have all other exchange server 2010 SP3 RU16 on this version only and they seem working perfectly fine. The issue happened only with particular one server and that's also with EMC where I can not see and modify the receive connectors and also getting these errors.

    Saturday, June 3, 2017 7:07 AM
  • Hi,

    Have you created a new receive connector? Does it the same issue?

    Does it still the same issue with another installing file?

    Please help to confirm that if your environment co-existence with Exchange 2013 and a hybrid configuration.

    Per my research it’s known issue or a bug when co-existence with Exchange 2013 and then when hybrid configuration wizard is initiated. It's could because 2010 doesn't understand 2013's new features.

    If so, it's recommended to use Exchange server 2013 admin tools for administration.

    Hope it helps. 


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.



    • Edited by Jason.Chao Tuesday, June 6, 2017 3:01 AM
    • Proposed as answer by Jason.Chao Saturday, June 24, 2017 3:44 PM
    Tuesday, June 6, 2017 2:38 AM