locked
System Event Log Error RRS feed

  • Question

  • I'm getting the following error in my System Event Log:
    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
    {46063B1E-BE4A-4014-8755-5B377CD462FC}
     to the user Server_Name\SQLUserID SID (S-1-5-21-2309726297-1128183303-1077692618-1002) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    I looked in the COM+ & DCOM management tool for the CLSID above & did not find it. I searched the Registry for it & found that it's associated with SQL.DTS.
    It appears to be occuring every time one of my SQL transaction logs gets backed up. The account is a standard user account, but is the account SQL Service & SQL Agent login with. I suppose my backup jobs are running with this account.
    I'd like to clear up the errors, but don't know what to grant permissions to. My SQL backups appear to be fine.

    Thanks,

    BigSam

    Sam Lowry
    Tuesday, December 29, 2009 8:20 PM

All replies

  • Hello,

     

    Thank you for your post here.

     

    Have you checked this? Please check how it works if you grant local SQL AgentUser group the local launch and Local activation permission on MSDTSServer100.

     

    SQL agent DCOM errors Event ID 10016

    https://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=422267&wa=wsignin1.0#details

     

    If you have any questions or concerns, please do not hesitate to let us know.

     

     

     

     

    Wednesday, December 30, 2009 4:07 AM
  • I am receiving the same error every 20 seconds continously in my event log as the orginal post mentions. 

    I have no idea how to grant local group launch and activation permisons on MSDTSServer100 and I don't even know if that is what is causing my problem.  How do I determine the source of the error like the original poster had done?

    Also, I don't really understand this level of technical explanation, can you put the answer to this problem in laymans terms?  Do you think it is because possibly computer was orginally setup with a different login for administrator and later I changed the account name using user management console.  I am running vista 64 home.

    Below I have quoted the entire error message:

    Thanks,
    D

    --- error message from event log ---
    The application-specific permission settings do not grant Local Activation permission for the COM Server application

    with CLSID
    {BC866CF2-5486-41F7-B46B-9AA49CF3EBB1}
     to the user March2009-PC\March2009 SID (S-1-5-21-3714278889-1450193354-2648561575-1000) from address LocalHost

    (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    - System

      - Provider

       [ Name]  Microsoft-Windows-DistributedCOM
       [ Guid]  {1B562E86-B7AA-4131-BADC-B6F3A001407E}
       [ EventSourceName]  DCOM
     
      - EventID 10016

       [ Qualifiers]  49152
     
       Version 0
     
       Level 2
     
       Task 0
     
       Opcode 0
     
       Keywords 0x80000000000000
     
      - TimeCreated

       [ SystemTime]  2010-01-11T08:15:06.000Z
     
       EventRecordID 160024
     
       Correlation
     
      - Execution

       [ ProcessID]  0
       [ ThreadID]  0
     
       Channel System
     
       Computer March2009-PC
     
      - Security

       [ UserID]  S-1-5-21-3714278889-1450193354-2648561575-1000
     

    - EventData

      param1 application-specific
      param2 Local
      param3 Activation
      param4 {BC866CF2-5486-41F7-B46B-9AA49CF3EBB1}
      param5 March2009-PC
      param6 March2009
      param7 S-1-5-21-3714278889-1450193354-2648561575-1000
      param8 LocalHost (Using LRPC)

    ---- error message end ---
    • Edited by rotaryb Tuesday, January 12, 2010 1:27 PM typo
    Tuesday, January 12, 2010 1:27 PM
  • ok, I found some answers at the following websites:

    Resolving DCOM 10016 Errors
    http://www.simonsen.bz/blog/Lists/Posts/Post.aspx?List=661fb59d-d352-4616-b9ec-ec36c73669d4&ID=55

    http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Windows%20Operating%20System&ProdVer=5.2&EvtID=10016&EvtSrc=DCOM&LCID=4105

    ------start quote-------

    Details
    Product:    Windows Operating System
    Event ID:    10016
    Source:    DCOM
    Version:    5.2
    Symbolic Name:    EVENT_COM_ACCESS_DENIED_IN_SERVER_ACTIVATION_OR_LAUNCH_PERMISSION
    Message:    

    The %1 permission settings do not grant %2 %3 permission for the COM Server application with CLSID %4 to the user %5\%6 SID (%7). This security permission can be modified using the Component Services administrative tool.

    %1 = machine-default, application-specific; %2 = local, remote; %3 = launch, activation; %4 = ; %5 = /; %6 = .
       
    Explanation

    A program, the Clsid displayed in the message, tried to start the DCOM server by using the DCOM infrastructure. Based on the security ID (SID), this user does not have the necessary permissions to start the DCOM server.
       
    User Action

    Verify that the user has the appropriate permissions to start the DCOM server.

    To assign permissions


       1. Using Regedit, navigate to the following registry value
          HKCR\Clsid\clsid value\localserver32
          The clsid value is the information displayed in the message.
       2. In the right pane, double-click Default. The Edit String dialog box is displayed. Leave this dialog box open.
       3. Click Start, and then click Control Panel.
       4. Double-click Administrative Tools, and then double-click Component Services.
       5. In the Component Services snap-in, expand Computers, expand My Computer, and double-click DCOM Config.
       6. In the right pane, locate the program by using its friendly name.
       7. Right-click the program name, and then select Properties.
       8. On the Security tab, in the Launch and Activation Permissions group box, select Customize, and then click Edit.

    Add the user to the permissions list, and give the user the appropriate permissions.

    -------end quote-------


    I'm not sure if they'll work yet but I have tried them and will see...

    -D

    Tuesday, January 12, 2010 3:38 PM