locked
Calendar requests go to all users with send as permission on the mailbox RRS feed

  • Question

  • We have a system where one user has shared their calendar so other people can update it and schedule appointments on their behalf.

    They have also allowed several users to have send-as permission on their mailbox.

    So, if we assume the user is called 'Boss' and they have given three colleagues send-as permissions and full access to their mailbox, let's call them 'UserA', 'UserB' and 'UserC'.

    UserA will go into Boss' calendar and create an appointment. To make sure Boss is aware of the appointment having been entered they will select Boss as a required attendee. This will in turn send a notification email to Boss. If UserA checks their Sent Items the notification will be there as an email from 'UserA on behalf of Boss' and with only one recipient, namely Boss.

    Now, if we move over to Boss' PC the appointment is there in the calendar. It shows there is only one required attendee, which is Boss. The notification email is there from 'UserA on behalf of Boss' with only one recipient, still Boss. The notification goes on to say that Boss does not need to respond because they organised the meeting.

    So far so good.

    However, in addition to the correct notification email there is a second one which arrived at the same time. It is from 'UserA on behalf of Boss', but it is addressed to UserB and UserC.

    Sure enough, going to UserB and UserC's computers the meeting request has gone to them - even though they are still not listed as attendees.

    This email does not appear in the Sent Items of either UserA or Boss and this seems to be the mystery. Where does that email come from? It may be a coincidence, but it seems suspicious that the users who get the email are users with Send-As permission - it may be a red herring.

    It is also interesting to note that since the second email is not actually addressed to Boss I can't see why it appears in that inbox in the first place.

    Because the email is not in the Sent Items on UserA's PC I logged out of Outlook on the Boss' PC and went into OWA so I could still see what was there. It made no difference, so I don't think the issue is client side.

    So there we go. That's what's happening. Something is generating meeting requests out of thin air and I can't see where they are coming from.

    The server is actually running SBS 2008, but the important fact is that it is Exchange 2007 SP3. The client PCs are using Outlook 2007. As it happens one of the two I tested in the above scenario was running without an Office service pack, the other was on SP2. Neither client has any rules configured.

    Any suggestions will be gratefully received. If anyone wants more information let me know and I will attempt to provide it.

    Thursday, January 27, 2011 12:49 PM

Answers

  • Hi,

    How do you configure configure delegate for the user B and User C?

    1. On the Boss's PC. open outlook, click tools->Options.

    2. In Delegates tab, If the User B and User C is in the delegates list. Please double click a user and uncheck the option "Delegate receives copies of meeting related messages sent to me."

    Then test to see if the issue persists.

    Gen Lin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    • Marked as answer by Gen Lin Thursday, February 3, 2011 2:25 AM
    Friday, January 28, 2011 9:05 AM

All replies

  • Hi,

    How do you configure configure delegate for the user B and User C?

    1. On the Boss's PC. open outlook, click tools->Options.

    2. In Delegates tab, If the User B and User C is in the delegates list. Please double click a user and uncheck the option "Delegate receives copies of meeting related messages sent to me."

    Then test to see if the issue persists.

    Gen Lin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    • Marked as answer by Gen Lin Thursday, February 3, 2011 2:25 AM
    Friday, January 28, 2011 9:05 AM
  • Hi,

    Is there any update on this problem?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    Thursday, February 3, 2011 2:25 AM
  • Sorry about that, I thought I already had marked it as the answer. My mistake.

    It was indeed the answer - simple when you know the setting is there.

    Thanks.

    Thursday, February 3, 2011 10:00 AM
  • Hi,

    Thank you for your reply. I am glad to hear that the problem is resolved.

    Gen Lin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    Friday, February 4, 2011 2:29 AM