locked
Slow response in Word 2007 SP2 when enabled with "revision mode" or "track changes". RRS feed

  • Question

  • Many users complained that slow response in Word 2007 to editing document when enabled with "revision mode" or "track changes" running on WinXP SP2. The most important is that this symptom has never been happened in previous Office version (i.e. Office 2000).

    Have they also encountered this similar symptom in their sides? Any solution to fix it? Thanks for support.

    Friday, July 9, 2010 2:16 AM

Answers

  • Hi,

     

    Thank you for using Word IT Pro Discussions forum. 

     

    From your description, I understand that when using "revision mode" or "track changes" in Word 2007 SP2 on Windows XP system, the performance is slow. If there is any misunderstanding, please feel free to let me know.

     

    Before we go further, I would like to confirm when this issue began to occur. Are there any hardware or software changes recently?

     

    First, I suggest testing this issue on problematic computer to see if the problem can be resolved.

     

    Step 1: Start the Word program in safe mode

    ==============

    1.       Click Start, point to All Programs, and then point to Microsoft Office.

    2.        Press and hold the CTRL key, and then click Microsoft Word.

     

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Word program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Word program:

     

    Disable add-ins

    ***************************

    a.      Click Tools > Options >  Add-in, click Go button in the Manage: Com-in Add.

    b.      Check if there are any add-ins, clear the checkbox to disable them.

    c.       Close the Office program and restart it.

    d.      Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.

     

    If the problem persists in the safe mode, let’s continue.

     

    Step 2: Test in Clean boot Mode

    ===============

    Let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2.        Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3.       Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This should not affect the system or other programs. We may still manually run these programs later.

     

    What’s the result now?

      

    How to return from the Clean Boot state

    --------------------------

    After the troubleshooting, we can return from the clean boot state:

     

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2.       On the "General" tab, click "Normal Startup - load all device drivers and services".

    3.       Click OK. Click Restart when you are prompted to restart your computer.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Monday, July 12, 2010 8:07 AM
    Saturday, July 10, 2010 3:27 AM

All replies

  • Hi,

     

    Thank you for using Word IT Pro Discussions forum. 

     

    From your description, I understand that when using "revision mode" or "track changes" in Word 2007 SP2 on Windows XP system, the performance is slow. If there is any misunderstanding, please feel free to let me know.

     

    Before we go further, I would like to confirm when this issue began to occur. Are there any hardware or software changes recently?

     

    First, I suggest testing this issue on problematic computer to see if the problem can be resolved.

     

    Step 1: Start the Word program in safe mode

    ==============

    1.       Click Start, point to All Programs, and then point to Microsoft Office.

    2.        Press and hold the CTRL key, and then click Microsoft Word.

     

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Word program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Word program:

     

    Disable add-ins

    ***************************

    a.      Click Tools > Options >  Add-in, click Go button in the Manage: Com-in Add.

    b.      Check if there are any add-ins, clear the checkbox to disable them.

    c.       Close the Office program and restart it.

    d.      Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.

     

    If the problem persists in the safe mode, let’s continue.

     

    Step 2: Test in Clean boot Mode

    ===============

    Let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2.        Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3.       Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This should not affect the system or other programs. We may still manually run these programs later.

     

    What’s the result now?

      

    How to return from the Clean Boot state

    --------------------------

    After the troubleshooting, we can return from the clean boot state:

     

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    2.       On the "General" tab, click "Normal Startup - load all device drivers and services".

    3.       Click OK. Click Restart when you are prompted to restart your computer.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Best Regards,

     

    Sally Tang

    • Marked as answer by Sally Tang Monday, July 12, 2010 8:07 AM
    Saturday, July 10, 2010 3:27 AM
  • Had the same issue went away after installing the rights management add on.
    • Proposed as answer by whiteycanberra Monday, February 6, 2012 12:13 AM
    Wednesday, September 22, 2010 12:28 PM
  • The root cause is Word 2007 will search the file "msdrm.dll" in system when clicking revision mode or track changes. Since the right management client has never been installed on computer, the slow response of Word 207 will be appearance. After installed right management client or copied file "msdrm.dll" to windows system folder, the symptom is solved.

    Friday, September 24, 2010 4:08 AM
  • Hi Sally, I deeply appreciate your support on this symptom.
    Friday, September 24, 2010 4:18 AM
  • Since I didn't need DRM, I ended up turning off DRM in Microsoft Office.   See the 'Disable' value here: http://technet.microsoft.com/en-us/library/dd772637%28WS.10%29.aspx

    Bryan Berns
    • Proposed as answer by E Eskam Monday, July 16, 2012 3:27 PM
    Saturday, October 16, 2010 1:36 PM