locked
The Application Virtualization Management Server service terminated with service-specific error 268480357 RRS feed

  • Question

  • Hi all,

    I have installed AppV in a virtual test environment using Sevrer 2008 and SQL 2008 Express and I am getting "Service cannot start..refer to service-specific error code 268480357". I have looked at the similar thread in the 4.5 Beta (Retried) forums (and accidently posted there!) and tried the "Answers" given in that thread. This is why my testing so far has been somewhat tailored. It goes as follows.....

    I did not use RD at any point, all installtion was done directly.

    I've checked the VAS service and it is set to run as NETWORK SERVICE, so I changed this to NT AUTHORITY\NetworkService.

    I checked the logins and there is not a login called <domain>\<VAS hostname>$ present. I added APPV\AppVServer$, gave it the public server role, mapped it to the APPVIRT database, given it SFTadmin and SFTeveryone role within the database and restarted the SQL Server service. The VAS service still fails with the same error.

    I have checked the server table and the registered server is registered with it's name only, not the FQDN.

    Either I am doing something wrong when adding roles (which wouldn't surprise me as I don't know what they should be) or someting else is wrong.

    Please, if there is one, could you provide a check list of setting to ensure all is set correct, or if that is not available, please give me some pointers as to where I am going wrong, or the installation maybe incorrect.

    Cheers,

    Matt
    Wednesday, February 10, 2010 11:01 AM

Answers

All replies

  • The Management Server log file should give you some more information to go on, i.e. it should give you a little more information than the event log. There is a Log folder under the server install folder that contains the log.
    Wednesday, February 10, 2010 1:25 PM
    Moderator

  • Thansk for replying Aaron,

    I meant to put this in, sorry. Here's the log..............

    [2010-02-09 16:09:44.904] - 3728 3480 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-09 16:10:02.513] APPVSERVER 3728 3480 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-09 16:10:02.582] APPVSERVER 3728 3480 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-09 16:10:02.583] APPVSERVER 3728 3480 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (3728)
    "
    [2010-02-09 16:10:02.607] APPVSERVER 3728 2808 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-09 16:19:55.015] - 1516 1612 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-09 16:20:14.953] APPVSERVER 1516 1612 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-09 16:20:15.046] APPVSERVER 1516 1612 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-09 16:20:15.046] APPVSERVER 1516 1612 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (1516)
    "
    [2010-02-09 16:22:58.580] APPVSERVER 1516 1520 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-09 16:27:00.872] - 3980 2984 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-09 16:27:17.894] APPVSERVER 3980 2984 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-09 16:27:17.894] APPVSERVER 3980 2984 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-09 16:27:17.896] APPVSERVER 3980 2984 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (3980)
    "
    [2010-02-09 16:27:17.909] APPVSERVER 3980 4060 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-09 16:27:44.331] - 1608 1092 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-09 16:28:00.480] APPVSERVER 1608 1092 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-09 16:28:00.481] APPVSERVER 1608 1092 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-09 16:28:00.482] APPVSERVER 1608 1092 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (1608)
    "
    [2010-02-09 16:28:00.484] APPVSERVER 1608 1412 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-10 09:33:17.750] - 1484 1568 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-10 09:33:37.229] APPVSERVER 1484 1568 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-10 09:33:37.370] APPVSERVER 1484 1568 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-10 09:33:37.372] APPVSERVER 1484 1568 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (1484)
    "
    [2010-02-10 09:36:04.269] APPVSERVER 1484 1488 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-10 09:49:33.685] - 3984 3968 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-10 09:49:50.101] APPVSERVER 3984 3968 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-10 09:49:50.102] APPVSERVER 3984 3968 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-10 09:49:50.103] APPVSERVER 3984 3968 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (3984)
    "
    [2010-02-10 09:49:50.129] APPVSERVER 3984 988 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-10 10:13:35.471] - 1300 3456 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-10 10:13:51.599] APPVSERVER 1300 3456 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-10 10:13:51.615] APPVSERVER 1300 3456 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-10 10:13:51.634] APPVSERVER 1300 3456 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (1300)
    "
    [2010-02-10 10:13:51.664] APPVSERVER 1300 3904 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-10 10:37:33.619] - 3952 2636 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-10 10:37:49.804] APPVSERVER 3952 2636 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-10 10:37:49.805] APPVSERVER 3952 2636 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-10 10:37:49.806] APPVSERVER 3952 2636 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (3952)
    "
    [2010-02-10 10:37:49.808] APPVSERVER 3952 3076 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-10 10:39:44.265] - 3560 1692 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-10 10:39:59.963] APPVSERVER 3560 1692 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-10 10:39:59.964] APPVSERVER 3560 1692 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-10 10:39:59.965] APPVSERVER 3560 1692 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (3560)
    "
    [2010-02-10 10:39:59.966] APPVSERVER 3560 2552 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-10 10:48:03.483] - 2772 3344 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-10 10:48:18.877] APPVSERVER 2772 3344 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-10 10:48:18.878] APPVSERVER 2772 3344 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-10 10:48:18.879] APPVSERVER 2772 3344 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (2772)
    "
    [2010-02-10 10:48:18.880] APPVSERVER 2772 2616 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."
    [2010-02-10 10:55:23.186] - 3724 2900 SW_MessageHandler::Open - - - - 5 65535 "Initialization complete."
    [2010-02-10 10:55:39.279] APPVSERVER 3724 2900 SW_SQLDataConnection::Open - - - - 2 41494 "Failed to establish a connection to the data source: (Server: AppVServer, Database: APPVIRT).
    "
    [2010-02-10 10:55:39.280] APPVSERVER 3724 2900 SW_SystemDispatcher::init - - - - 1 44901 "System dispatcher initialization error [-1]. System dispatcher startup will stop.
    "
    [2010-02-10 10:55:39.281] APPVSERVER 3724 2900 SW_SystemDispatcher::fini - - - - 0 44952 "Successfully shut down Microsoft System Center Application Virtualization Management Server Version 4.5.2.17140 (3724)
    "
    [2010-02-10 10:55:39.282] APPVSERVER 3724 3768 SW_MessageHandler::Close - - - - 5 65535 "Shutdown complete."


    Sorry for the long log post, but I thought I'd be through and include a large section. I've had no joy since the original post and the error has remianed the same.

    Edit: - I've also tried turning the firewall off to no effect (although I didn't think it would anyway).

    Cheers,

    Matt
    Wednesday, February 10, 2010 2:09 PM
  • Hello,

    While using google to locate more information I found an old kb-article that might offers some general advice as to what to verify;
    http://support.microsoft.com/kb/931594

    /Znack
    Wednesday, February 10, 2010 3:18 PM
  • Thanks Znack,

    I have seen this article. My windows accounts are configured correctly.

    Account Authorities doesn't show in the Application Virtualisation Management Console and I can;t seem to be able to find an equivalent.

    Cheers,

    Matt
    Wednesday, February 10, 2010 3:41 PM
  • Hi,

    make sure your firewall doesn't block SQL traffic, SQL allows TCP/IP based connection (preferable on a fixed port, like 1433) and listens on the propper Network interface.

    Also the SQL Browser service should be running. Some checkups can be found in the App-V Trail guide (http://technet.microsoft.com/en-us/appvirtualization/cc843994.aspx), SQL config section.


    I also sometimes found issues when using DBSERVER vs. DBSERVER\INSTANCE methodology.
    You could try different settings in the Registry.

    Also, try to connect with the App-V Server Management Console to the App-V System. If this works you could try the DBSERVER vs. DBSERVER\INSTANCE trick in the [Default Server Group]'s properties.




    Falko
    Wednesday, February 10, 2010 4:57 PM
    Moderator
  • Hi Falko,

    The firewall is turned off and this doesn't appear to change anything.

    The Briwser service is set to automatic and is running. I have use the guide to create my setuup. The guide use SQL 2005 Express but I'm using 2008 as that's what I thought we'd be more likely to use in production. SOmetimes I think this is where the issue lies, however I have enable TCP/IP and Named Pipes. I have also tried using dynamice ports and setiing the listen port to 1433. What I don't get is, if the installer can connect and add the database to the SQL instance, why can't the service do the same? What is the difference between what the installer is doing and what the service is doing? ALso, the installer does not automatically pick up the instance, I have to manually put in the server name and the port, but then it continues without producing any errors.

    I don't know what you mean by DBSERVER vs. DBSERVER\INSTANCE methodology or what I would need to change in the registry. I can however get the console to connect and the Default Server Group's properties have DNS Host Name = APPVSERVER (Correct) and RTSP = 554 (Correct and default).

    Cheers,

    Matt
    Thursday, February 11, 2010 9:29 AM
  • Hi,

    yea, I was a little short yesterday (without having an App-V Server on hand..)

    so:

    In the registry: HKLM\Software\Microsoft\SoftGrid\4.5\Server: SQLServername: this migh be <SQLSERVERNAME> or "SGLSERVERNAME>\<NAMEDINSTANCE>"

    In the Server MMC: There is a "Logging" tab in the Default Server Group's Properties (You seem to have found a single server's properties, but not the ones of tha entire group). In that Loggin Tab, double click the "SQL Database" entry. Als here check if the DNS host name of the SQL server is specified with or without an instance name.
    ( I tend to expect the issue here...)


    Falko


    Falko
    Thursday, February 11, 2010 4:29 PM
    Moderator
  • Hi all,

    Falko, I've not had a go at your suggestion yet for reasons that will become apparent....

    I decided to try SQL 2005 Express as an experiment and all went like a dream. The installer could see the instance and the service started first time. Great! :) I also found out that the bit in the Trial Guide where it says install IIS 7 and include .... and .... and Management Tools, actually means install IIS 7 and include .... and .... and Management Tools (including all options, even the IIS 6 compatability stuff)

    So I made a note of this and the SQL 2005 instalation options used and started again a fresh with 2008 SQL. Selecting these options in the install...

    - Database Engine Services (Only, no sub options)
    - Management Tools
    - SQL CLient Connectivity SDK


    Once installed I enable TCP/IP.

    Then I tried to install the AppV Management Console. The installer still didn't see the SQL server/instance and I couldn't even get it to work by putting in the hostname in manually as I had done before.

    So back in the SQL TCP/IP settings under the IP Addresses tab I set the TCP Port on every IP to 1433. The installer still couldn't see the instance but I could now proceed by manually putting in the Hostname.

    But....

    The installer then failed with Error 25109: Could not create the data store. So I'm guessing if the installer can't see the instance automatically, the installer will either fail or the service will fail.

    Has anyone managed to get AppV 4.5 to work with SQL 2008? If so, can you give a complete install procedure for SQL and all settings post install.

    Also, if SQL 2008 Express isn't supported, please put me out of my misery! :)


    Cheers,

    Matt
    Friday, February 12, 2010 4:48 PM
  • HI All,

    Check SQL server service first. If Management console cannot connect with DB. it will give this error.

    Thanks,

    Hiren.
    Thursday, March 11, 2010 12:39 PM
  • Same issue here

    Server 2008 x86
    SQL Server 2008 Express with Tools
    App-V Management Server cannot see DB Instance

    Tried all usually known options as well. (TCP Port etc)


    Saturday, March 13, 2010 5:06 PM
  • I think i found the issue, at least this worked for me. I worte a short blog post about it.
    http://www.verboon.info/index.php/2010/03/app-v-management-server-setup-and-sql-server-configuration/

    • Proposed as answer by znack Tuesday, March 16, 2010 5:02 AM
    • Marked as answer by Aaron.ParkerModerator Monday, December 19, 2011 12:53 PM
    Sunday, March 14, 2010 12:11 AM
  • Hi Alex,

    I tried the things you mention in your blog, but still had the same issue. I can;t find any official literature about SQL 2008 and AppV so I've stuck with SQL 2005 as this seems to just work out of the box and there is more information about it :)

     

    Cheers,

    Matt

    • Proposed as answer by znack Monday, March 22, 2010 12:21 PM
    • Marked as answer by Aaron.ParkerModerator Monday, December 19, 2011 12:53 PM
    Monday, March 22, 2010 12:20 PM