locked
Email enables Lists working but not Document Libraries RRS feed

  • Question

  • Even if if re-purpose the alias from a list that works into a document library the email never arrives in the library.

    I turned on verbose logging for email and go this.

    04/15/2011 15:19:14.27  OWSTIMER.EXE (0x294C)                    0x16B0 Windows SharePoint Services    E-Mail                         6874 Warning  An error occurred while attempting to create an attachment for an item sent via e-mail. The e-mail was sent to the list "Shared Documents", and the error was: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)). 
    04/15/2011 15:19:14.27  OWSTIMER.EXE (0x294C)                    0x16B0 Windows SharePoint Services    E-Mail                         6874 Warning  An error occurred while attempting to create an attachment for an item sent via e-mail. The e-mail was sent to the list "Shared Documents", and the error was: Object reference not set to an instance of an object.. 

    I have full control to the entire site being the farm admin and the site collection admin so the access denied message should not occurr.

    For my entire farm I don't know of a single email enabled document library that is working while at the same time it appears that all of the email enables lists are working with no problems.

    Has anyone seen this before?  Any ideas?

    Thanks much

    Friday, April 15, 2011 7:44 PM

Answers

  • Okay I figured out the problem but it makes absolutely no sense to me why!

    In order to prepare for upgrading to SP2010 we have locked a few things down in the SP farm, including unchecking the "Manage Permissions" checkbox in Central Admin - Application Management - User Permissions for Web Application.  We did this because we need better control over what users have "Full Control" of the sites.  Leaving this option turn on allows users with Full Control to give other users Full Control.

    After turning this option back on the emails went through to the document library.  So why Manage Permissions needs to be on for an item to be added to a document library is beyond me????  Adding something to a library (whether through email or directly) is an Add Items right and NOT a Manage Permissions right.

    Thanks for the help but I am not happy with the solution.

    • Marked as answer by rcwynn Tuesday, April 19, 2011 2:06 PM
    Tuesday, April 19, 2011 2:06 PM

All replies

  • Hi rcwynn,

    If you are running SharePoint and other applications on different servers, or you are using Microsoft Forefront Security for SharePoint to scan e-mail messages for unsolicited commercial email, you may experience this error. This is because FSCRealtimeScanner.exe (It is a process in Forefront Security for SharePoint runs under the Network Service account) does not have access to the SPSTimer service. Please try the solution in KB934285. This solution contains the step to modify the registry. Please do a backup the registry before you modify it.

    Thanks & Regards,
    Emir


    Monday, April 18, 2011 7:41 AM
  • We are not using Forefront Security and do not have other applications running on the SharePoint Server.  We have a 2 server farm, WFE and SQL Server database.  Any other idead on what would cause this issue?

    Thanks.

    Monday, April 18, 2011 1:53 PM
  • Hi rcwynn,

    Thanks for your reply.

    Please modify the permission for the alias you typed in E-mail address to have full control in that document library or please enable Accept e-mail messages from any sender option in Incoming E-Mail Settings. Have you modified permission of the SMTP drop folder?

    If the problem persisted, please check your ULS log, can you find any error there?

    Best regards,
    Emir

    Tuesday, April 19, 2011 10:09 AM
  • Okay I figured out the problem but it makes absolutely no sense to me why!

    In order to prepare for upgrading to SP2010 we have locked a few things down in the SP farm, including unchecking the "Manage Permissions" checkbox in Central Admin - Application Management - User Permissions for Web Application.  We did this because we need better control over what users have "Full Control" of the sites.  Leaving this option turn on allows users with Full Control to give other users Full Control.

    After turning this option back on the emails went through to the document library.  So why Manage Permissions needs to be on for an item to be added to a document library is beyond me????  Adding something to a library (whether through email or directly) is an Add Items right and NOT a Manage Permissions right.

    Thanks for the help but I am not happy with the solution.

    • Marked as answer by rcwynn Tuesday, April 19, 2011 2:06 PM
    Tuesday, April 19, 2011 2:06 PM