none
Exchange account and account with custom MAPI provider in same profile

    Question

  • Dear all,

    we have a scenario where there are two mail servers for different domains running on different e-mail platforms. One is an Exchange 2016 server, the other one is a Kerio Connect server. Now some of my users have e-mail addresses on both servers and want to use them together in their one Outlook instance and, of course, the same profile - so they have, for example, all their calendars from both servers in one view.

    Kerio Connect provides a software called Kerio Outlook Connector which is basically a custom MAPI provider plugin for Outlook, while connection to the Exchange server is established the standard way of autodiscover which supplies Outlook Anywhere or MAPI/HTTP.

    Now when I set up both a Kerio and an Exchange account in the same Outlook profile, it basically works, but there are some issues which I have already described in this thread at Kerio's support forums:

    http://forums.kerio.com/mv/msg/30849/133437/#msg_133437

    While this may not be a supported scenario at all for Outlook, I'd be thankful for any hint that helps me making it work nonetheless.

    For example, does Outlook for Windows support EWS? Could I set up the Kerio account as EWS account in Windows Outlook, not using the Kerio MAPI provider plugin at all? I already tried to set it up via ActiveSync, which basically worked regarding the problems I had before, but EAS really is optimized for mobile devices - many mails with attachments don't get synced, shared or public calendars are a problem (getting reminders from all subscribed calendars all of sudden because ActiveSync doesn't make a real difference between "own" and "other" calendars), and so on..

    Or is there any other way I can configure Outlook to respect the separation of the two accounts - in terms of transport providers, Free/Busy queries and so on?

    Kind regards
    Nico

    Friday, March 31, 2017 11:16 AM

All replies

  • Hi Nico,

    Please understand that I have no Kerio Connect server account to do a test in Outlook client to reproduce your issue. I am not familiar with the connection and account working for the Kerio account.

    Generally, if there are two accounts configured in Outlook, the incoming and outgoing emails should not be mixed to just one account. They should be sent to the corresponding account respectively.

    In your Outlook, go to File > Account Settings > Account Settings, in E-mail tab, which is the default account? Please switch another account as the default account to have a try. Go to Data Files tab, set the corresponding data file as default. If possible, please provide a screenshot about the Email tab and Data files tab here for more information (notice to mosaic your email address).

    Additionally, please go to File > Options > Add-ins, select Manage COM Add-ins, uncheck to disable other third-party add-ins, restart Outlook to have a try.


    Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 3, 2017 7:16 AM
    Moderator
  • In addition, it is recommended to complete your whole issue here such as the incorrect Reply-address issue here for better understanding.

    Then other partners who read this thread would know more complete about your issue and give more suggestions :)


    Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 3, 2017 7:19 AM
    Moderator
  • Dear Winnie,

    first of all, thanks for your reply, and sorry for not posting all relevant parameters of the issue here. :-)

    To sum the issue up: When I have an Exchange and a Custom MAPI provider account together in the same Outlook profile, unintuitive things happen.

    Let's say, my profiles are for e-mail addresses within the domains exchangedomain.com and mapidomain.net.

    When I send an e-mail from my mapidomain.net account to two e-mail addresses, john@exchangedomain.com and jane@mapidomain.net, Outlook appears to send 2 e-mails (according to the status bar). It appears that it wants to "split" the sending process: For the recipients in mapidomain.net via the corresponding account, and for the ones in exchangedomain.com accordingly.

    This leads to an error message in my exchangedomain.com account because it still appears to send with my mapidomain.net e-mail address which is, of course, not allowed to send mails via this domain/account. The error message is a standard:

    Diese Nachricht konnte nicht gesendet werden. Versuchen Sie es später erneut, oder wenden Sie sich an den Netzwerkadministrator. Sie besitzen nicht die Berechtigung, die Nachricht im Auftrag des angegebenen Benutzers zu senden. Fehler: [0x80070005-0x0004dc-0x000524].

    So to Outlook/Exchange, it looks like a delegation issue (of course, me@mapidomain.net doesn't have rights to send on behalf of me@exchangedomain.com and this isn't wanted at all anyway), but the real issue for me is the fact that Outlook tries to be "intelligent" about the transport provider and determine it by the recipient addresses, whereas I just want it to send the entire e-mail without any interference over the account that I chose in the "From:" setting.

    I also tried playing around with the default account/pst file settings. In some constellation (which I couldn't reproduce later on) it worked for new e-mails, but if I Reply-All to a message that has both exchangedomain.com and mapidomain.net recipients, and I am in my mapidomain.net account, strange things happen again, like the delegation error above.

    Interestingly enough, it doesn't happen the other way round - when I send or reply to a "mixed-recipient" mail from the exchangedomain.com account, it just gets sent out via the exchangedomain.com account and then the Exchange mailserver handles correct delivery (so just as I expect it to be by default).

    Is there any way to force Outlook not to try to determine the transport provider by recipient addresses, but "blindly" sent through the account that's set in the "From:" field?

    Kind regards
    Nico

    Tuesday, April 4, 2017 2:45 PM
  • As for another interesting phenomenon: Sometimes, mails from the MAPI account are sent through the Exchange server absolutely randomly, including being sent from the wrong e-mail address. The From: field shows the MAPI account (given I am currently in one of the folders in the account and just click the "New E-mail" button), the signature is the MAPI account's by default, and I send an e-mail to an external domain, so actually there should be no "Oh, there's an exchangedomain.com recipient, let's split the mail delivery" logic. If I send an e-mail to the exact same recipient 5 minutes later again, it gets delivered normally, i.e. through the MAPI account.

    So I'm quite positive that this is not a contact lookup issue (I heard that Outlook tries to determine the transport provider through the contacts in the address books, among others)..it's just absolutely random, probably a 1-out-of-30 chance of the mail being delivered through the wrong account, as far as my observations go. This goes both for Outlook 2010 and 2013.

    Wednesday, July 5, 2017 9:15 AM
  • Migrate Kerio Connect to Exchange with third party application software. The software provides direct IMAP option to move all Kerio Connect email to Exchange server. With this software, you can directly convert Kerio to PST export in Outlook versions. The software provides various saving options to save Kerio to Outlook, Zimbra, Thunderbird, Windows Live Mail, etc. formats.
    Friday, July 13, 2018 12:19 PM