locked
Windows 7 deployment error -2147023589 RRS feed

  • Question

  • Hi, I did the following:

    1. Integration of updates into win 7 pro with sp1 x86 installation and creation of .iso image file
    2. Creation of new deployment share in MDT 2012 update 1
    3. Import of win 7 pro with sp1 x86 (with integrated updates) into deployment share
    4. Creation of Task Sequence for deployment of that image
    5. Customization of customsettings.ini and bootstrap.ini files to achieve completely silent installation
    6. Editing of unattended.xml answer file (among other things new local admin user is going to be created)
    7. Updating of deployment share
    8. Creating of media
    9. Updating of media
    10. Burning .iso file to dvd
    11. Installing a brand new virtual machine from .iso file

    Silent installation went flawlessly (I only got a screen to choose media file (x86 or x64)), at the end I got a screen to choose user to log on with (administrator or new local admin user). I used the second one and as last step of installation I received the following information:

     

    LiteTouch deployment failed, Return Code = -2147023589 0x8007051B

    I have found on net that this return code means:

    This security ID may not be assigned as the owner of this object. 

    This is too generic, does anyone have experience with this error code? Thanks in advance.

    Friday, July 25, 2014 6:09 AM

Answers

  • The local MDT Administrator account is required in MDT Litetouch to complete installation during the State Restore phase. Modification of the default Administrator accounts in the unattend.xml file is not supported.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Monday, July 28, 2014 5:08 PM

All replies

  • If I log on with built-in administrator account there is no error. The same error occurs when I disable built-in administrator account in WSIM. I do not why I have an option to log on with this account since it should be disabled by default. It seems that installation always uses this account thus logging on with other local admin account at the end of installation causes an error. I am confused to be honest.
    • Edited by BoxiKG Friday, July 25, 2014 12:23 PM
    Friday, July 25, 2014 12:22 PM
  • The local MDT Administrator account is required in MDT Litetouch to complete installation during the State Restore phase. Modification of the default Administrator accounts in the unattend.xml file is not supported.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Monday, July 28, 2014 5:08 PM
  • So at the end of LiteTouch deployment administrator account is always enabled. What is your advice? I want to "simulate" manual installation - to have administrator account disabled and to have an option to log on as new local administrator account created during installation without any errors. Post install script to disable administrator account or to leave everything as it is and disable that account later?



    • Edited by BoxiKG Tuesday, July 29, 2014 6:12 AM
    Tuesday, July 29, 2014 6:09 AM