none
Prohibit the connection from Project Professional to Project Server RRS feed

  • Question

  • Good morning everyone,

    I have a project management class with a lot of students, so we have several groups with different projects.I want the project’s manager can only see their project only, not other groups' project. I can prohibit the viewing, and accessing permission for my students in project web access, but if the PM using this function

    http://i.imgur.com/ItweY.jpg
    “Retrieve the list of all projects from Project Server”, they can access other groups' project. How can I prohibit, restrict this function?

    thanks you so much and have a blessed holiday.

    Sunday, November 25, 2012 2:37 AM

Answers

  • Hi PhuHa,

    The topic we are talking about are existing feature of the tool.

    You need to check the project section in you project manager's category. I can guess that you are using custom category for project manager.

    Ok, Open PWA through PWA administrator rights;

    1. Go to the server settings,

    2. Click on the "Manage Category" in the security section

    3. Now select project manager category

    4. Select the second (Only the projects indicated) radio button in the "projects" section

    5. Remove all the projects from Selected projects list

    6. Check the first checkbox "The User is the Project Owner or the User is the Status Manager on assignments within that Project"

    7. Save the Project manager category.

    Now you can check the projects in the project professional through your PM. I am sure now you can only see users own projects.

    Note: Make sure that your user is only member of your project manager group, and as Ben said clear the active cache also. Hope this will help you with clear picture, keep posted for clarification.

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com

    Tuesday, November 27, 2012 3:15 PM
  • Hi PhuHa,

    the PMs are probably members of multiple groups.  Just add them to the single group (project managers), and make sure they are not members of any other groups.  for an overview of how permissions work, please check out http://www.applepark.co.uk/project-server-security-explained/ 

    In terms of where can you clear the cache, I suggest you use Bing to search for adding a command to the ribbon/quick start menu.  The specifics you need in this instance is the command name, CleanUp Cache.



    Ben Howard [MVP] blog | web

    Tuesday, November 27, 2012 7:53 PM
    Moderator

All replies

  • Hi PhuHa,

    You need to use "Project Manager" Group for your Project manager roles, this default group can see only their projects in the project center.

    Else you can create custom Category and groups. In the category select the first checkbox "The user is the Project Owner or the User is the Status Manager on assignments within that Project" and in the group assign the project manager security template for the permission.

    Hope this will help you, and let us know if you require any clarification.

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com

    Sunday, November 25, 2012 11:02 AM
  • Thanks Avinash,

    I can restrict the access in the web interface except the connection from Project Professional 2010 (application) to Project Server. If you open the image link that I post, you will understand.

    Monday, November 26, 2012 3:13 AM
  • Hi PhuHa,

    As am in client place, so i can not check your given link, please explain me on text.

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com

    Monday, November 26, 2012 7:02 AM
  • Hi, 

    You cannot disable the function "retrieve the list of all projects from project server", but then this name is a bit misleading, it should say "retreive the list of all projects from project server that you have the right to see".  

    As Avinash says, and you appear to have accomplished, changing the category's or permissions will restrict what a PM can open.  If the PM has already opened a project, then the project will remain in the active cache, until you manually clear the cache.


    Ben Howard [MVP] blog | web

    Monday, November 26, 2012 7:25 AM
    Moderator
  • Hi Ben,

    What kind of cache that I should clear? the cache of the server or the cache on each PM's computer? 

    @Avinash: ok, here the situation. I got one project server with multiple projects. Each PM had their own project, and they can only see their project only if they login to PWA. BUT, if they use their Project Professional 2010, click on FILE - Open - Enterprise Projects - and choose

    "Retrieve the list of all projects from Project Server"

    then They will be able to access other groups project, that is the scenario that I don't want it happen, but actually it happened already. So now how can i stop it? as Ben said, I should clear the cache, but which cache? and FYI, I created a new project, with new PM, and did not even log in to PWA yet, but this account still be able to access the other groups project.

    Monday, November 26, 2012 10:50 PM
  • Hi, it is the active cache.  you will need to add the command "cleanup cache" to either the quickstart or ribbon in order to use it.  

    Ben Howard [MVP] blog | web

    Monday, November 26, 2012 10:56 PM
    Moderator
  • Hi PhuHa,

    The topic we are talking about are existing feature of the tool.

    You need to check the project section in you project manager's category. I can guess that you are using custom category for project manager.

    Ok, Open PWA through PWA administrator rights;

    1. Go to the server settings,

    2. Click on the "Manage Category" in the security section

    3. Now select project manager category

    4. Select the second (Only the projects indicated) radio button in the "projects" section

    5. Remove all the projects from Selected projects list

    6. Check the first checkbox "The User is the Project Owner or the User is the Status Manager on assignments within that Project"

    7. Save the Project manager category.

    Now you can check the projects in the project professional through your PM. I am sure now you can only see users own projects.

    Note: Make sure that your user is only member of your project manager group, and as Ben said clear the active cache also. Hope this will help you with clear picture, keep posted for clarification.

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com

    Tuesday, November 27, 2012 3:15 PM
  • The check box that you told me to follow:

    "The User is the Project Owner or the User is the Status Manager on assignments within that Project"

    is already checked in the "Manage Categories - My projects" section.

    For example:

    Peter still be able to see, access Ethan, Leah's project through Project Professional. I tried to clear cache on Peter's personal computer too, but no use.

    Ben:

    Where can I find the clear active cache as you mentioned above?

    Thanks you so much Avinash and Ben, I really need to fix this problem as soon as possible.

    Tuesday, November 27, 2012 7:43 PM
  • Hi PhuHa,

    the PMs are probably members of multiple groups.  Just add them to the single group (project managers), and make sure they are not members of any other groups.  for an overview of how permissions work, please check out http://www.applepark.co.uk/project-server-security-explained/ 

    In terms of where can you clear the cache, I suggest you use Bing to search for adding a command to the ribbon/quick start menu.  The specifics you need in this instance is the command name, CleanUp Cache.



    Ben Howard [MVP] blog | web

    Tuesday, November 27, 2012 7:53 PM
    Moderator
  • I tried to remove Peter from all groups, and added him to project manager group only. After that, I logged in as him to PWA, and tried to open other group's project from Project Professional, and successful. :)) (For the cleanup cache function, I set it up for the Project Professional already).

    Wednesday, November 28, 2012 12:33 AM
  • Is your problem solved??

    edit peter in "Manage User" and in the Group section remove all the groups from the user then add only Project Manager group, there may be one more possibility that your project manager group (MyProjects) having multiple category, so make sure project manager group should have only My Project category assigned.

    Hope we are trying for the last. All the best. :)

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com


    Wednesday, November 28, 2012 3:18 AM
  • did as your instruction but the problem still exists. :(
    Wednesday, November 28, 2012 8:58 PM
  • Now I'm confused - it worked, then it doesn't work...  I think perhaps you have exhausted my troubleshooting on this forum!

    Ben Howard [MVP] blog | web

    Wednesday, November 28, 2012 11:29 PM
    Moderator
  • Hi PhuHa,

    Can you please re-explain your question more specific? I think we are in wrong track some ware.

    OR to understand details about Project server security you can use below link of technet and Ben Haward blog, where Ben Howard[MVP] sir explained very well about it:

    Technet:http://technet.microsoft.com/en-us/library/cc197354.aspx

    Blog:http://www.applepark.co.uk/project-server-security-explained/

    Regards,


    Avinash kumar | e2eProjects Pvt. Ltd | Blog:http://om-avinash.blogspot.com



    Thursday, November 29, 2012 4:01 AM
  • I'm terribly sorry for my problem in explanation and made you confused. Let me explain one more time:

    Peter is the PM for project A. He should only be able to access project A only through Project Web Access and Project Professional. The same for Diane for Project B.

    But I just discovered that, Peter and Diane can access project C,D, E... from all other groups through Project Professional function:

    "Retrieve the list of all projects from Project Server"

    So how can I stop them from access other groups information? I tried to remove Diane and and Peter from  every group and category, after that added them back to Project manager group only with my project category, but no use.

    Thanks you for your time and kindness.

    Thursday, November 29, 2012 6:40 PM