locked
Losing sound in Vista Business RRS feed

  • Question

  • I have installed WinVista Business and everything seem to work OK, except for the sound.

    If I play a file (audio or video+audio) the sound is OK, but if I pause that file and resume after 30 seconds the sound is lost.

    After that if i go to "Playback devices" / "Configure" and select another configuration (the active configuration is "Stereo" and if i change that to "Mono" or another) i get a warning dialog:

    ---------------------------
    Device In Use
    ---------------------------
    The device is being used by another application. If you continue, that application may stop working.
    Do you want to continue?
    ---------------------------
    Yes No
    ---------------------------

    If I select "Yes" and press "Test" button the sound is back, and the player has sound again.

    I tested with WMP 11 and Media Player Classic and got same result: after a pause the sound is lost; i don't think it's a player problem.

    The sound was fine in XP and never got any problem with it.

    My motherboard is Asus P4S800, with integrated audio (SoundMAX Integrated Digital Audio). After installation Vista connected to internet and downloaded the drivers for sound.

    How can i correct this problem so i don't loose sound after pausing a file?

    Saturday, April 28, 2007 11:52 AM

All replies

  • Any idea? Anybody?
    Sunday, April 29, 2007 10:39 AM
  • Same problem here. Different sound hardware. Vista bug?
    Monday, April 30, 2007 5:28 PM
  • I have the identical problem in Vista Ultimate.  It has to be Vista given that it streams audio from the Internet without the same disruption.  Has anyone gotten any feedback yet?
    Monday, May 7, 2007 10:35 PM
  • hi Cornel,

     

    I tried what you said, but could not see this issue. I tested it on some different machines, one of them has Soundmax integrated digital device. Does this issue occurs consistantly (50% of the time, or 100%)? Does it happen with other applications, say, realplayer plays a .rm file?

    Tuesday, May 8, 2007 10:02 PM
  • Hello Eric,

      I hope you haven't lost interest in this issue.  I've been having the same problem.  I have the same symptoms Cornel described and I am also using the SoundMax Integrated Audio on an Intel D865Perl mobo.  This issue started occuring when I upgraded from Windows2000.  This issue occurs 100% of the time.  I tried to recreate the problem from another application as you suggested.  In this instance, the WMP was playing an MP3 song.  I paused the song.  I opened up LimeWire and used the built-in player from LimeWire to attempt to play a song.  The sound cuts out.  I never hear a note.  I go back into WMP to try to continue the song it was playing.  It is mute.   
      One thing I've noticed once in awhile is that when the MP3's no longer play, I can still hear a Windows System Beep or tone. 

    Also, there is another thread on this same issue (no one from MSFT has responded yet).  It is titled "can't play any sound, sound just stops working and cannot play files".  Its in the Vista Hardware forum, also.  Any help you can provide is appreciated.  Thanks, 

    Jay

    Tuesday, July 24, 2007 4:45 AM
  • Exactly the same problem D865 Perl Motherboard.  Sound quits - which for some reason also locks up videos.  Usually logoff fixes - but fiddling with the sound control will also sometuimes do it.  Just poke around under Souds -> playback - Spakers -> Advanced -> uncheck allow applications to take exclusive control of this device - we'll see if it helps

     

    tsnyder(a--t)xantrion.com

     

     

     

    Monday, August 20, 2007 7:26 AM
  • I am using Vista Ultimate and every so often I loose output on the Mic, otherwise the sound works.  The only 'fix' I have found (and its not a real fix) is to reboot.

    Anyone else with this problem?
    Monday, September 3, 2007 10:34 PM
  • Morning folks.

     

    OK, I am, or had the same issue when trying to play anything from Media Play to iTunes.  Yes, the only solution I saw was to restart the computer when my sound was lost after 30 seconds or so.  However, the quick and simple fix I found, move the volume slider up and down and wait for the “ding” to occur; mine is up about ¾ of the way.  This “appears” to have corrected the issue.  Granted, we all know it’s a VISTA bug here, but adjusting the volume is quicker then restarting one’s system. 

     

    I have the following:  Home built Shuttle X running VISTA Business with a NVIDIA nForce sound card built on the motherboard. 

     

    Thank you.

     

    Saturday, September 8, 2007 11:41 AM
  •  

     

    ok - same exact issue w/d865 PERL motherboard w/Ultimate.  Anyway - workaround #1: goto control panel -> sound and select your audio device; select configure button (it should enable once you select the sound device); change the sound field from current to something else (i.e. mono to stereo) and you should get the message "The device is being used by another application...".  Click Yes.  This seems to unlock whatever is hanging.  Granted - This is very similar to Cornel's workaround but might be a further clue...

     

    Monday, December 10, 2007 9:38 PM
  • Same problem here...Vista Ultimate. Intel D865PERL motherbodard integrated sound.

    Tuesday, January 1, 2008 8:39 PM
  •  

    Ok after a year of frustration I fixed this once and for all.

     

    - Purchase a cheap PCI Creative Soundblaster card and install it.  In my case a SoundBlaster X-FI model SB0790 at a CompUSA going out of business sale.

     

    - Disable the intel sound card in device manager

     

    So worth it, happiness, joy supreme, can stop, start, move forward and backwards in videos with impunity.  No more restarting, log on log off, adjust sound - reinstall sound card etc.  Blach.  Oh my god best money I ever spent.

     

    Of course now XP SP3 is coming out which everyone says rocks so maybe I will roll back still.  Boy was Vista an awful release, not as bad as ME but still, ugh.

     

    Tom Snyder

    tpsnyder (at) xantrion.com

     

     

    Tuesday, January 1, 2008 8:45 PM
  • Nice to hear you solve the problem, Tom.

    I'm considering the same option myself. But, would like to have a solution without having to buy more hardware.

     

     

    Tuesday, January 1, 2008 10:54 PM
  • If you get tired of waiting for Microsoft or Intel to solve the problem you can get a

     

    Creative Sound Blaster 16 PCI - sound card

    Product ID
    CDW Part:   715803
    Mfg. Part:   3000473000003
    UNSPSC:   43201502

     

    For $22 at CDW. 

     

     

    Tuesday, January 1, 2008 11:02 PM
  •  

    OK, so I read about this in another forum and it's proved to work (for me).  I had to rollback to a previous audio driver.  My particular driver is for SoundMAX Integrated Digital Audio.  The "rollback driver" option was not available under the audio's "driver" tab.  I had to download an old driver, uninstall the current driver, restart and then install the driver that I had downloaded.  My current driver is version "5.12.1.3665" (the working one).  For those of you with the SoundMAX audio this should work.  For everyone else, replacing your driver might be worth a shot.  I don't recommend trying this unless you're fairly competent with computers.  If you uninstall a driver and can't install a new one, you WILL HAVE NO SOUND until you do.  Also, Windows Update will provide you with an optional audio driver update.  If you download this update the SAME SYMPTOMS WILL RETURN.  Hope this helps -

    Jay

    Tuesday, January 8, 2008 2:09 AM
  •  

    The only way to solve this and all others vista bugs is to install XP or a better OS.
    Saturday, March 15, 2008 7:17 PM
  • I'm angry at Microsoft for this piece of ***. I paid good money for Vista Ultimate, and it turned out to be an Ultimate waste of money. I'm having the same sound issue, and I don't think I should have to do any fancy footwork or purchase new hardware to make such an expensive piece of software work. The original post was placed in 2007, and it is a reoccurring problem across many users of different versions of Vista, so why haven't any of these "brilliant" Microsoft programmers updated Vista with this bug fix? What good is an operating system that can't even manage simple drivers that its predecessor had no trouble with? 

     

    Sunday, May 4, 2008 1:39 AM