locked
HTML scripting shows up on all forms in our WSS 3.0 RRS feed

  • Question

  • When using a team site discussion, I click on the dicussion topic.  This opens the dicussion topic and I can see the reply button.  I click on the reply button.  All I see is the HTML script and the message.

    When I go to a custom list on a different team site, I look at an item that is displayed in a form.  When I click on edit all the fields display the HTML code.

    When I click on Site Actions, Edit page, Click on Modify this web part (content editor), Click on the Rich Text Editoron the right hand side, I get "An error has occurred in the script on this page.  Line: 1056; Char:2 Error: 'body' is null or not an object  Code: 0  URL: ......  Do you want to continue running scripts on this page?"  It doesn't matter what team site or page I got to I get the same thing. 

    I am the SharePoint Admin.  This seems to be only happening on my box.  I'm using Windows 7 on my box and we are running WSS 3.0.  Somewhere I saw something about a script that needed to be ran on the server side to stop this.  I can't seem to find anything.

    I have tried using a different browser other than IE, I have restarted my box.  To make things worse it doesn't always happen.

    Do I need to look for an error on the server or just on my box?  So confused.

     


    Sandy
    • Moved by Mike Walsh FIN Thursday, June 23, 2011 8:03 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Wednesday, June 22, 2011 8:16 PM

Answers

  • Hi Sandy,

    Try to mark the compatibility option under the browser: Tools->Compatibility View Settings.

    If it still persists, would you please provide more information about that:

    1.      Which version of your IE being used?

    2.      Do you have any custom master pages in your site? If have, check if the page has the tag <meta http-equiv="X-UA-Compatible" content="IE=7">, this meta tag will force a page to render in IE 7 mode, this tag should be added to custom master page if they are be rendered in IE 8.

    Could I confirm with you about your saying “using a different browser other than IE,… To make things worse it doesn't always happen”? Does this happen using one Browser but not happen using another Browser or it doesn’t always happen in one browser?


    Xue-Mei Chang
    Friday, June 24, 2011 9:44 AM
    Moderator

All replies

  • Hi Sandy,

    Try to mark the compatibility option under the browser: Tools->Compatibility View Settings.

    If it still persists, would you please provide more information about that:

    1.      Which version of your IE being used?

    2.      Do you have any custom master pages in your site? If have, check if the page has the tag <meta http-equiv="X-UA-Compatible" content="IE=7">, this meta tag will force a page to render in IE 7 mode, this tag should be added to custom master page if they are be rendered in IE 8.

    Could I confirm with you about your saying “using a different browser other than IE,… To make things worse it doesn't always happen”? Does this happen using one Browser but not happen using another Browser or it doesn’t always happen in one browser?


    Xue-Mei Chang
    Friday, June 24, 2011 9:44 AM
    Moderator
  • My orginial questions...

    http://social.technet.microsoft.com/Forums/en-US/sharepointadmin/thread/5a693117-d743-478a-a461-0ea1a7d9e5e6

    When using a team site discussion, I click on the dicussion topic. This opens the dicussion topic and I can see the reply button. I click on the reply button. All I see is the HTML script and the message.

    When I go to a custom list on a different team site, I look at an item that is displayed in a form. When I click on edit all the fields display the HTML code.

    When I click on Site Actions, Edit page, Click on Modify this web part (content editor), Click on the Rich Text Editoron the right hand side, I get "An error has occurred in the script on this page. Line: 1056; Char:2 Error: 'body' is null or not an object Code: 0 URL: ...... Do you want to continue running scripts on this page?" It doesn't matter what team site or page I got to I get the same thing.

    I am the SharePoint Admin. This seems to be only happening on my box. I'm using Windows 7 on my box and we are running WSS 3.0. Somewhere I saw something about a script that needed to be ran on the server side to stop this. I can't seem to find anything.

    I have tried using a different browser other than IE, I have restarted my box. To make things worse it doesn't always happen.

    Do I need to look for an error on the server or just on my box? So confused.

    --------------------------

    My one and only reply from Xue-Mei Chang

    Hi Sandy,

    Try to mark the compatibility option under the browser: Tools->Compatibility View Settings.

    If it still persists, would you please provide more information about that:

    1. Which version of your IE being used?

    2. Do you have any custom master pages in your site? If have, check if the page has the tag <meta http-equiv="X-UA-Compatible" content="IE=7">, this meta tag will force a page to render in IE 7 mode, this tag should be added to custom master page if they are be rendered in IE 8.

    Could I confirm with you about your saying “using a different browser other than IE,… To make things worse it doesn't always happen”? Does this happen using one Browser but not happen using another Browser or it doesn’t always happen in one browser?


    Xue-Mei Chang

    ------------------------------------------

    I'm still having this issue.  I tried the Compatiablity and it still does the same thing.  I have tired turn on off the Internet Options hunting for a setting.  I'm using IE 9.038112.16421 64-bit Edition, Update Versions: 9.01 (KB2530548) Cipher Strength: 256 bit, Product ID: 03553-007-1385882-86825

    I tried Chrome and it did the same thing but it isn't Microsoft product.

    This is a SharePoint Intranet site and we have only one site collection.  All changes have been made with MS Designer 2007.  There is no references as mentioned. 

    Xue-Mei Chang if you could respond back that would be great.  Sorry it took so long for me to get back to you.

    I am the SharePoint Administrator and I have a back up Admin that can edit the content editor but I can't.  We are both running Windows 7, we both have Office 2010, He is not running designer but I am, and we have the exact same version of IE. 

    This is very frustrating because sometimes it works but not all day. 

    I have been searching for an answer and can't find it.


    Sandy
    • Merged by Mike Walsh FIN Saturday, July 23, 2011 5:57 AM identical question. Quotes virtually all of the original thread
    Friday, July 22, 2011 8:59 PM