none
Isolated network without internet access - how do I make the yellow "no internet access" icon go away?

    Question

  • Hello,

    I have a large closed network that I am working with and we are beginning to roll out Windows 7 Professional on the desktop.   In our test environment we saw the "No internet access" yellow triangle in the system tray, but didn't think it was a problem because we knew we weren't connected.

    Now that we are fielding it, we are getting calls from people asking why they are getting this message in their system tray.   It has been brought up to just hide that icon, but I'm looking for something more elegant.  I read through these forums and took a look at:

    How to Mange the Network Connectivity Status Indicator
    http://www.anitkb.com/2010/12/how-to-mange-network-connectivity.html

    Which was suggested by JM, but it does not work.  The yellow icon is still there.  Is there some other way to make that notification disappear?  I realize it is just stating the obvious, that there is no internet connection, but I'd like to reduce these phone calls.

    Any help would be appreciated.

    V/R

    --Jeff

    Wednesday, September 21, 2011 3:38 PM

Answers

  • After studying the behaviour in more detail, I would recommend that both of these GPO settings be applied to ensure that Vista and later are covered.

    • Turn Off Windows Network Connectivity Status Indicator Active Tests [Enable]
    • Do not show the "local access only" network icon [Enable]

    I completed re-testing this in two labs and validated the results. 

    I hope this helps you Jeff.

     

     


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    • Marked as answer by Protholl Thursday, September 22, 2011 7:10 PM
    Thursday, September 22, 2011 2:32 PM

All replies

  • Sir, if you want to disappear the Notifications , you must hide the Network icon By Customize it .

     

     

     

     

    Regards


    MCP | MCTS | MCITP
    Wednesday, September 21, 2011 4:45 PM
  • Jeff- I have re-read my blog posting.  I made an update to the information.  The registry edit that I posted is for Windows Vista.  The group policy method is intended for Windows 7.

    Did you try the GPO method?


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    Wednesday, September 21, 2011 5:53 PM
  • Sir, if you want to disappear the Notifications , you must hide the Network icon By Customize it .

     

     

     

     

    Regards


    MCP | MCTS | MCITP

    Hello,

    As I stated before:

    It has been brought up to just hide that icon, but I'm looking for something more elegant. 

    So far I have thought about using internal DNS to fool this utility into visiting one of my controlled internal web servers, then create that text file that it is looking for but that isn't flying with management at this time.

    V/R

    --Jeff
     

    Wednesday, September 21, 2011 5:56 PM
  • JM,

    I did try both the registry key and the GPO, one after another, but on the same computer so both the regedit and GPO fix are in place.  I will go remove the regedit hack and reboot to see if it works.

    Thanks,

    --Jeff

    Wednesday, September 21, 2011 5:59 PM
  • JM,

    I removed the registry key but left the local GPO in place and rebooted.  I ran a resultant set of policy against that system and verified the GPO was in place and set.  It still shows the yellow triangle.

    --Jeff

    Wednesday, September 21, 2011 6:20 PM
  • hmm...  I'll have to fire up the test lab and double check.  I am pretty sure that I tested these settings on a Windows 7 system.

     


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    Wednesday, September 21, 2011 6:29 PM
  • Does your test lab have any internet connection via proxy, etc?  I my case it is fully isolated.

    Thanks,

    --Jeff


    • Edited by Protholl Wednesday, September 21, 2011 6:55 PM
    Wednesday, September 21, 2011 6:44 PM
  • I quickly validated this today on an internet connected network, but chaning my DNS client settings so that name resolution for the client would not work.  I applied the regedit and sure enough, when I disabled the ActiveProbing, the Network Indicator did not show a yellow exclamation mark.  When I re-enabled the ActiveProbe, the yellow exclamation mark re-appeared.

    I will continue to validate this by setting up a VM lab with NO internet connectivity to see if the results are as expected.  I did this long before, but the details are fading away due to age...

     


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    Wednesday, September 21, 2011 8:06 PM
  • So I brought a 2008 R2 server online in a VM environment.  The 2008 R2's NIC was bridged to a network adapter on the host that was a loopback adapter.  This design was selected to provide the guest OS with a link, but no where to go.

    When I applied the GPO as described in my blog, the results were as expected.

    If you applied both the regedit and policy, let the system sit there for a little while to see if the icon changes as shown in this post.

     


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    Thursday, September 22, 2011 12:55 AM
  • See if this GPO setting works on your Win7/2008 R2 system...

     

    1. Click Start, type gpmc.msc, and then press ENTER. Select an appropriate Group Policy object (GPO).
    2. Navigate to Computer Configuration > Policies > Administrative Templates > Network Connections
    3. Enabled the “Do not show the “local access only” network icon” policy setting.

    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    Thursday, September 22, 2011 1:08 AM
  • ·          

    Hi,

     

    In windows 7, NCSI is Used for Direct access clients to check the location but if you are not using direct access you can disable it.

     

    DirectAccess Client Determines that it is on the Internet When on the Intranet

     

    Also, check if the following articles help:

     

    Appendix H: Network Connectivity Status Indicator and Resulting Internet Communication in Windows 7 and Windows Server 2008 R2

     

    You cannot connect to the Internet from a Windows Vista-based computer that uses a local .pac file

     

    Regards,

     

    Sabrina

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, September 22, 2011 4:39 AM
  • After studying the behaviour in more detail, I would recommend that both of these GPO settings be applied to ensure that Vista and later are covered.

    • Turn Off Windows Network Connectivity Status Indicator Active Tests [Enable]
    • Do not show the "local access only" network icon [Enable]

    I completed re-testing this in two labs and validated the results. 

    I hope this helps you Jeff.

     

     


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    • Marked as answer by Protholl Thursday, September 22, 2011 7:10 PM
    Thursday, September 22, 2011 2:32 PM
  • After studying the behaviour in more detail, I would recommend that both of these GPO settings be applied to ensure that Vista and later are covered.

    • Turn Off Windows Network Connectivity Status Indicator Active Tests [Enable]
    • Do not show the "local access only" network icon [Enable]

    I completed re-testing this in two labs and validated the results. 

    I hope this helps you Jeff.

     

     


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube


    JM,

    These two GPOs in concert work great.  The icon is "normal" and this should cut down on the calls.  They still get the "no internet access" if they hover their mouse over the icon but I'm not worried about that. 

    Thank you (all) for this information.

    --Jeff

    Thursday, September 22, 2011 6:28 PM
  • Glad this was able to resolve this issue for you.  This was a good refresher for me as well as I hadn't taken such a deep look into this topic in quite a while.

     


    Visit anITKB.com, an IT Knowledge Base.

    anITKB facebook youtube
    Thursday, September 22, 2011 6:35 PM