locked
SharePoint 2013 Survey List RRS feed

  • Question

  • Recently we upgraded from SP2010 to SP2013 environment. During our test, we missed to identify that all the survey list has column added called "Name" of type "file". Issue is not just on migrated survey list but also when new survey list is created. There is no input or attach field to upload any file and although this field is set as required field, it allows to submit surveys without any input this field. 

    On 2010, when new survey lists are created, it propmts you to add questions immediaetly but noticed on 2013, it simply creates new list and then you can go back to list to add questions. Is this new 2013 behavior?

    I tried to delete on Designer but it does not allows to delete it, gave error message "Column settings are not supported for this type of column". But it allows if I rename before deleting. For existing ones, I guess I can run powershell script to look for survey type list and delete these columns but concerned that this happens on when creating new survey list. So can anyone please help understand what happends new survey list is created? 

     

    MK Sin

    Thursday, February 27, 2014 2:41 PM

All replies

  • Hi,

    According to your post, my understanding is that you had issues about SharePoint 2013 Survey List.

    This is a new behavior in SharePoint 2013.

    In SharePoint 2010, once you create a survey list, you will need to start creating questions for this survey. Please refer to: Survey List In SharePoint 2010

    In SharePoint 2013, after you create a survey list, you need to click Setting-> Add Questions to create questions for this survey. Please refer to: Creating a SharePoint 2013 Survey

    It will be better if you can descript more detail that where you see the “Name” column.

    In my envireonment, if I create a survey list in SharePoint 2013, there is no “Name” column.

    Best Regards,

    Linda Li


    Linda Li
    TechNet Community Support

    Friday, February 28, 2014 4:17 AM
  • This field "name" appears only on newform.aspx. On Edit & Display, this field does not appears. I am able to reproduce this issue on both test and produciton environment on all site colleciton. 

    This field does not appear on list settings - under Columns. 


    MK Sin

    Friday, February 28, 2014 3:34 PM
  • Hi,

    In my new form, there is no “Name” filed.

    It will be better if you can provide some screenshots.

    Best Regards,

    Linda Li


    Linda Li
    TechNet Community Support

    Sunday, March 2, 2014 8:51 AM
  • Linda,

    Here is few screenshot on new and display forms with and without adding questions.  at the bottom there's a screenshot of columns listed under settings.


    New & Display form example

    Questions on Survey List


    MK Sin

    Monday, March 3, 2014 11:32 PM
  • Hi,

    In my SharePoint 2013 environment, there is no Name filed in the new form.

    Did you have the Name filed in the New Form of the Survey list before you upgraded SharePoint 2010?

    Did you customize the new form in the SharePoint 2010 environment?

    Best Regards,

    Linda Li


    Linda Li
    TechNet Community Support

    Tuesday, March 4, 2014 1:30 AM
  • No, there is no "Name" field in 2010. This behavior is not limited to old survey type list but also to newly created survey list on 2013. Like I have mentioned earlier, even when I create brand new empty Survey list, it creates this column. So column that is getting displayed is secondary thing, primary issue is how this column is even getting created.


    MK Sin

    Wednesday, March 5, 2014 6:45 PM
  • Hello Kim,

    did you get the Solution for that?

    I am also trapped in the same issue and want to get rid of this field.

    Regards,

    Azra


    With Thanks and Regards, Azra

    Wednesday, March 12, 2014 3:49 PM
  • Me too! Very annoying that I can't get rid of it. Worse is that it messes up the Graphical Summary view. It shows each response as a row.
    Wednesday, April 16, 2014 8:33 PM
  • Hi

    I have exactly the same problem. What's strange is that I created a Survey a few months ago and I didn't had this issue. Maybe related to a side-effect of the Cumulative Update I installed since the last time I created the first survey ?

    Any solution will be appreciated.

    Tuesday, April 28, 2015 2:32 PM
  • Finally I was able to figure out the issue and found a solution. Saying that there is no guarantee this is same issue in your environment, so make sure to fully test on test/dev environment.

    Just to recap the issue, "Name" field appears on Survey list. In my case actually issue was more severe as this field was set as required field on all other list ("custom", announcment, task etc.).

    Root cause: As I previously pointed out, during migration from 2010 to 2013 we had consultant using powershell scriptsto update metadata, creating, adding, populating custom list & site columns which required toggling "sealed" properties and making fields optional and switching back to required. In that process looks like "Name" (internal name -  "FileLeafRef") which is one of internal hidden field was set as required causing all lists making it mandatory field. 

    As for resolution, I was able to fix it by deactivate/activate "Field" feature on all the affected site collections - It is basically resetting all the system columns. This will not fix the issue on existing list. For that you can write a powershell script to set it as "Not Required" on all the existing lists.

    For Survey list, I just had handful so made changes manually. Go to survey list settings page, click one of questions or "modified' or any column. On address bar, go to the end of url and change value for "Field" query parameter to "FileLeafRef" (case sensitive so make sure to type in exactly, it directs you to the page where you can delete it make it optional field.

    To deactivate/activate ( solution found on stack exchange)

    stsadm -o deactivatefeature -name Fields -url http://sitecoll -force
    stsadm -o activatefeature -name Fields -url http://sitecoll -force

    Hope this helps.


    MK Sin

    Wednesday, November 11, 2015 9:10 PM