locked
missing icons on windows seven RRS feed

  • Question

  • That while some of the icons on the desktop or other routes is not a true

    my OS is windows seven Ultimate

    It also gave the following solution, but the problem is not resolved

    •        Run cmd
    • taskkill /IM explorer.exe /F
    • CD /d %userprofile%\AppData\Local
    • DEL IconCache.db /a
    • shutdown /r

    screenshot: 

    http://vbland.persiangig.com/missing%20icons%20on%20windows%20seven.png

    thanks for your help

    Friday, July 1, 2011 9:04 AM

Answers

  • If C:\Windows\Installer is empty, that is likely the entire problem since many .ICO icon files for installed programs reside within that folder.

    One reason that folder gets purged is Windows Installer detects a problem with the permissions and logs Event ID 1028 in the Application log:

    Event ID: 1028
    Event Source: MsiInstaller
    Description: Windows Installer has determined that its configuration data cache folder was not secured properly. The owner of the key must be either Local System or Builtin\Administrators. The existing folder will be deleted and re-created with the appropriate security settings.

    http://technet.microsoft.com/en-us/library/dd316069(WS.10).aspx

    You can try restoring a backup of that folder if you have one. You can also try copying over the contents of C:\Windows\Installer from another computer of the same OS versions and ideally, most of the same applications installed. Otherwise you will need to reinstall the programs.

    • Marked as answer by Ashkan209 Monday, July 4, 2011 2:10 PM
    Sunday, July 3, 2011 11:53 PM

All replies

  • Hi,

    If you run the program, does it work correctly? If it do, maybe you have lost icon association.

    Friday, July 1, 2011 2:08 PM
  • Hi,

    I understand your answer , but I Re-did the scenario (del iconcache.db and restart OS)

    Some of them were changed and some did not change, Those changes would also be incorrect

    The problem remains

    new screenshot:

    http://vbland.persiangig.com/Untitled.png

    Friday, July 1, 2011 8:04 PM
  • Hi,

    I understand your answer , but I Re-did the scenario (del iconcache.db and restart OS)

    Some of them were changed and some did not change, Those changes would also be incorrect

    The problem remains

    new screenshot:

    http://vbland.persiangig.com/Untitled.png


    Thanks, but I need to know: Are those applications working fine?

    If they are working but they don't have icon associated, could be a problem with some icons association.

    So.. for example with Adobe Reader, please go to this location: C:\Windows\Installer\{AC76BA86-7AD7-1033-7B44-AA0000000001}

    Right click on any Icon, select Properties and clic on Change button and make sure that Windows Photo Gallery is the default Application for all (.ico) files

    Friday, July 1, 2011 9:19 PM
  • Hi,

    Thanks

     

    Thanks, but I need to know: Are those applications working fine?

    yes , All application are working fine

     

    So.. for example with Adobe Reader, please go to this location: C:\Windows\Installer\{AC76BA86-7AD7-1033-7B44-AA0000000001}

    c:\windows\installer is empty

    please see two screenshots

    http://vbland.persiangig.com/1.png

    http://vbland.persiangig.com/2.png

    Sunday, July 3, 2011 2:19 PM
  • You have a serious problem, could you please create an other account and see if there is not icon too? Just for make sure that the problem is only under your current account.
    Sunday, July 3, 2011 3:19 PM
  • If C:\Windows\Installer is empty, that is likely the entire problem since many .ICO icon files for installed programs reside within that folder.

    One reason that folder gets purged is Windows Installer detects a problem with the permissions and logs Event ID 1028 in the Application log:

    Event ID: 1028
    Event Source: MsiInstaller
    Description: Windows Installer has determined that its configuration data cache folder was not secured properly. The owner of the key must be either Local System or Builtin\Administrators. The existing folder will be deleted and re-created with the appropriate security settings.

    http://technet.microsoft.com/en-us/library/dd316069(WS.10).aspx

    You can try restoring a backup of that folder if you have one. You can also try copying over the contents of C:\Windows\Installer from another computer of the same OS versions and ideally, most of the same applications installed. Otherwise you will need to reinstall the programs.

    • Marked as answer by Ashkan209 Monday, July 4, 2011 2:10 PM
    Sunday, July 3, 2011 11:53 PM
  •  

    Hi,

    I copy \windows\installer\*.* from another windows seven , that has same software (my office pc) to this computer (the computer had problem)

    and then

    •        Run cmd
    • taskkill /IM explorer.exe /F
    • CD /d %userprofile%\AppData\Local
    • DEL IconCache.db /a
    • shutdown /r

    and after restart all icon was correct

    Thank you very much Craig and sergio

     

    Monday, July 4, 2011 2:25 PM