locked
Issues after restoring sharepoint 2007 farm RRS feed

  • Question

  •  

    Dear all,

    Please advise on examination and handling of the issues we faced after restoring sharepoint farm.

    After the unsuccessful update of WSS3.0 with SP3 we decided to recreate sharepoint farm with the existing content. The following actions were performed:

    1. Uninstallation of WSS3.0 and installation of Microsoft Sharepoint Search Server Express 2008 without any notifications or issues. New Central Admin, Sharepoint Config, Shared Services and other things were created successfully.

    2. Creating new sharepoint applications with new content databases.

    3. Deleting content databases and attaching old ones by stsadm:

    stsadm -o deletecontentdb -url http://myapplication:port –databasename newdatabase -databaseserver sqlsrv

    stsadm -o addcontentdb -url http://myapplication:port -databasename oldcontentdatabase -databaseserver sqlsrv

    All our three web applications were created in the same way.

    4. Deployment of custom solutions.

     

    All applications are working fine at the first glance, but some pages are not accessible causing 404 error. For example, core.css storing at _styles/core.css. Attempt to open it through SPD 2007 gets:

    "The server could not complete your request. Contact your internet service provider or Web server administrator to make sure that the server has the Frontpage Server Extensions or SharePoint Services installed."

    With details:

    “Server error: The URL ‘/_styles/core.css’ is invalid. It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web”

    Forms and view pages (AllItems.aspx, EditForm.aspx, DispForm.aspx, etc) of custom library are also inaccessible. SPD message:

    “soap:ServerServer was unable to process request. ---> The file https://serverurl/web/Libname/Forms/DispForm.aspx does not exist.”

    But if create new list form through SPD it will work nice.

    Please can anybody help in solving these issues? Thank you very much in advance.

    I have found related thread http://social.msdn.microsoft.com/Forums/en-US/sharepointcustomization/thread/0c67f8af-850d-41d0-a14a-c0939382066b but I was unable to find mentioned SQL jobs







    • Edited by SergBel Friday, November 4, 2011 8:54 PM
    Thursday, November 3, 2011 9:10 AM

Answers

  • Issue is fixed by reuploading all "broken" files.

     

     

     

    • Marked as answer by SergBel Friday, November 4, 2011 9:25 PM
    Friday, November 4, 2011 9:25 PM