locked
Application doesn't work when launched with VAppLauncher RRS feed

  • Question

  • Hi All,

    I have a sequenced application that is deployed to Windows 7 64-bit with SCCM 2007 but fails when launched, however the same app on the same machine launches without error if I use SFTTray.exe. (Sequencer 4,6, AppV Client 4.6)

    Now as far as I can see VAppLauncher invokes SFTTray and I have tried to identify something different in the behaviour with ProcMon, Process Explorer and even comparing the processes with PowerShell but I can't see any differences in the processes.

    I know that VAppLauncher invokes STFTray with the /LaunchResult switch but I expect this is just so VAppLauncher knows when SFTTray has successfully launched so it can terminate, for completeness I added /LaunchResult to my SFTTray command but the app still works.

    I have also tested the application on an equivelant Windows 7 32-bit build as well as running the application elevated but the behaviour is consistent.

    Are there any known differences between SFTTray when called by VAppLauncher and when it is called directly?  I haven't found anything search the forums that addresses this specific issue.

    Many Thanks in advance

    Andrew


    • Edited by admason Friday, May 23, 2014 1:59 PM
    Friday, May 23, 2014 10:42 AM

All replies

  • Hello,

    The major difference is that vapplauncher is simply not passing all parameters along, such as /EXE for example.

    Perhaps if you run a process monitor you can see a difference in behavior between the two scenarios?



    Nicke Källén | The Knack| Twitter: @Znackattack

    Sunday, May 25, 2014 6:42 PM
  • Hi,

    Unfortunately ProcMon hasn't been very helpful.  For starters when monitoring the application itself ProcMon appears to get stuck in a loop repeatedly logging the same events over and over.  Typically the app errors within seconds but with ProcMon running backed by a file on the local machine it has run for over an hour, amassing 43GB of PML files and the app only errors after ProcMon crashes, very bizarre.

    When I realised the that issue may actually be with SFTTray I was able to monitor that with ProcMon and one thing I did notice is that when I start SFTTray.exe directly the environment settings reported in the Details of Process Start are as expected for a 64-bit machine, i.e. PROCESSOR_ARCHITECTURE=AMD64.  However when I launch the app via the SCCM deployed shortcut the SFTTray process spawned from VAppLauncher starts with PROCESSOR_ARCHITECTURE=x86 in the Process Start Details.  Despite this difference however when I start a Command Prompt with both SFTTray directly and VAppLauncher both report the same environment variables, i.e PROCESSOR_ARCHITECTURE=AMD64 (.\SysNative`CMD.exe & .\System32\CMD.exe) or PROCESSOR_ARCHITECTURE=x86 (.\SysWow64\CMD.exe)

    The app works from the the CMD prompt started by SFTTray directly irrespective of what the PROCESSOR_ARCHITECTURE env var is reporting.

    What is also interesting is that despite ProcMon reporting different values for PROCESSOR_ARCHITECTURE in the Process Start details Process Explorer and the details captured by the Powershell Get-Process Cmdlet all report PROCESSOR_ARCHITECTURE=AMD64 for both instances of SFTTray.

    I have also noticed that SFTTray re-uses an existing process when it launches therefore if I launch my app via SFTTray directly then launch it via VAppLauncher the instance launched via VAppLauncher works because it re-uses the SFTTray Proccess that was launched directly.  Likewise if I launch the app via VappLauncher and then launch SFTTray directly the instance launched directly via SFTTray fails because it has re-used the SFTTray process from Vapplauncher.

    Is there no way of forcing a second SFTTray process to run so that any existing processes from VAppLauncher don't interfere?

    Tuesday, May 27, 2014 9:36 AM
  • Hello,

    With the ConfigMgr integration for App-V enabled? No, you would have to disable the integration.

    Recommended would be to try the App-V 4.6 SP3 HF 2, which is the latest version, just to ensure that it hasn't already been remediated;

    http://blogs.msdn.com/b/sgern/archive/2014/05/05/10522622.aspx


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, May 27, 2014 6:19 PM
  • Hi,

    I've installed SP3 Hotfix 2 and that still doesn't work.  Thanks for the suggestion anyway.

    Andrew

    Thursday, May 29, 2014 3:36 PM
  • Hello,

    I would validate this against a ConfigMgr 2012 environment

    - If it works, then obviously Microsoft will recommend you to upgrade

    -If it doesn't work, I would raise a support call


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, May 30, 2014 8:13 AM