locked
Programs can't access folders due to accounts error. RRS feed

  • Question

  • Hi, I've had this problem for a while and it's mostly been manageable but today I really feel like I should sort it out.

    When I got this new laptop (Toshiba Windows 8) my dad insisted on sorting it out for me and initially put his Microsoft details in as the administrator. When he deleted his account and set mine up, since then I've been the administrator but have to go through administrator permissions pop-ups. Furthermore, programs I have installed that have files in the Documents folder (EA games for example) have had trouble running because of the permissions issues. I have tried to look at the properties of folders in the past but I haven't had much success.

    Other points - there have been many cases of extra accounts popping up in the permissions windows, like unknown accounts or local accounts, but not in the Accounts section of Control Panel. Also, all folders in the Libraries section seem permanently set to Read-only. Please help!!

    Sunday, August 24, 2014 9:22 AM

Answers

  • Hi,

    As T. Kujala  mentioned, the permission pop-up was handled by UAC. On my side, I don't recommend you disable it completely since UAC helps you to protect your computer.

    To check the incorrect permission issue, I suggest you run following command to reset permissions on your computer:

    cd /d c:\
    icacls * /T /Q /C /RESET

    For detailed information about this command, you can refer to:
    Icacls
    http://technet.microsoft.com/en-us/library/cc753525.aspx

    For your games failed to run with permission error, I suggest you run it as Administrator by right-clicking the exe file.


    Kate Li
    TechNet Community Support

    • Marked as answer by Michael_Martin Tuesday, September 2, 2014 6:05 PM
    Tuesday, August 26, 2014 9:24 AM

All replies

  • You can configure the User Account Control settings if you want to run programs always as an administrator without any prompting.

    http://windows.microsoft.com/en-us/windows/turn-user-account-control-on-off#1TC=windows-7

    If you have only read pemissions to some folders, you have to change permission or you have to take ownership of a folder.

    http://technet.microsoft.com/en-us/library/cc754344.aspx

    http://technet.microsoft.com/en-us/library/cc753659.aspx

    Sunday, August 24, 2014 10:21 AM
  • Hi,

    As T. Kujala  mentioned, the permission pop-up was handled by UAC. On my side, I don't recommend you disable it completely since UAC helps you to protect your computer.

    To check the incorrect permission issue, I suggest you run following command to reset permissions on your computer:

    cd /d c:\
    icacls * /T /Q /C /RESET

    For detailed information about this command, you can refer to:
    Icacls
    http://technet.microsoft.com/en-us/library/cc753525.aspx

    For your games failed to run with permission error, I suggest you run it as Administrator by right-clicking the exe file.


    Kate Li
    TechNet Community Support

    • Marked as answer by Michael_Martin Tuesday, September 2, 2014 6:05 PM
    Tuesday, August 26, 2014 9:24 AM
  • The main problem I have with my games is that even if I run them as administrator, any subfolders I create cannot be accessed (like if I categorise my custom content for my Sims games). I don't mind being slightly disorganised though.

    Thank you for your response. I read the link you shared, but there are a couple of things missing. I know how to run the command but what will happen afterwards? Does a list of accounts pop up afterwards?

    Tuesday, August 26, 2014 3:19 PM
  • I would consider the command (slightly) unsafe, but I don't know (I recently tried an unrelated command and ruined the performance of my system)

    UAC proper (virtualization) cannot be disabled on itself. But the prompts can.

    The real problem might be that the files created by the games might have been stored on the other account, in the %LOCALAPPDATA%\VirtualStore folder. Deleted that account? Deleted the VirtualStore folder too!

    A safer command is working on the VirtualStore folder alone. So you can do cd /d %LOCALAPPDATA%\VirtualStore and the other command.

    Tuesday, August 26, 2014 7:56 PM