locked
Outlook 2016 - offline Outlook Data File (.ost) path cannot be changed - bug or "feature"? RRS feed

  • Question

  • I'm using Outlook 2016

    According to https://support.microsoft.com/en-us/help/2752583, method 2, we can set the ForceOSTPath registry entry to change the location of the .ost file.

    However, I've found that my Gmail account in IMAP access has created the .ost file in the default path instead of the path pointed by ForceOSTPath.

    So my questions are:

    Is this a bug?
    Or is it a "feature" and/or a known bug?
    Or is it because my Gmail account is using IMAP?
    Or is it because my Gmail account is the secondary account in my Outlook profile (the 1st one being Exchange account)?

    Thanks in advance

    Monday, October 8, 2018 5:13 PM

Answers

  • Hi Horinius,

    Based on my research, the ForceOSTPath registry mentioned in your original thread applies to Exchange OST files. To relocate the default IMAP .ost path for Outlook 2016, please use the ForcePSTPath regedit:

    Important: Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    1. Press Win+R, type "regedit", press Enter.
    2. Browse to the following subkey in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook

    3. Right click on the key and choose New > String Value, rename the new string value to "ForcePSTPath", input your desired data path as the value data:

    Note: This does not change the path for existing accounts. It works only for accounts created after the key is set. Remember to create the folder you want to store the IMAP pst files in before you set the key.

    Hope the above information can be helpful.

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Horinius Tuesday, October 9, 2018 12:44 PM
    Tuesday, October 9, 2018 2:36 AM

All replies

  • Hi Horinius,

    Based on my research, the ForceOSTPath registry mentioned in your original thread applies to Exchange OST files. To relocate the default IMAP .ost path for Outlook 2016, please use the ForcePSTPath regedit:

    Important: Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

    1. Press Win+R, type "regedit", press Enter.
    2. Browse to the following subkey in the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook

    3. Right click on the key and choose New > String Value, rename the new string value to "ForcePSTPath", input your desired data path as the value data:

    Note: This does not change the path for existing accounts. It works only for accounts created after the key is set. Remember to create the folder you want to store the IMAP pst files in before you set the key.

    Hope the above information can be helpful.

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by Horinius Tuesday, October 9, 2018 12:44 PM
    Tuesday, October 9, 2018 2:36 AM
  • Hi Horinius,

    Based on my research, the ForceOSTPath registry mentioned in your original thread applies to Exchange OST files. To relocate the default IMAP .ost path for Outlook 2016, please use the ForcePSTPath regedit:

    Hi Yuki,

    Indeed!  I have tried the ForcePSTPath registry value and it worked for IMAP OST file!

    So, it's clear that someone in Microsoft has done a mistake, ie this is a bug:

    IMAP OST file relies on ForcePSTPath registry value.

    Either they have to change this behaviour (use ForceOSTPath instead of ForcePSTPath) or change the KB article to clearly state this exception.


    • Edited by Horinius Tuesday, October 9, 2018 1:21 PM
    Tuesday, October 9, 2018 1:13 PM
  • Hi Horinius,

    Great to see that the issue has been resolved and thanks for your feedback about the KB article. I have tried to help submit your suggestion by clicking the "No" button at the bottom of the web page:

    You may also submit the feedback this way to increase the possibility for our voice to be heard by the related team.  

    Regards, 

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Teams.

    Wednesday, October 10, 2018 2:01 AM