locked
error when installing mailbox role RRS feed

  • Question

  • Hi all.
    I have an exchange organisation with two exchange 2003 server.
    And now I am upgrading to exchange 2010.
    Installer asked me install some hotfixes and roles, and i did it.
    Then an error appeared:

    ---------------------------------------------------------
    Summary: 12 item(s). 10 succeeded, 1 failed.
    Elapsed time: 00:57:08
    Organization Preparation
    Completed
    Elapsed Time: 00:38:45
    Preparing Setup
    Completed
    Elapsed Time: 00:00:00
    Stopping Services
    Completed
    Elapsed Time: 00:00:02
    Copy Exchange Files
    Completed
    Elapsed Time: 00:00:54
    Language Files
    Completed
    Elapsed Time: 00:02:12
    Restoring services
    Completed
    Elapsed Time: 00:00:01
    Languages
    Completed
    Elapsed Time: 00:00:03
    Management Tools
    Completed
    Elapsed Time: 00:00:14
    Hub Transport Role
    Completed
    Elapsed Time: 00:06:43
    Client Access Role
    Completed
    Elapsed Time: 00:03:41
    Mailbox Role
    Failed
    Error:
    The following error was generated when "$error.Clear();
     $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
     $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
     $dismbx = get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1;
     if( $dismbx -ne $null)
     {
     $srvname = $dismbx.ServerName;
     if( $dismbx.Database -ne $null -and $RoleFqdnOrName -like "$srvname.*" )
     {
     Write-ExchangeSetupLog -info "Setup DiscoverySearchMailbox Permission.";
     $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
     if( $mountedMdb -eq $null )
     {
     Write-ExchangeSetupLog -info "Mounting database before stamp DiscoverySearchMailbox Permission...";
     mount-database $dismbx.Database;
     }
     $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
     if( $mountedMdb -ne $null )
     {
     $dmRoleGroupGuid = [Microsoft.Exchange.Data.Directory.Management.RoleGroup]::DiscoveryManagementWkGuid;
     $dmRoleGroup = Get-RoleGroup -Identity $dmRoleGroupGuid -DomainController $RoleDomainController -ErrorAction:SilentlyContinue;
     if( $dmRoleGroup -ne $null )
     {
     Add-MailboxPermission $dismbx -User $dmRoleGroup.Identity -AccessRights FullAccess -DomainController $RoleDomainController -WarningAction SilentlyContinue;
     }
     }
     }
     }
     " was run: "Couldn't resolve the user or group "domain.ru/Microsoft Exchange Security Groups/Discovery Management."
    If the user or group is a foreign forest principal, you must have either a two-way trust or an outgoing trust.".
    Couldn't resolve the user or group "domain.ru/Microsoft Exchange Security Groups/Discovery Management."
    If the user or group is a foreign forest principal, you must have either a two-way trust or an outgoing trust.
    The trust relationship between the primary domain and the trusted domain failed.
    
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?
    v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp
    
    Elapsed Time: 00:04:27
    
    Finalizing Setup
    Cancelled

    ---------------------------------------------------------
    Other roles and console was installed.
    Mailbox role  was not set up correctly. It exist in console, but setup programm suggest install mailbox role (it think, that mailbox role doesn't set up).
    Best Practice Analizer shows this error:
    ---------------------------------------------------------
    'MailboxRole' is partially configured on server 'newsserver.domain.ru'.
    Either setup is configuring it right now or setup failed while configuring it.
    Please rerun the setup if isn't being run

    ---------------------------------------------------------
    When I run setup, I have error same as in first setup.
    I try to remove and install mailbox role.
    I press uninstal button in controll panel. Setup programm shows me the error - some mailbox databases uses public folder and setup can't deletes this pulic folder database.
    I change default public folder of mailbox databases, and try to delete public folder database.
    I receive an error:
    ---------------------------------------------------------

    The public folder database 'Public Folder Database 0224158565' cannot be deleted.
    Public Folder Database 0224158565
    Failed
    Error:
    The public folder database "Public Folder Database 0224158565" contains folder replicas.
    Before deleting the public folder database, remove the folders or move the replicas to another public folder database.
    For detailed instructions about how to remove a public folder database,
    see http://go.microsoft.com/fwlink/?linkid=81409&clcid=0x409.


    ---------------------------------------------------------
    I added second server to replication in all three public folder, wateed tem minutes and delete my new server from replication.
    But wen I delete public folder database, I receive this arror again.
    What can I do? help me please.

    мой блог - http://vvnet.ru

    • Edited by Yakov Barinov Tuesday, November 30, 2010 9:33 AM trimed empty line in quotes
    Tuesday, November 30, 2010 9:28 AM

Answers

  • Problem was in trusts. Some ports was blocked on firewalls. Network administrators opened it and I installed mailbox role sucesfully.
    мой блог - http://vvnet.ru
    • Marked as answer by Yakov Barinov Monday, December 6, 2010 10:26 AM
    Monday, December 6, 2010 10:26 AM

All replies

  • I've seen this before - do you have any trusts in place?
    My Book - Active Directory, 4th Edition
    My Blog - www.briandesmond.com
    Tuesday, November 30, 2010 11:02 PM
  • I'm having a similar problem when trying to install the Mailbox role.

    Summary: 3 item(s). 1 succeeded, 1 failed.
    Elapsed time: 00:03:24


    Preparing Setup
    Completed

    Elapsed Time: 00:00:00


    Mailbox Role
    Failed

    Error:
    The following error was generated when "$error.Clear();
              $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
              $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
              $dismbx = get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1;
              if( $dismbx -ne $null)
              {
                $srvname = $dismbx.ServerName;
                if( $dismbx.Database -ne $null -and $RoleFqdnOrName -like "$srvname.*" )
                {
                  Write-ExchangeSetupLog -info "Setup DiscoverySearchMailbox Permission.";
                  $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
                  if( $mountedMdb -eq $null )
                  {
                    Write-ExchangeSetupLog -info "Mounting database before stamp DiscoverySearchMailbox Permission...";
                    mount-database $dismbx.Database;
                  }

                  $mountedMdb = get-mailboxdatabase $dismbx.Database -status | where { $_.Mounted -eq $true };
                  if( $mountedMdb -ne $null )
                  {
                    $dmRoleGroupGuid = [Microsoft.Exchange.Data.Directory.Management.RoleGroup]::DiscoveryManagementWkGuid;
                    $dmRoleGroup = Get-RoleGroup -Identity $dmRoleGroupGuid -DomainController $RoleDomainController -ErrorAction:SilentlyContinue;
                    if( $dmRoleGroup -ne $null )
                    {
                      Add-MailboxPermission $dismbx -User $dmRoleGroup.Identity -AccessRights FullAccess -DomainController $RoleDomainController -WarningAction SilentlyContinue;
                    }
                  }
                }
              }
            " was run: "Couldn't resolve the user or group "domain.contoso.org/Microsoft Exchange Security Groups/Discovery Management." If the user or group is a foreign forest principal, you must have either a two-way trust or an outgoing trust.".

    Couldn't resolve the user or group "domain.contoso.org/Microsoft Exchange Security Groups/Discovery Management." If the user or group is a foreign forest principal, you must have either a two-way trust or an outgoing trust.

    The trust relationship between the primary domain and the trusted domain failed.

    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp

    Elapsed Time: 00:03:23


    Finalizing Setup
    Cancelle

    Wednesday, December 1, 2010 8:56 PM
  • I saw this issue once where there were trusts however all Exchange roles were being installed into the Forest Root domain where the groups actually existed.  It ended up in a wierd state where the HT and CAS roles were sucessfully installed.  The installed throught mailbox wasnt installed but the uninstaller thought that it was (but was unable to remove it).

    My solution at the time was to reload the server, rejoin the domain and perform a recovery install, there was no data on the server so nothing was lost but time.

    http://technet.microsoft.com/en-us/library/dd876880.aspx

     

    Wednesday, December 1, 2010 9:02 PM
  • Problem was in trusts. Some ports was blocked on firewalls. Network administrators opened it and I installed mailbox role sucesfully.
    мой блог - http://vvnet.ru
    • Marked as answer by Yakov Barinov Monday, December 6, 2010 10:26 AM
    Monday, December 6, 2010 10:26 AM