locked
Remoteapp in session collections server 2012 RRS feed

  • Question

  • Hi,

    When publishing remoteapps in a session collection (consisting of 2 or more RDSH) in server 2012 the option to "Show the session collection in RD Web Access" is disabled, so the users are not able to connect directly to the full desktop. I have no idea why this is, but anyways, if we were to connect directly to the session collection by using an rdp client (mstsc) instead of the rd web, what would be the farm (session collection) name? Connecting directly to the broker doesn't work.

    Thank you

    Sunday, October 7, 2012 6:52 PM

Answers

  • Hi,

    If you want you may try the following registry modification on your connection broker(s) to make the full desktop icon show up with your RemoteApps in the same collection:

    HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Terminal Server\ CentralPublishedResources\ PublishedFarms\ <collection name>\ RemoteDesktops\ <collection name>

    ShowInPortal     REG_DWORD     0x00000001

    If you choose the above approach I recommend you test thoroughly since 2012 Server Manager intends for you to have a collection publish RemoteApps or Remote Desktops, but not both.  I do not know if there is a technical reason for this change.

    -TP

    • Marked as answer by Kjartis Monday, October 8, 2012 6:43 AM
    Monday, October 8, 2012 3:56 AM
  • There are a few RDP parameters that need to be in place if you would like to connect through the Win 2012 RD Connection broker.

    In this blog post I did some explanation on this: http://microsoftplatform.blogspot.nl/2012/04/rd-connection-broker-ha-and-rdp.html


    Kind regards,
    Freek Berson
    The Microsoft Platform
    Twitter
    Linked-in
    Wortell company website

    • Marked as answer by Kjartis Monday, October 8, 2012 6:43 AM
    Sunday, October 7, 2012 8:15 PM

All replies

  • There are a few RDP parameters that need to be in place if you would like to connect through the Win 2012 RD Connection broker.

    In this blog post I did some explanation on this: http://microsoftplatform.blogspot.nl/2012/04/rd-connection-broker-ha-and-rdp.html


    Kind regards,
    Freek Berson
    The Microsoft Platform
    Twitter
    Linked-in
    Wortell company website

    • Marked as answer by Kjartis Monday, October 8, 2012 6:43 AM
    Sunday, October 7, 2012 8:15 PM
  • Hi Freek,

    Thanks for your answer, I actually found that blog right after i posted :)

    However, a quick question, I've configured it and so forth, but when i connect i get:

    RDSH02.corp.example.com

    "The certificate is not from a trusted certifying authority"

    How would i install the certificate when there's no RD session host configuration tool on the RDSH servers? Broker, web access, gateway etc certs are all done through the new Remote desktop server manager snapin.

    Do we have to resort to powershell or wmi to do it?

    Thanks

    Sunday, October 7, 2012 8:37 PM
  • Hi,

    If you want you may try the following registry modification on your connection broker(s) to make the full desktop icon show up with your RemoteApps in the same collection:

    HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Terminal Server\ CentralPublishedResources\ PublishedFarms\ <collection name>\ RemoteDesktops\ <collection name>

    ShowInPortal     REG_DWORD     0x00000001

    If you choose the above approach I recommend you test thoroughly since 2012 Server Manager intends for you to have a collection publish RemoteApps or Remote Desktops, but not both.  I do not know if there is a technical reason for this change.

    -TP

    • Marked as answer by Kjartis Monday, October 8, 2012 6:43 AM
    Monday, October 8, 2012 3:56 AM