locked
Exchange 2007-What is the best method to setup a resource to autoaccept but still reject conflicts? RRS feed

  • Question

  • I'm trying to setup a resource (room) that will allow appointments to get automatically accept and decline conflicting appointments.

    I've toggled options for this back and forth and cannot find a perfect combination.  I am at a point where I'm able to get the resource to successfully autoaccept an appointment.  However, if someone attempts to schedule an appointment in a time block that is already being used is still being added instead of being declined.  I've also noticed users can still schedule appointments during "All day" events.

    What is the best method to set this up?

    Here are the resource settings:

    AutomateProcessing : Autoaccept
    IsResource : True
    Reource Type : Room

    Within the mailbox options,Resource Settings/Resource Scheduling Options, the option "Allow Conflicts" is not checked.

    Any assistance with this would be appreciated.

    Jason





    Friday, March 14, 2014 6:48 PM

Answers

  • Run this cmdlet to get your room mailbox configuration:

    get-mailboxcalendarsettings -identity <room mailbox> | Format-List


    AutomateProcessing                  : AutoAccept
    AllowConflicts                      : False
    BookingWindowInDays                 : 31
    MaximumDurationInMinutes            : 44640
    AllowRecurringMeetings              : True
    EnforceSchedulingHorizon            : True
    ScheduleOnlyDuringWorkHours         : False
    ConflictPercentageAllowed           : 0
    MaximumConflictInstances            : 0
    ForwardRequestsToDelegates          : True
    DeleteAttachments                   : True
    DeleteComments                      : True
    RemovePrivateProperty               : True
    DeleteSubject                       : False
    DisableReminders                    : True
    AddOrganizerToSubject               : True
    DeleteNonCalendarItems              : True
    TentativePendingApproval            : True
    EnableResponseDetails               : True
    OrganizerInfo                       : True
    ResourceDelegates                   : {}
    RequestOutOfPolicy                  :
    AllRequestOutOfPolicy               : False
    BookInPolicy                        :
    AllBookInPolicy                     : True
    RequestInPolicy                     :
    AllRequestInPolicy                  : False
    AddAdditionalResponse               : False
    AdditionalResponse                  : 
    RemoveOldMeetingMessages            : True
    AddNewRequestsTentatively           : True
    ProcessExternalMeetingMessages      : False
    DefaultReminderTime                 : 15
    RemoveForwardedMeetingNotifications : False
    Identity                            : 


    To decline conflicting, set AllowConflict to false by:

    Set-MailboxCalendarSettings -Identity <room mailbox> -AllowConflicts $False

    If you want user to book during office hous only then:

    Set-MailboxCalendarSettings -Identity <room mailbox> -ScheduleOnlyDuringWorkHours $True 

    Sunday, March 16, 2014 5:16 PM

All replies

  • Instead of appointments, I mean to say Meeting Requests.
    Friday, March 14, 2014 7:50 PM
  • Run this cmdlet to get your room mailbox configuration:

    get-mailboxcalendarsettings -identity <room mailbox> | Format-List


    AutomateProcessing                  : AutoAccept
    AllowConflicts                      : False
    BookingWindowInDays                 : 31
    MaximumDurationInMinutes            : 44640
    AllowRecurringMeetings              : True
    EnforceSchedulingHorizon            : True
    ScheduleOnlyDuringWorkHours         : False
    ConflictPercentageAllowed           : 0
    MaximumConflictInstances            : 0
    ForwardRequestsToDelegates          : True
    DeleteAttachments                   : True
    DeleteComments                      : True
    RemovePrivateProperty               : True
    DeleteSubject                       : False
    DisableReminders                    : True
    AddOrganizerToSubject               : True
    DeleteNonCalendarItems              : True
    TentativePendingApproval            : True
    EnableResponseDetails               : True
    OrganizerInfo                       : True
    ResourceDelegates                   : {}
    RequestOutOfPolicy                  :
    AllRequestOutOfPolicy               : False
    BookInPolicy                        :
    AllBookInPolicy                     : True
    RequestInPolicy                     :
    AllRequestInPolicy                  : False
    AddAdditionalResponse               : False
    AdditionalResponse                  : 
    RemoveOldMeetingMessages            : True
    AddNewRequestsTentatively           : True
    ProcessExternalMeetingMessages      : False
    DefaultReminderTime                 : 15
    RemoveForwardedMeetingNotifications : False
    Identity                            : 


    To decline conflicting, set AllowConflict to false by:

    Set-MailboxCalendarSettings -Identity <room mailbox> -AllowConflicts $False

    If you want user to book during office hous only then:

    Set-MailboxCalendarSettings -Identity <room mailbox> -ScheduleOnlyDuringWorkHours $True 

    Sunday, March 16, 2014 5:16 PM
  • Hi Jason,

    Please post all results of Get-MailboxCalendarSettings Room1 | FL here for further anylysis. Please make sure the AllowConflict parameter is set to False. The ConflictPercentageAllowed and MaximumConflictInstances parameters are set to 0.

    Thanks,


    Winnie Liang
    TechNet Community Support

    Tuesday, March 18, 2014 2:39 AM