none
[//target/manager] and a semi-colon in email msg RRS feed

  • Question

  • Hi,

    We are using MIM 2016 (build 4.3.2124.0) and have created a few new email templates that include the following:

    • [//target/manager]
    • [//target/creator]

    However, when the email is rendered, there is a semi-colon ; after each [//target/manager] and [//target/creator]

    So for example, the email message looks like this: Dear Joe Blogs;

    Is there a way to remove this semi-colon?

    Is this a MIM bug?

    We dont remember seeing this with FIM in the past.

    Thank you,

    sk


    • Edited by Shim Kwan Monday, May 23, 2016 10:50 PM
    Monday, May 23, 2016 10:49 PM

All replies

  • Hi,

    can verify this, seems like a bug to me also, I already send an email to aadmimfeedback@microsoft.com

    /Peter


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    Tuesday, May 24, 2016 5:39 AM
  • thank you Peter
    Wednesday, May 25, 2016 1:12 AM
  • that's something you can change on the email template. Its HTML.

    Nosh Mernacaj, Identity Management Specialist

    Wednesday, May 25, 2016 5:31 PM
  • Nosh, can you share with us please how you would modify the html then?

    it appears to happen within the [//target/manager] tag,

    I wasnt aware of being able to modify anything within that tag?


    • Edited by Shim Kwan Thursday, May 26, 2016 9:54 PM
    Thursday, May 26, 2016 9:54 PM
  • Each email is sent from a template and the variables filled out during runtime. "; " is part of the template. Show me the html of the email in question.

    Nosh Mernacaj, Identity Management Specialist

    Thursday, May 26, 2016 10:00 PM
  • Nosh I already checked that in my demolab, and the ";" seems to come directly from the resolving of the attribute, there was no such char in my mail template.

    So SK is right, I already give that to aadmimfeedback and was told to open a bug report on connect.

    So we can maybe expect that to be fixed in one of the next hotfixes.

    /Peter


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    Friday, May 27, 2016 8:09 AM
  • Peter, I trust you, but I do not believe in Magic

    Can someone send me the HTML for this email so I can fix it?

    Thanks,

    Nosh


    Nosh Mernacaj, Identity Management Specialist

    Friday, May 27, 2016 12:28 PM
  • Yes, this a known problem. 

    The class in FIM that does ResolveGrammar delimits multi-value attributes with ; and adds the semi-colon even if there only is one value.

    So it's a FIM/MIM problem, not a template problem.


    Did my post help? Please use "Vote As Helpful", "Mark as answer" or "Propose as answer". Thank you!

    Friday, May 27, 2016 1:25 PM
  • Seems so, just opened a bug report at connect.

    I also did a proof again with simple html (without inline css)

    <html>
    <body>
    Target Creator: [//Target/Creator]<br/>
    Target Owner: [//Target/Owner]
    </body>
    </html>

    Mail message looks like this:

    Target Creator: Peter Stapf ;
    Target Owner: Peter Stapf ; 
    

    Applie also to manager, but in the above cases also single value ref attributes are affected.

    /Peter


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    Friday, May 27, 2016 1:41 PM
  • First of Creator is always a single object. This MS sloppy coding.

    With the manager and all references, you can always do the //Target/Manager/DisplayName or //Target/Manager/FistName //Target/Manager/LastName.


    Nosh Mernacaj, Identity Management Specialist


    Friday, May 27, 2016 2:42 PM
  • Found out the reason,

    all of the other guys replies got me into some thinking.

    Seems that the ; is appended if the attribute is pointing to another object (reference)

    So when using [//Target/Creator/DisplayName] the ; is gone and all is fine and so should the other one do if its a reference.

    /Peter


    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    Friday, May 27, 2016 3:10 PM
  • Peter,

    I take it you did not read my reply, which says the same thing?


    Nosh Mernacaj, Identity Management Specialist

    Friday, May 27, 2016 3:16 PM
  • Was answering from within a mail, did saw you already replied. Your right you got it.

    Peter Stapf - ExpertCircle GmbH - My blog: JustIDM.wordpress.com

    Friday, May 27, 2016 3:23 PM
  • Great minds think alike! :)

    Nosh Mernacaj, Identity Management Specialist

    Friday, May 27, 2016 3:46 PM
  • HI,

    Thank you for providing options, while MS fix the bug.

    Regards,

    SK

    Monday, May 30, 2016 1:05 AM
  • While I hope they do fix it, I am not totaly sure this will be considered a bug. When you run a SQL query that returns one row, you get something saying (1rows). There are ways to do away and that is the important part. This is a framework not a an out of the box feature, so you can chose to use as you please. We need to understand that referencing an object is totaly different from most comon attributes.

    Nosh Mernacaj, Identity Management Specialist


    Monday, May 30, 2016 7:48 PM