none
Unable to enable Remoting with SSL on a Windows 2008 R2 server RRS feed

  • Question

  • When I run this command on a Windows 2008 R2 server, I get an error:

    winrm create winrm/config/Listener?Address=*+Transport=HTTPS@Hostname="REDACTED";CertificateThumbprint="REDACTED"}

    WSManFault
        Message
            ProviderFault
                WSManFault
                    Message = This resource requires the following selectors: Address Transport

    Error number:  -2144108453 0x8033805B
    The WS-Management service cannot process the request because the request contained invalid selectors for the resource.

    I have verified I have a proper certificate, signed by our internal CA, and the thumbprint is correct.  I used this same exact command on a Windows 2012 R2 server using the same certificate template to generate the CERT from our CA and it worked perfectly.  So I don't know if this a problem with that particular server or Windows 2008 R2 in general.

    Anyone else encountered this problem?

    Thanks

    NK

    Thursday, November 12, 2015 3:28 PM

Answers

  • You are missing a { in the command:

    winrm create  winrm/config/Listener?Address=*+Transport=HTTPS@ {
    Hostname="REDACTED";CertificateThumbprint="REDACTED"
    }


    \_(ツ)_/

    • Marked as answer by NJK-Work Thursday, November 12, 2015 6:50 PM
    Thursday, November 12, 2015 3:51 PM

All replies

  • You are missing a { in the command:

    winrm create  winrm/config/Listener?Address=*+Transport=HTTPS@ {
    Hostname="REDACTED";CertificateThumbprint="REDACTED"
    }


    \_(ツ)_/

    • Marked as answer by NJK-Work Thursday, November 12, 2015 6:50 PM
    Thursday, November 12, 2015 3:51 PM
  • EDIT: <snip>

    No longer needed, didn't see jrv's initial post.


    Thursday, November 12, 2015 3:53 PM
  • Arrrgg!!  I pride myself at not making stupid mistakes.  I cant believe I missed that...even the document I wrote up for my fellow workers has it in there...and I still missed it.

    Thanks for catching my typo.

    NK

    Thursday, November 12, 2015 6:54 PM
  • Thanks Mike.  JRV was able to solve my problem, but in the future I will be sure to post WinRM questions in the proper forum.

    Thanks and have a good weekend.

    NK

    Thursday, November 12, 2015 6:55 PM
  • Thanks Mike.  JRV was able to solve my problem, but in the future I will be sure to post WinRM questions in the proper forum.

    Thanks and have a good weekend.

    NK

    I hadn't actually seen jrv's post (we posted so close together that the forum wasn't in sync yet) when I posted. I removed my initial post, since jrv spotted the actual issue.

    Glad you got it worked out.


    Thursday, November 12, 2015 6:57 PM
  • For the record, I found another problem in the command. The HTTPS cannot be right next to the @ symbol - there has to be a space between them.  So the command should be:

    winrm create  winrm/config/Listener?Address=*+Transport=HTTPS @{Hostname="REDACTED";CertificateThumbprint="REDACTED"}

    and NOT

    winrm create  winrm/config/Listener?Address=*+Transport=HTTPS@{Hostname="REDACTED";CertificateThumbprint="REDACTED"}

    So I think I had two problems in my original command.

    NK

    Thursday, November 12, 2015 7:39 PM
  • Yes - the HTTPS is a designator that says to configure HTTPS using the following parameter which is delivered as a hash @{}.  The space is a delimiter that is required by all command parsers. The contents of the hash are name value pairs and are the named parameters of the HTPS configuration command.

    HTTPS @{
         Hostname="REDACTED";
         CertificateThumbprint="REDACTED"
    }


    \_(ツ)_/

    Thursday, November 12, 2015 7:51 PM