none
IE11 loses login when run as different user RRS feed

  • Question

  • I have the latest IE11 on win7 with all updates. After being sufficiently scared by ransomware reports, I decided to run IE isolated as a different user from my main desktop (standard UAC settings). The idea is whatever nasty comes in through the back door will only harm a fake normal user's "documents" and leave mine in peace!

    I can see in the task manager that there are a number of IE running processes all correctly set to that different user

    However, IE loses login information. For example, when I login to my yahoo account or a phpBB forum with the option "remember me and login automatically", it doesn't. If I keep the same tab active it is ok, but if I browse away to say google, and come back to the phpBB page, I have to login again. Which is a pain

    what can be wrong and is there any solution? thanks

    Friday, April 1, 2016 5:20 PM

All replies

  • Hi,

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com/en-us

    "remember me and login automatically" functionality relies on document cookies. Tools>Internet Options>Privacy tab.

    Autologin can also depend on your IE security zone settings.

    Tools>Internet Options>Security tab, click "Reset all zones to default"

    and the IE security zone that a site/domain is mapped to...

    For Home users...

    Trusted Sites icon, 'Sites' button.... Remove any sites you have placed in the Trusted Zone. (eg. Yahoo sites).

    Win7 has a built-in Guest account that has lower privileges than the default 'near administrator' default user... eg. no Addons, no cookies.

    If possible include with your questions to the answers forum links to any websites that you are having problems with.

    Regards.


    Rob^_^

    Monday, April 4, 2016 1:46 AM
  • Hi crack tracker,

    Based on your description, first please make sure IE doesn’t start in InPrivate Mode.

    It seems that your IE11 could not remember credentials.

    Please refer to the following link to check the result.

    Remember passwords and fill out web forms:

    http://windows.microsoft.com/en-us/internet-explorer/fill-in-forms-remember-passwords-autocomplete#ie=ie-11

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, April 4, 2016 9:22 AM
    Moderator
  • thanks for your replies, IE as far as I can tell is using all the defaults, and the only departure from normality is that it is being used as a different user (RUNAS). There are no problems when I run it as the desktop user. In fact today it doesn't lose any login credentials at all, so go figure! Intermittent faults are the worst of all :)
    Monday, April 4, 2016 10:36 AM
  • I think you could wait for several days and see if this problem will occur again, we are looking forward to your good news :)

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, April 5, 2016 1:12 AM
    Moderator