locked
Internet access through VPN RRS feed

  • Question

  • Hi all,

    I have a Surface Pro 2 and a shiny new Surface Book, both running Windows 10 v1511.  On the surface Pro 2, when connected to my client's PPTP VPN I have Internet access.  On the Surface Book I do not.  All of the network settings for the VPN connection are the same.  What am I missing?

    Thanks,

    Tim


    Tim in Dublin

    Thursday, January 28, 2016 3:17 PM

Answers

  • Hi TimInDublin,

    " If I clear the Use default gateway on remote network check box as MeipoXu suggested, I have access to the Internet, but then I have trouble accessing resources on the remote network."
    This is an expected behavior.

    If that option is enabled, all the network packages will go through the VPN. If the remote network is not allowed to connect to Internet, the local Internet will be blocked, too.

    To use Internet and the VPN resources at the same time, we could use the "route add " command line to add a static route record.
    For example, to add a static route to a network that has the IP address of 192.168.10.0, the subnet mask of 255.255.255.0, and the gateway (the first IP address of the range assigned to the static IP address pool) of 192.168.1.1, type the following command at the command prompt, and then press ENTER:
    route -p add 192.168.10.0 mask 255.255.255.0 192.168.1.1

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, February 2, 2016 5:57 AM

All replies

  • Are you receiving any error when you try to setup connection?

    Try disconnect one of your device and connect with other (only connect one of them) and check whether it works.

    Sometimes, VPN policy only accept one PC.

    Thursday, January 28, 2016 3:47 PM
  • I am not trying simultaneous connections.  The connection works on both machines.  One has Internet access, one doesn't.  The machine that doesn't have Internet access can access other machines on the remote network.  This appears to be a split tunnelling issue, except I didn't have to do anything special with the Surface Pro to get it to work properly.


    Tim in Dublin

    Thursday, January 28, 2016 7:10 PM
  • Windows+R -> cmd /k route print

    Do this while connected to the VPN on both machines.

    Are they identical?

    Thursday, January 28, 2016 7:36 PM
  • Hi TimInDublin,
    The main issue is that there is no internet connection when connected to a VPN, right? Are you using the built-in VPN?

    If you are using the built-in VPN, please check the following configuration.
    1.Double-click My Computer, and then click the Network and Dial-up Connections link.
    2.Right-click the VPN connection that you want to change, and then click Properties.
    3.Click the Networking tab, click Internet Protocol (TCP/IP) in the Components checked are used by this connection list, and then click Properties.
    4.Click Advanced, and then click to clear the Use default gateway on remote network check box.
    5.Click OK, click OK, and then click OK.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, January 29, 2016 6:58 AM
  • Hi MeipoXu,

    That setting is already in place.  As I mentioned in my original post, all of the network settings for the two machines are the same.

    Thanks,

    Tim


    Tim in Dublin

    Friday, January 29, 2016 8:29 AM
  • Hi The Grim,

    Almost completely identical (Interfaces and DHCP entries are different of course).  The major difference is that the Surface Book (which is the one I'm having trouble with) Has a persistent route which points to the gateway on the remote network:

      Network Address          Netmask  Gateway Address  Metric
              0.0.0.0          0.0.0.0      192.168.1.1  Default

    The other machine does not have this entry.  If I clear the Use default gateway on remote network check box as MeipoXu suggested, I have access to the Internet, but then I have trouble accessing resources on the remote network.

    And I thought I knew what I was doing :-)

    Thanks,

    Tim


    Tim in Dublin


    • Edited by TimInDublin Friday, January 29, 2016 8:37 AM
    Friday, January 29, 2016 8:36 AM
  • Hi TimInDublin,

    " If I clear the Use default gateway on remote network check box as MeipoXu suggested, I have access to the Internet, but then I have trouble accessing resources on the remote network."
    This is an expected behavior.

    If that option is enabled, all the network packages will go through the VPN. If the remote network is not allowed to connect to Internet, the local Internet will be blocked, too.

    To use Internet and the VPN resources at the same time, we could use the "route add " command line to add a static route record.
    For example, to add a static route to a network that has the IP address of 192.168.10.0, the subnet mask of 255.255.255.0, and the gateway (the first IP address of the range assigned to the static IP address pool) of 192.168.1.1, type the following command at the command prompt, and then press ENTER:
    route -p add 192.168.10.0 mask 255.255.255.0 192.168.1.1

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, February 2, 2016 5:57 AM