Microsoft.ACE.OLEDB.16.0 provider is not registered on the local machine. (System.data) RRS feed

  • Question

  • Trying to import data from Excel is giving this message.

    Office365 64-bit

    Here's what I tried:

    1) I installed the 64-bit Access database engine 2016

    2) I tried the 2010 & 2007 versions as well

    3) I reinstalled Office365

    I'm out of ideas. What else could be going on here?

    Monday, October 8, 2018 8:53 PM


All replies

  • I believe that you need this guy: https://www.microsoft.com/en-us/download/details.aspx?id=54920

    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    • Proposed as answer by Puzzle_Chen Tuesday, October 9, 2018 8:22 AM
    • Marked as answer by Olaf HelperMVP Saturday, November 10, 2018 6:25 AM
    Monday, October 8, 2018 9:05 PM
  • If you already installed the 64-bit Acess Database Engine 2016 and still have the same problem, you can try opening - the 64-bit  "SQL Server Import and Export Data" directly, out of Management Studio. It worked for for me:

    - Close SQL Server Management Studio

    - Go to Start Menu -> Microsoft SQL Server 2017 ->  SQL Server 2017 Import and Export Data (64-bit)

    - Open the application and try to import data using the "Excel 2016" option, it should work fine.

    Hope this helps.


    • Proposed as answer by Eric-K Saturday, April 27, 2019 7:05 PM
    Monday, February 25, 2019 4:55 PM
  • The above steps did worl for me also. It still is strange that it didnt work from whitin SSMS. Thanks for the answer.

    Btw i did not close SSMS, and it worked fine.

    Saturday, April 27, 2019 7:07 PM
  • I tried all of these and am still getting the same error.

    Tuesday, May 7, 2019 4:58 PM
  • This solution worked for me.  I didn't need to close SQL Management Studio either.

    Thank you.

    Wednesday, July 3, 2019 4:26 PM
    • Edited by Syed_Rabbani Tuesday, August 13, 2019 4:51 PM included more
    Tuesday, August 13, 2019 4:17 PM
  • Thanks for the suggestion.  SSMS wouldn't work, but using the Import-Export Wizard worked just fine.  All my selections were the same, but I-X Wizard worked w/o returning an error.


    Monday, September 30, 2019 9:26 PM
  • It worked fine for me ! Thanks for the suggestion
    Wednesday, October 2, 2019 7:35 PM
  • Hello it works, but how can I see my import files .xlsx on sql server?


    Thursday, October 10, 2019 6:43 PM
  • This worked on me
    Thursday, November 28, 2019 12:03 PM
  • Thanks 

    this worked for me.

    • Edited by Mayank Jars Friday, January 24, 2020 2:26 AM
    Friday, January 24, 2020 2:25 AM
  • C:\AccessDatabaseEngine.exe /quiet worked for me!
    Wednesday, February 26, 2020 7:34 AM
  • If you have already installed the Access Redistributable but still have problems, here is a remedy I discovered:

    (1) On the taskbar, click Windows and scroll down the installed apps to 'Microsoft SQL Server YYYY' (where YYYY is the year) and click it. 

    (2) A short list of apps should appear underneath. One of them should be 'SQL Server YYYY Import and Export'.

    (3) Click that and the DTS Wizard runs. I was able to import data from Excel 365 without any problems.

    It appears that running the wizard outside of SSMS solves the problem.


    Sunday, June 21, 2020 3:33 AM