locked
Receive connector with MTLS RRS feed

  • Question

  • Hi,

    I have SMTP; Authentication failed during Mail from E2016 NDR to using Exchange 2016 receive connector with MTLS enabled.

    It is working in Exchange 2010 receive connector.  Here are the settings,

    1. Permission Groups

    Anonymous users & Partners

    2. Authentication

    Transport Layer Security (TLS) & Enable Domain Security (Mutual Auth TLS)

    3. Get-TransportConfig |fl TLSReceiveDomainSecureList,TLSSendDomainSecureList

    TLSReceiveDomainSecureList : {partners.domain.sg}

    TLSSendDomainSecureList : {partners.domain.sg}

    4. SAN cert

    mail.domainA.sg

    autodiscover.domainA.sg

    exchange2016.domainA.sg

    domain.sg

    Please advise.


    Kelvin Teang

    Monday, July 31, 2017 7:20 AM

All replies

  • Hi Kelvin,

    What is the detailed error? 

    In Exchange 2016, there are two types of receive connectors, FrontendTransport and HubTransport, which type did you use?

    In general, the frontendTransport receive connector is used to accept anonymous and authenticated SMTP connections into your Exchange organization, please create a frontendtransport connector and enable domain security(Mutual Auth TLS) to check again.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Niko.Cheng Tuesday, August 1, 2017 7:31 AM
    Tuesday, August 1, 2017 7:29 AM
  • Hi Kelvin,

    Just checking in to see if above suggestion was helpful ? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

     

    Thanks for your understanding.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 3, 2017 8:33 AM
  • Hi Niko,

    Yes, I created frontendtransport connector and enabled domain security(Mutual Auth TLS). 

    Received  SMTP; Authentication failed during Mail from E2016 after enabled domain security(Mutual Auth TLS). 


    Kelvin Teang

    Friday, August 4, 2017 8:25 AM