locked
Cannot connect to Analysis Services instance RRS feed

  • Question

  • Hi,

    I'm new to analysis services and have been following through the tutorials here http://msdn.microsoft.com/en-us/library/ms170208(v=sql.100) for SQL Server 2008.

    I've tried to deploy in visual studio 2008 and it gives an error saying it cannot connect. I've got sql server 2008 installed and I attached the 2008 Adventure Works database to my local default SQL instance. I can connect via management studio Ok. Also, when creating the data source in visual studio I hit the "Test Connection" button which was also OK.

    In management studio when I hit the connect drop down button in the Object Explorer, I get the option to connect to Analysis Services. When I do this it comes up with the server name "(local)" and uses Windows Authentication (I'm logged on to Windows as Administrator). However, this fails with the following message "Cannot connect to (local). A connection cannot be made. Ensure that the server is running. (Microsoft.AnalysisServices.AdomdClient)"

    I'm really stuck on this - has anybody got any ideas what might be going on? 

    Cheers

    Wednesday, August 8, 2012 3:06 PM

Answers

  • So you have SSAS running on your local machine? When you installed it, did you add yourself as an Administrator on the SSAS Instance? (part of the setup process).

    Try putting in your Machine name in place of "(local)" or try browsing to it.

    Have you run SQL Server Configuration Utility to see if the service is even running?


    Todd C - MSCTS SQL Server 2005, MCITP BI Dev 2008 Please mark posts as answered where appropriate.

    • Marked as answer by Eileen Zhao Tuesday, August 28, 2012 7:52 AM
    Wednesday, August 8, 2012 5:36 PM
  • As Todd mentioned, check whether the SSAS Instance is running. Also check whether you have a default instance or named instance. In case of named instance you have to provide also the instance name, when connecting in the form (machineName\InstanceName) or for local instance (locahost\InstanceName) or (.\instance name).

    To determine instance name, launch SQL Server Cofinguration manager ans check SQL Server Services. The instance name is in the Parentheses listed.

    If you have installed the instance and forgot to add yourselves as an administrator of the instance, and have UAC enabled, you have to Lanuch the SSMS as an administrator to rise the priviledges. Then connect to the instance and add your username explicitly as administrator of the instance.

    • Marked as answer by Eileen Zhao Tuesday, August 28, 2012 7:52 AM
    Thursday, August 9, 2012 5:21 AM

All replies

  • So you have SSAS running on your local machine? When you installed it, did you add yourself as an Administrator on the SSAS Instance? (part of the setup process).

    Try putting in your Machine name in place of "(local)" or try browsing to it.

    Have you run SQL Server Configuration Utility to see if the service is even running?


    Todd C - MSCTS SQL Server 2005, MCITP BI Dev 2008 Please mark posts as answered where appropriate.

    • Marked as answer by Eileen Zhao Tuesday, August 28, 2012 7:52 AM
    Wednesday, August 8, 2012 5:36 PM
  • As Todd mentioned, check whether the SSAS Instance is running. Also check whether you have a default instance or named instance. In case of named instance you have to provide also the instance name, when connecting in the form (machineName\InstanceName) or for local instance (locahost\InstanceName) or (.\instance name).

    To determine instance name, launch SQL Server Cofinguration manager ans check SQL Server Services. The instance name is in the Parentheses listed.

    If you have installed the instance and forgot to add yourselves as an administrator of the instance, and have UAC enabled, you have to Lanuch the SSMS as an administrator to rise the priviledges. Then connect to the instance and add your username explicitly as administrator of the instance.

    • Marked as answer by Eileen Zhao Tuesday, August 28, 2012 7:52 AM
    Thursday, August 9, 2012 5:21 AM
  • I had the same issue. 

    I solved my problem by uninstalling the version of SQL server edition I had and installing SQL Server 2012 Evaluation Edition.

    You can use this link: http://www.microsoft.com/en-us/download/details.aspx?id=29066


    Platt

    Friday, September 5, 2014 3:25 PM