none
BizTalk 2013 Sso Mmc Snapin does not show key pairs. RRS feed

  • Question

  • Hi, we successfully installed the SSOMMCSNAPIN.MSI and connected to our SSO system on Bts 2013 CU1.

    We can add a new application (right click, add app) and even add key value pairs in this new app. However. The key value pairs are not shown in the mmc. it keeps on telling "There are no items to show in this view".

    I started digging in the SSODB and found our newly created application in the [SSODB].[dbo].[SSOX_ApplicationInfo] table.

    I also found the Key Value pair in the  [SSODB].[dbo].[SSOX_FieldInfo] table.

    I also noticed that adding multiple keypairs (blindly) results in only one record  in the fieldinfo table and that the previous entry is removed somehow... 

    Are we missing something ?

    Br

    Kristof DM


    Www.visionsofnight.com

    Monday, June 24, 2013 12:53 PM

Answers

All replies

  • Is it possible you have run into the issue with the tool not returning the first key/value-pair in the list as Richard Seroter writes about in the post covering his administration tool? http://seroter.wordpress.com/2007/09/21/biztalk-sso-configuration-data-storage-tool/

    Quote: This is because if every case I’ve tested, the SSO query API doesn’t return the first property value from the database. Drove me crazy. So, I put a “dummy” in there, so that you’re always guaranteed to get back what you put in

    Monday, June 24, 2013 2:24 PM
  • Have you tried the MMC snap in for SSO?

    It is provided by Microsoft for SSO management.

    http://www.microsoft.com/en-us/download/details.aspx?id=14524


    Jean-Paul Smit | Didago IT Consultancy
    Blog | Twitter | LinkedIn
    MCTS BizTalk 2006/2010 + Certified SOA Architect

    Please indicate "Mark as Answer" if this post has answered the question.

    Monday, June 24, 2013 3:04 PM
  • Hi Marcus,

    I downloaded the tool as it looked very promissing.

    After rebuilding it on .net 4.5 it seems to be working. Now we can add multiple Fields to an SSO app and retrieve them !

    However, importing configurations (using an XML defitnition) with Values already in the parameters seems a 'No GO'. Perhaps we'll look in to the source code to change this behaviour!  For the time being, this is sufficient. 

    Thanks for the Tip !

    Br

    Kristof DM



    Www.visionsofnight.com

    Tuesday, June 25, 2013 9:36 AM
  • Unfortunately the Microsoft one also seems to have an issue in 2013, see SSO MMC snap in for BizTalk 2013
    Friday, July 26, 2013 3:25 AM
  • hi

    I had the same issue as stated above and with the below URL I was able to resolve the issue.

    http://biztalkorchestration.blogspot.com.au/2016/01/unable-to-add-key-in-sso-application.html

    I did tried solution 1 but it din't work for me ..so I downloaded the dll and replaced both the SSOMMCSnapIn.dll.config and SSOMMCSnapIn.dll which did the trick..

    Hope it helps someone..

    thanks & regards

    Silam

    Monday, April 10, 2017 1:27 AM