none
"No Audio Output Device is installed" on Win7 Remote Desktop Connection RRS feed

  • Question

  • all settings in the options menu of RDC have been confirmed (play sound locally is selected)

    However, once connected there is a red/white "X" on the speaker icon in the taskbar of the remote PC and states "No Audio Output Device is installed" & I am unable to troubleshoot or configure sound settings. I removed all audio cables & restarted the remote PC as well. 

    Wednesday, December 6, 2017 5:53 PM

All replies

  • Hi,

    Is that you set the remote audio playback as following screenshot?

    Please check if the audio that on your current PC is fine.

    I did a test if the Allow audio and video playback redirection group policy is disabled on remote PC, it will show "No Audio Output Device is installed" on remote PC.

    Did the PC join the domain?

    If yes, please take following steps to see if the Allow audio and video playback redirection group policy is disabled on your remote PC.

    1. Open Command Prompt (as administrator).

    2. Type gpresult /h c:\gpreport.html  (press Enter)

    If no, please take following steps to see that group policy.

    1. Type gpedit.msc in search box, and press Enter.

    2. Find Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection

    3. Double click Allow audio and video playback redirection on right panel.

    4. Set the policy to enable or not configured.

    Please try to use other PC to RDP that remote desktop to see if it can work.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Vera Hu Friday, December 8, 2017 1:23 AM
    Thursday, December 7, 2017 6:50 AM
  • I'm having the exact same issue as described in the original post.

    Running Windows 10 Pro 2017 on the PC I'm connecting *with* and Windows 10 Pro 2018 on the PC I'm connecting *TO*.

    I am connecting from a home computer to a work computer and therefore signing on to their domain.

    RDC client Remote Audio Playback settings confirmed to be "Play on this computer"

    Also tried the above group policy fix. It was set to 'not configured', but just in case, I changed it to "enable".

    I clicked "apply", closed the dialogue box, and upon re-entering confirmed the setting had in fact taken hold, and showed as "enable".

    Still no sound on remote connection. I also tried closing out the connection and reconnecting. 

    No sound.

    Any other ideas?


    • Edited by aaeryhn Saturday, October 13, 2018 5:05 PM
    Saturday, October 13, 2018 5:04 PM