locked
Published Report vs SharePoint Document Library Issues RRS feed

  • Question

  • Afternoon all,

    Can anyone give me a run down of the common pitfalls that can happen when publishing a PPS report to a SharePoint site?  I've created a sample dashboard that has an analytic grid and a scorecard.  I publish these so that I can preview them, which appears to work fine on a standalone preview (http://sharepoint:40000/Preview/) but not when I publish to a specific SharePoint Site.  

    The target site has the definition and the PerformancePoint web part installed but upon navigating to the SharePoint housed page, I see two errors that aren't present in the standalone preview, namely: -

    1. I don't have permission to view the data in the analytic grid
    2. The scorecard has errors when rendered, it appears like it can't call the data from my data cube.
    I've checked permissions, which I believe to be fine, I've accounts fully permission within SharePoint that have access to the Dashboard designer.

    Any pointers would be appreciated.


    http://www.final-exodus.net
    Friday, August 27, 2010 2:31 PM

Answers

  • The instructions I have for this are as follows and this is assuming default install and using default web site:

    1.      Modify the web.cofig files on the server for the PPS Preview, PPS Web Service, and SharePoint sites.  This is needed to be able to setup the security to pass the users credentials to the database for access the Analysis Services data instead of using the identity setup to run the PPS or SharePoint application pools.

    a.      Change the appSetting for Connection Per User setting to True instead of False

                                              i.     <add key="Bpm.ServerConnectionPerUser" value="False" />

    1.      This will have to be done in three locations

    a.      Preview - C:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview

    b.      Web Service - C:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\WebService

    c.      SharePoint site - C:\Inetpub\wwwroot\wss\VirtualDirectories\80

    Once you have this modified it should work as expected.  You can compare your settings between the Preview and SharePoint site, just make sure that you modify the setting in all three places so it is consistent.


    Dan English's BI Blog
    • Edited by Dan English Friday, August 27, 2010 4:30 PM removed extra content for distributed environment
    • Marked as answer by Heidi Tr - MSFT Friday, September 3, 2010 2:28 PM
    Friday, August 27, 2010 4:28 PM

All replies

  • Is this a sandbox, single server, setup or distributed?  If the SharePoint and SSAS are on separate boxes then you will need to look at leveraging Kerberos with Per User security setting or explore the Cutom Data setup with PPS authentication.  If preview is on same box as SharePoint then it should work though.  Maybe you simply need to go into the SharePoint web.config file and enable the Per User security setting.

    You can also run a Profiler trace on SSAS to see the credentials that are being passed, but most likely it could be the web.config file setting.


    Dan English's BI Blog
    Friday, August 27, 2010 2:44 PM
  • They're all on a standalone development box, so there's no cross server communication going on.  Although, the config file alterations I've not heard of.  Have you any links that detail these changes further?
    http://www.final-exodus.net
    Friday, August 27, 2010 2:46 PM
  • If you take a look at the web.config file in your Preview directory you will most likely see that the value bpm.serverconnectionperuser was set to True.  Make sure you use a basic editor like Notepad when making the change and also make a backup of the config file prior to making any changes.

    This setting has to be made for the Preview, PPS WebService, and SharePoint directories in 2007 version.  You do not need to perform an IIS Reset for this change, it will occur right away after you refresh your page.

    Here are a couple of links that discuss this in regards to configuring Kerberos to get the PerUser setting working.  Kerberos is only needed in a distributed environment setting though.  In a sandbox you will be okay.

    http://technet.microsoft.com/en-us/library/dd630733(office.12).aspx

    http://technet.microsoft.com/en-us/library/bb838742(office.12).aspx


    Dan English's BI Blog
    • Edited by Dan English Friday, August 27, 2010 3:01 PM added links
    Friday, August 27, 2010 2:58 PM
  • Hi Dan,

    Currently this setting is set to False and there's only one instance of it.  I've set this to false and it still didn't work.  The settings I've modified are as below: -

    <appSettings>
      <add key="Bpm.ServerConnectionPerUser" value="True"/>
      <add key="Bpm.MaxFileTitleLength" value="15"/>
      <add key="Bpm.IndicatorImageCacheTime" value="10"/>
     </appSettings>
    
    The same permissions denied issue came up.


    http://www.final-exodus.net
    Friday, August 27, 2010 3:53 PM
  • The instructions I have for this are as follows and this is assuming default install and using default web site:

    1.      Modify the web.cofig files on the server for the PPS Preview, PPS Web Service, and SharePoint sites.  This is needed to be able to setup the security to pass the users credentials to the database for access the Analysis Services data instead of using the identity setup to run the PPS or SharePoint application pools.

    a.      Change the appSetting for Connection Per User setting to True instead of False

                                              i.     <add key="Bpm.ServerConnectionPerUser" value="False" />

    1.      This will have to be done in three locations

    a.      Preview - C:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\Preview

    b.      Web Service - C:\Program Files\Microsoft Office PerformancePoint Server\3.0\Monitoring\PPSMonitoring_1\WebService

    c.      SharePoint site - C:\Inetpub\wwwroot\wss\VirtualDirectories\80

    Once you have this modified it should work as expected.  You can compare your settings between the Preview and SharePoint site, just make sure that you modify the setting in all three places so it is consistent.


    Dan English's BI Blog
    • Edited by Dan English Friday, August 27, 2010 4:30 PM removed extra content for distributed environment
    • Marked as answer by Heidi Tr - MSFT Friday, September 3, 2010 2:28 PM
    Friday, August 27, 2010 4:28 PM