locked
Content Organizer Rules with Document Set. RRS feed

  • Question

  • Hi All,

    I created a Content Organizer rule for Document set. Rule is triggered when the documents are in Drop Off Library. Document sets are moving to the target library as per the rule in the form of ZIP FORMAT. I have 2 questions here:

    1. The format of the document library with document set is changing from DocumentSet Collection to  ZIP format which is not acceptable to the Business User. Is there any other way to do it?

    2. The DocumentSets which are not matching the rule are still present in Drop Off Library. I would like them to move them again to Source Library without ZIP format. How is it possible?

    Regards,

    Seema

    Monday, May 27, 2013 9:04 AM

Answers

  • Hi Seema,

    Ensure your Document ID service and Document set feature is activated in the site.

    Next ensure the Document set content type is also enabled on the site, and send the Document set as unpackaged to the drop off library. Here is a short article on how to set this up correctly.
    http://www.sharepointanalysthq.com/2011/02/routing-document-sets-in-sharepoint-2010/
    on your second issue, nothing out of the box will accomplish this, you will need to specify a content orginizer to go through the drop off library and manually move the items either back to the original site or to an appropriate library in the site.

    Regards, Pieter
    MCPD | MCITP

    My Blog

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by seema.thakur Wednesday, June 5, 2013 10:58 AM
    Monday, May 27, 2013 10:17 AM
  • The article I sent previosuly, did you also pay attention to the do's and don'ts?

    For me it sounds like you deleted the "Packaged" content type from the drop off library. Could you please run through the article?

    Regards, Pieter
    MCPD | MCITP

    My Blog

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by seema.thakur Wednesday, June 5, 2013 10:57 AM
    Friday, May 31, 2013 8:59 AM

All replies

  • Hi Seema,

    Ensure your Document ID service and Document set feature is activated in the site.

    Next ensure the Document set content type is also enabled on the site, and send the Document set as unpackaged to the drop off library. Here is a short article on how to set this up correctly.
    http://www.sharepointanalysthq.com/2011/02/routing-document-sets-in-sharepoint-2010/
    on your second issue, nothing out of the box will accomplish this, you will need to specify a content orginizer to go through the drop off library and manually move the items either back to the original site or to an appropriate library in the site.

    Regards, Pieter
    MCPD | MCITP

    My Blog

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by seema.thakur Wednesday, June 5, 2013 10:58 AM
    Monday, May 27, 2013 10:17 AM
  • Hi Pieter,

    Thanks for the Update. Its working fine when the Content type is DocumentSet. But in my case, I have a custom Content Type, which uses DocumentSet as one of the column. The file is remaining in ZIP format and not changing back to Document Collection type.

    Thanks,

    Seema.

    Monday, May 27, 2013 10:37 AM
  • "which uses DocumentSet as one of the column" Could you explain this?

    Regards, Pieter
    MCPD | MCITP

    My Blog

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Monday, May 27, 2013 10:52 AM
  • Hello Pieter,

    Document ID service and Document set feature is activated in my site. Also Document set content type is enabled on the site. But still the document set is present in the Drop Off Library in the ZIP format. Its moving to the correct location when we manually use SENDTO option.Timer job is  set to one minute.. I wonder why the Timer job is not moving it..Please comment.

    Thanks,

    Seema.

    Thursday, May 30, 2013 3:48 PM
  • The article I sent previosuly, did you also pay attention to the do's and don'ts?

    For me it sounds like you deleted the "Packaged" content type from the drop off library. Could you please run through the article?

    Regards, Pieter
    MCPD | MCITP

    My Blog

    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    • Marked as answer by seema.thakur Wednesday, June 5, 2013 10:57 AM
    Friday, May 31, 2013 8:59 AM