locked
Cannot upload/sync jar file RRS feed

  • Question

  • When I sync'd a folder of java files, everything synchronized from my local drive to my OneDrive for Business, except for a single file. It is a .jar file and is only 111k in size. I can add a different file to that folder, I can try to sync it again, but the error message remains the same:

    Please get in touch with your help desk to change or restore your permissions on the server to allow you to upload files.

    I also have a personal OneDrive account that sync'd this same folder structure (it's the activities for a lab designed for AP Computer Science - one directory has a .jar file in it).

    I am the administrator for the SharePoint site, so I can probably change whatever I need to change, but I do not know where to look to allow .jar files.  BTW, I tried with a different jar file: syncs just fine on the personal OneDrive account, disallowed on the OneDrive for Business account.

    If someone could point me to the screen that lets me allow/disallow file types, I'd be ever so grateful.

    Cheers!

    Saturday, January 17, 2015 8:47 PM

Answers

All replies

  • Are there any special characters in the file name?

    http://support.microsoft.com/kb/2933738

    .jar is not blocked by default, but could have been blocked by your SharePoint server administrators.


    Mike Smith TechTrainingNotes.blogspot.com
    Books: SharePoint 2007 2010 Customization for the Site Owner, SharePoint 2010 Security for the Site Owner

    Saturday, January 17, 2015 10:57 PM
  • Thanks for the reply.  The file name is simply "elevens.jar", and is a file that is distributed by the College Board.  I mention this in case anybody wants to download and experiment with the exact same conditions as mine.

    Anyway, the file should be allowed and is not.  Any .jar file I try to sync, fails. If I rename the file to something like "elevens.zip", then it syncs just fine.  I cannot rename it back to elevens.jar, though.

    This only occurs with OneDrive for Business 2013.  I have this because my school offers Office 365 for free.  We sign up with our eligible email address and gain access to Office 365 and Office 2013.  I also have, installed on the same laptop, OneDrive that comes with my free year of Office 365.  I *can* copy a .jar file to that account.  My laptop is Windows 8.1.

    I have the school-issued Office 365 software installed on my desktop, running Windows 7 Professional, 32-bit.  I cannot sync a .jar file there either, so I have at least determined that the client is not causing an issue.

    As far as I can tell, I am the administrator for the SharePoint system, which is all "in the cloud".  Once I signed up for the free Office 365 software, I became the administrator.  At least, I can manage users and groups and permissions and so on and so forth.  I figure there  must be a screen somewhere that would allow me to control filetypes for the system.  For example, what if I wanted to remove access to .doc files because I was tired of enabling users of old software?  What button would I press to do this?  Chances are, wherever that button resides, there also resides an extensions list just begging to be managed.

    Saturday, January 24, 2015 7:14 PM
  • Sigh - I created the question as MSMcCue, and apparently I've posted a reply as msmccue6010.  Dunno why I have two different accounts when I know I'm logging in with a single username.  I'm sure I'll figure it out.  In the meantime, please accept my apologies - I'm really the same person!

    Mike

    Saturday, January 24, 2015 8:22 PM
  • You didn't mention Office 365 in your first message. With on premise your server admin can modify the blocked file list, and could have added .jar to that list. You cannot manage the blocked file list in Office 365, but the list of blocked files is short: .ashx, .asmx, .asp, .aspq, .axd, .cshtm, .chtml, .json, .rem, .shtm, .shtml, .soap, .stm, .svc, .vbhtm, .vbhtml, .xamlx  (this page says there's a shorter list: https://support.office.microsoft.com/en-us/article/Types-of-files-that-cannot-be-added-to-a-list-or-library-30be234d-e551-4c2a-8de8-f8546ffbf5b3?CorrelationId=5f571e95-e966-465a-a9e5-4b1502b4b038&ui=en-US&rs=en-US&ad=US)

    I just uploaded a test file named elevens.jar to my Office 365 tenant to both a SharePoint library and to a OneDrive for Business library. Both worked just fine.

    Maybe there's something inside of the file that's causing the block. Try uploading a file with the same name, of about the same size, but with random text.


    Mike Smith TechTrainingNotes.blogspot.com
    Books: SharePoint 2007 2010 Customization for the Site Owner, SharePoint 2010 Security for the Site Owner

    Sunday, January 25, 2015 6:14 AM
  • Hello,

    I am having the same problem as you were having with uploading .jar files.  Did you ever find a resolution to your problem?  I can't believe they block certain file extensions.  (Also, they won't allow you to use a "#" in a filename, even though the MS OS allows it!)

    Any help would be greatly appreciated!

    Thursday, September 3, 2015 11:10 PM
  • I don't know if this will help anyone but I had the same problem.  When I changed the extension of the file I could upload it to SP2013.  When I changed it back it would not upload.  The problem was blocked file types but if you have a look in blocked file types you will not see it in there.    What I think is happening is that your PC sees the .jar file as a javescript file which is blocked (jse).  The icon/file association was that of a jave file.   I just went to another machine which did not have java installed, the icon of the file was now blank and I was able to upload the file.
    Friday, January 6, 2017 10:38 PM