none
UAC won't stay disabled RRS feed

  • Question

  • I've been having problems with UAC on Windows 7 Pro for a couple months now. I need UAC disabled because it interferes with some enterprise software. The rest of the computer is locked down, so I don't need UAC to control access or elevation. 

    When I first set up the computer, I can disable UAC and it will stay off.

    Once I run Windows Update (including the Malicious Software Removal Tool, which I suspect has something to do with this) and restart the computer, however, the following things start happening:

    User account control is inaccessible from the control panel. (it pops a blank white window under the control panel window)
    The registry key "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies" and all its subkeys are missing entirely.
    I get access control popup windows for changes to programs and settings, but no secure desktop, and a batch file that is supposed to edit C:\Program Files\*stuff* and C:\ProgramData\*stuff* comes back with insufficient permissions unless it is explicitly run as an Administrator. 

    If I manually add the key ...\Policies\System\ and the DWORD value LUAEnable = 0, then I can access UAC from the control panel again, but the level is set to maximum security. 

    If I simply restart from here (with the correct registry key in place, without touching the control panel), when Windows comes back up, the registry key "Policies" is completely gone again. I get the same result if I change the slider in the Control Panel to its minimum level before restarting, as well.

    If I change the Group Policy settings through GPEdit.msc, I get the same results.

     

    How on Earth can I keep UAC disabled? What keeps deleting that registry key every time my computer boots?

    Monday, October 24, 2011 9:45 PM

All replies

  • Hi,

     

    I would like to verify if the computer is in domain. If so, the group policy is controlled in AD. The configuration on local cannot be applied and will reverse after reboot.  

     

    If the computer is in domain, please post in the following forum.

    http://social.technet.microsoft.com/Forums/en-US/winserverGP/threads

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, October 26, 2011 9:35 AM
    Moderator
  • I was using GPAnywhere, actually, and the issue seems to be originating there. Thanks for taking a look.
    Thursday, October 27, 2011 3:35 PM