none
Project Server 2013 Workflow Submit Button Greyed Out RRS feed

  • Question

  • Hi I am trying to build a workflow for demand management, using SPD 2013.

    The workflow is a simple 3 stage affair.

    It seems to publish ok, I applied it to the EPT ok, can create a project ok, but cannot submit to stage 2 as the submit button is greyed out?

    Newbie, any ideas?

    Wednesday, August 7, 2013 3:57 PM

All replies

  • Anyone know?
    Thursday, August 8, 2013 7:01 AM
  • Hi,

    I worked on a similar issue where the submit button is greyed out. We found that workflow history list was deleted.

    We have recreated the workflow history list to resolve the issue.

    Check if you can access the workflow history list. Below is the link to workflow history list (change the URL as per your PWA name and server name).  

    http://Servername/PWA/lists/Workflow%20History

    Thursday, August 8, 2013 10:41 PM
  • Hi,

    Did you manage to sort this out? 

    Do you have any required custom fields set up on the PDP's in your first stage that had not been completed? 


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Thursday, August 15, 2013 3:03 AM
    Moderator
  • Hi guys

    Sorry for slow reply, I am using a web admin account, and creating a new tasks list doesn't seem to help.

    I can confirm there are no required fields yet. Just trying to get the process running in its most simple form.

    So submit button still greyed out...

    Any other ideas?

    Monday, August 19, 2013 2:53 PM
  • Anyone know? Still scratching our heads. The workflow basically has this;

    • Stage 1 waits for project be submitted, then goes onto stage 2
    • Stage 2 waits for project to be commited, then goes into stage 3
    • Stage 3 waits for project to be commited, then the end of workflow is set
    Tuesday, August 20, 2013 8:18 AM
  • There is no workflow tasks going in the tasks list or history list for that matter, does that give any indication of whats going on?
    Tuesday, August 20, 2013 9:29 AM
  • Assuming its in progress, check if it fails eventually, I think using the system account for the workflow causes a HTTP 401 error which might cause this.

    Tuesday, August 20, 2013 9:39 AM
  • How do I change what account initiates the workflow? Says system account
    Tuesday, August 20, 2013 5:28 PM
  • I know this is VERY old but in case someone still has errors this worked for me

    https://msdn.microsoft.com/en-us/library/office/jj822159(v=office.15).aspx


    Tasks

    Sunday, February 28, 2016 8:42 AM