none
Possible Autodiscover issue

    Question

  • I posted this question on the Microsoft techcommunity forums, and they redirected me here. 

    The problem is we are unable to collect any data from Microsoft Exchange from within Excel or Power BI. The message is always the same: "Unable to connect"

    When I do the autodiscover tests from Microsoft, (alsmost) everything seems to be working fine. When I configure a new account in Outlook, autodiscover works perfect.

    I was planning to attach screenshots and Power BI trace logs but since my account istn't verfied yet, I can't...


    Wednesday, April 19, 2017 11:28 AM

Answers

All replies

  • If you're using excel I'd ask over here.

    https://social.technet.microsoft.com/Forums/office/en-US/home?forum=excel

    or for Power BI over here.

    https://social.technet.microsoft.com/forums/en-us/home?category=powerbi

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Thursday, April 20, 2017 3:00 PM
  • Hi,

    Would you please tell us that which application you used to collect data?

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 20, 2017 4:14 PM
    Moderator
  • The main reason why I used Power BI to collect data was to exclude the problem was not with Excel only. 

    What happend was: somebody inside the organisation was trying to open the 'Email insights' template in Excel. Because it didn't work the question came to me, when I tried to do the same thing, It didn't work either.  So I tried to connect to Exchange Online from within Power Bi (as suggested).

    https://ibb.co/hkT5BQ

    So now we concluded that there is a possible autodiscover issue. Its working for Oulook, mailboxes are automatically detected, but for Excel and Power Bi, its not.

    Friday, April 21, 2017 12:06 PM
  • Hi,

    You may check whether any related events are logged to further troubleshoot the issue.

    In addition, I suggest you also refer to dedicated Excel and PowerBI forums posted by Dave to get more efficient support.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 25, 2017 9:52 AM
    Moderator
  • I reposted to same queston in the Excel forum. I guess this topic can be closed then.

    Thanks for your help
    Tuesday, April 25, 2017 9:59 AM