locked
Opening files from a Novell-Share takes about ten seconds RRS feed

  • Question

  • Hi there,

    first a few information about our environment:

    • Windows 7 Enterprise SP1 Clients with Novell Client installed in latest version
    • Windows Server 2008 R2 DCs
    • Network-shares based on Novell Netware

    When accessing files on Novell-Shares for the first time it takes about 10 seconds to open. Reopening it or any other file at this location again is totally fast. Waiting about 15 minutes after closing the file causes the lag again.

    We traced our client-side network traffic and saw many Netbios-queries which failed because our WINS-Servers do not know the Netware-Servers. So first it tried it using every WINS-Server (three in our env.) and then on broadcast in the local subnet three times. It got no answer and timed out.

    So the next step I tried was to disable Netbios-over-TCP/IP with the radio buttons in the Network Adapter settings. After a reboot, the problem reoccured, but there were no more Netbios queries in the trace.

    After days of searching for a solution I tried to stop the "TCP/IP-Netbios-Helper"-Windows Service on spec. And suddenly every network share access was totally fast. We tried this with other clients, too. Same behavior! We even did not disable the NetBios-over-TCP/IP setting. Stopping the service was all we needed to do.

    Unfortunately disabling the service causes problems. The Windows-Login fails with a message "No Logon servers available". Using the full qualified user name ("user@local.domain.com") works. But then we saw that policies were not applied.

    Any ideas, what could cause the lag? Or is it possible to disable this service without any side-effects?

    Bye,
    Jürgen

    Friday, August 8, 2014 6:06 AM

Answers

  • Hi,

    we already tried it with Windows-shares on servers joined to our domain. There we had no performance issues.

    And we already found the referenced Novell-article, too. So we tried to change the provider order already... without success.

    But:
    We found a solution!

    The problem was on my PC. I have VMware Workstation installed with two additional virtual network adapters. I disabled "Netbios-over-TCP/IP" on my primary network adapter, but I forgot to disable it on those adapters.

    So after disabling it on the virtual adapters too, every access to a Novell-share is fast. I don't need to disable the service anymore.

    Thanks for your help!

    Tuesday, August 12, 2014 1:21 PM

All replies

  • 1. Disabling some services may change firewall settings.

    2. Detailed network traffic analysis is needed as well as audit in AD.

    3. One reason for our abandoning NetWare was time lag (at that time 25s with current NW client.)

    Rgds

    Milos

    Friday, August 8, 2014 6:41 AM
  • 1. Disabling some services may change firewall settings.

    2. Detailed network traffic analysis is needed as well as audit in AD.

    3. One reason for our abandoning NetWare was time lag (at that time 25s with current NW client.)

    Rgds

    Milos

    1. I already disabled firewall completely. This did not change the behavior.
    2. We already analysed network traffic. And in this traffic we saw many (unanswered) Netbios-Queries. This brought us to disable the "Netbios-over-TCP/IP". Since there was more Netbios-Traffic after this, we stopped the above mentioned service.

    Has anyone more ideas?

    Monday, August 11, 2014 6:56 AM
  • Hi,

    What is the result if we access files on other network shares?

    I found a thread in novell forum and suggestion is checking the provider order and put Netware first, open network and sharing center, change adapter settings, Select Advanced on the menu> Advanced settings, Click on Provide Order Tab and change order.

    And have you contact the novel support team? They're more familiar with this product.

    http://forums.novell.com/forum.php

    NOTE This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.


    Yolanda Zhu
    TechNet Community Support

    Tuesday, August 12, 2014 7:29 AM
  • Hi,

    we already tried it with Windows-shares on servers joined to our domain. There we had no performance issues.

    And we already found the referenced Novell-article, too. So we tried to change the provider order already... without success.

    But:
    We found a solution!

    The problem was on my PC. I have VMware Workstation installed with two additional virtual network adapters. I disabled "Netbios-over-TCP/IP" on my primary network adapter, but I forgot to disable it on those adapters.

    So after disabling it on the virtual adapters too, every access to a Novell-share is fast. I don't need to disable the service anymore.

    Thanks for your help!

    Tuesday, August 12, 2014 1:21 PM