none
AnalysisServices Error in Event Viewer (Event ID:6644)

    Question

  • Hi Team,

    Getting the below log in event viewer.

    Event ID:6644

    Event manager error: Could not load file or assembly 'Microsoft.AnalysisServices.SharePoint.Integration, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.

    But we have version 12 in server  C:\Windows\Assembly\GAC_MSIL\Microsoft.AnalysisServices\12.0.0.0__89845dcd8080cc91\Microsoft.AnalysisServices.DLL

    Can anyone help me how to fix the issue?

    Thanks,

    Ashok

    Friday, March 24, 2017 2:47 PM

All replies

  • Hi Ashok,

    Are you using PowerPivot 2013 on your Sharepoint environment, when you deploy SharePoint 2013 solution it seems.NET assembly redirect from 10.0.0.0 to 11.0.0.0.  That is the one that gets installed by the 2013 solutions

    PowerPivot 2013 is even still using this AnalysisServices.SharePoint.Integration assembly

    Check this MS explanation and you can fix in this way, you need to re-deploy the solution package to see if this help. For more information, please see:  Could not load file or assembly, follow the below stseps.

    https://msdn.microsoft.com/en-us/library/ff487868.aspx

    In SharePoint 2010 environments that have Power Pivot for SharePoint, this error will occur if the application-level solution for Power Pivot did not deploy correctly


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Friday, March 24, 2017 3:05 PM
  • Hi Krishna,

    Thanks.

    Yes I am using PowerPivot 2013.Even I redeployed it didn't fixed my issue.

    Regards,

    Ashok

    Friday, March 24, 2017 3:32 PM
  • Hi Ashok,

    Please edit the web.config file located at C:\Program Files\Microsoft Office Servers\15.0\WebServices\PpsMonitoringServer, change the "<bindingRedirect oldVersion="9.0.0.0" newVersion="10.0.0.0" />" to this "<bindingRedirect oldVersion="10.0.0.0" newVersion="12.0.0.0" />" to see what happens.

    Best Regards,

    Victoria

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, March 27, 2017 11:35 AM
    Moderator
  • Hi Victoria,

    I changed redirection from 10 to 12 instead of 9 to 10 but getting same error.

    Thanks,

    Ashok

    Monday, March 27, 2017 12:35 PM
  • Hi Ashok,

    Please clear configuration cache and then run IISREST.

    https://gallery.technet.microsoft.com/office/SharePoint-2010-2013-21f55320

    Best Regards,

    Victoria


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 29, 2017 11:04 AM
    Moderator