locked
Powershell virtual directory authentication change RRS feed

  • Question

  • Hi,

    We just applied SP2 on in our Exchange 2010 environment. We noticed after that that windows authentication on the powershell directory on IIS changed forn enabled to disabled which caused some issues for some of our third party tools that rely on powershell. Can someone explain to me the reasoning behind the change? I couldn't find anything in the release notes.

    Wednesday, March 14, 2012 12:57 PM

Answers

  • I just checked again on a machine pre SP2 and another one with SP2. The machine with pre SP2 (it has SP1 RU4) has PS windows authetication  enabled but it's disabled on the machine with SP2. This looks to me like an undocumented change. Maybe someone from the exchange product group can elaborate.
    • Marked as answer by Mike Logan Thursday, March 15, 2012 8:19 PM
    • Unmarked as answer by Mike Logan Thursday, March 15, 2012 8:19 PM
    • Marked as answer by Mike Logan Thursday, March 15, 2012 8:19 PM
    Thursday, March 15, 2012 12:59 AM

All replies

  • Nor can I, the defaults are here -

    http://technet.microsoft.com/en-us/library/gg247612.aspx

    Not sure why that was changed.


    Sukh

    Thursday, March 15, 2012 12:13 AM
  • I just checked again on a machine pre SP2 and another one with SP2. The machine with pre SP2 (it has SP1 RU4) has PS windows authetication  enabled but it's disabled on the machine with SP2. This looks to me like an undocumented change. Maybe someone from the exchange product group can elaborate.
    • Marked as answer by Mike Logan Thursday, March 15, 2012 8:19 PM
    • Unmarked as answer by Mike Logan Thursday, March 15, 2012 8:19 PM
    • Marked as answer by Mike Logan Thursday, March 15, 2012 8:19 PM
    Thursday, March 15, 2012 12:59 AM
  • I know this question is a little old, but I can't find any information on this change anywhere.  Should the authentication settings on the 'PowerShell' virtual directory be changed back to their pre-SP2 values?  Does leaving anonymous authentication disabled cause any issues?
    Friday, September 14, 2012 3:10 PM