locked
Unable to access registry RRS feed

  • Question

  • I have sequenced application Look@Lan.

    WHile launching the shortcut it will check the registry value

    [HKCU\Software\Borland\Locales]

    String Name : <Path of LookAtLan.exe>

    Value: ENG

    And loads with English language.

    If registry doesn't exists it loads in Swedish language.

    I kept this registry in Package, but still it is loading in Swedish language.

    Please help me on this.


    Thanks and Regards, Uday Kiran Reddy Project Engineer Technology Infrastructure Services, Wipro Technologies ____________________________________________ Mob: +91-900-061-2578 | Email: uday1kiran@live.in

    Wednesday, September 30, 2015 6:54 AM

Answers

  • Check This: https://social.technet.microsoft.com/Forums/en-US/53075f47-ce35-48cf-a36c-a8746aa26d4c/can-regional-and-language-settings-locale-date-format-etc-be-applied-through-registry-in-appv?forum=mdopappv

    Seems that the Locales can't be applied with AppV.

    Wednesday, September 30, 2015 7:27 AM
  • I think this app is a bit buggy, try change:
    %ALLUSERSPROFILE%\Microsoft\AppV\Client\Integration\2CE1DD44-21D8-49EC-A66F-35814471872A\Root\VFS\ProgramFilesX86\Look@LAN\LookAtLan.exe
    to
    C:\ProgramData\Microsoft\AppV\Client\Integration\2CE1DD44-21D8-49EC-A66F-35814471872A\Root\VFS\ProgramFilesX86\Look@LAN\LookAtLan.exe
    If that still does not work:

    Try to resequence, and this time set PVAD to your installdir.

    Wednesday, September 30, 2015 7:35 AM
  • Try to launch the shortcut by opening up virtual bubble using start-process in PS and see or you can use /appvve instead.

    $AppVName = Get-AppvClientPackage *name*
    
    Start-AppvVirtualProcess -AppvClientObject $AppVName cmd.exe
    

    Once Cmd opens up virtual environment, launch your shortcut. Or else you can edit the shortcut and use parameters like the below.

    C:\Windows\System32\cmd.exe /c "shortcutpath" /appvve:<PACKAGEGUID_VERSION_GUID>


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, September 30, 2015 8:10 AM

All replies

  • I guess your shortcut explicitly looks for the REG value in local registry. One way to confirm this is to publish the package. create a local registry key with the above value and then launch the shortcut and verify.

    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, September 30, 2015 7:06 AM
  • I applied locally by chaging the path in registry to

    %ALLUSERSPROFILE%\Microsoft\AppV\Client\Integration\2CE1DD44-21D8-49EC-A66F-35814471872A\Root\VFS\ProgramFilesX86\Look@LAN\LookAtLan.exe

    based on the shortcut target location.But it is not working still

    I f I copy the files manually to other machine and keep them on desktop locally instead of App-v.It is working if we keep the HKCU registry to Desktop path.

    But it App-V no progress.


    Thanks and Regards, Uday Kiran Reddy Project Engineer Technology Infrastructure Services, Wipro Technologies ____________________________________________ Mob: +91-900-061-2578 | Email: uday1kiran@live.in

    Wednesday, September 30, 2015 7:15 AM
  • Check This: https://social.technet.microsoft.com/Forums/en-US/53075f47-ce35-48cf-a36c-a8746aa26d4c/can-regional-and-language-settings-locale-date-format-etc-be-applied-through-registry-in-appv?forum=mdopappv

    Seems that the Locales can't be applied with AppV.

    Wednesday, September 30, 2015 7:27 AM
  • I think this app is a bit buggy, try change:
    %ALLUSERSPROFILE%\Microsoft\AppV\Client\Integration\2CE1DD44-21D8-49EC-A66F-35814471872A\Root\VFS\ProgramFilesX86\Look@LAN\LookAtLan.exe
    to
    C:\ProgramData\Microsoft\AppV\Client\Integration\2CE1DD44-21D8-49EC-A66F-35814471872A\Root\VFS\ProgramFilesX86\Look@LAN\LookAtLan.exe
    If that still does not work:

    Try to resequence, and this time set PVAD to your installdir.

    Wednesday, September 30, 2015 7:35 AM
  • Try to launch the shortcut by opening up virtual bubble using start-process in PS and see or you can use /appvve instead.

    $AppVName = Get-AppvClientPackage *name*
    
    Start-AppvVirtualProcess -AppvClientObject $AppVName cmd.exe
    

    Once Cmd opens up virtual environment, launch your shortcut. Or else you can edit the shortcut and use parameters like the below.

    C:\Windows\System32\cmd.exe /c "shortcutpath" /appvve:<PACKAGEGUID_VERSION_GUID>


    (Please click on "Vote as Helpful" and/or "Mark as Answer", if it has helped you. )

    Wednesday, September 30, 2015 8:10 AM