locked
2nd phone keeps ringing in a Hunt Group RRS feed

  • Question

  • Hi.

    We have setup a hunt group with paralell ringing in Lync.

    Most of the time it works like a charm, but if we have only one agent logged inn or in status Available, and revice 2 phones to the hunt group at the same time, the phone keeps ringing even after that one of the phones are answerd. We can talk to in the phone, but the lync client keeps ringing on the second call. The only way we can get rid of the ringing is to hang up the first call, then answer the next.

    Is this a know bug?


    Best Reguards Kim Morgan Ellis Fiva
    Tuesday, June 14, 2011 5:26 PM

All replies

  • Hi,Kim,

    The Response Group application uses standard response group routing methods including Serial,longest-idle,parallel,round robin and the new attendant routing to route the call to the an available agent. However all the agents  are called at the same time for every incoming call, regardless of their current presence. If no  agents are available, the call is held in a queue until an agent is available and the caller hears music during the period. If the queue is full, or if the call times out while in the queue, the caller might hear a message and then is either disconnected or transferred to a different destination depend on your deployment.(Note:Transfer call need Call Park deployment,more details please check http://technet.microsoft.com/en-us/library/gg398513.aspx)

    In your case,if you mean the sencond call keeping ring in a long time but isn't disconnect or transfer,it might be you set a maxium number for your queue and long time for timeout.Would you please check these setting and verified them with the following TechNet document?

    http://technet.microsoft.com/en-us/library/gg521009.aspx

    Regards,

    Sharon


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 16, 2011 10:19 AM
  • Hi,Kim,

    Any updates here?

    Regards,

    Sharon


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 21, 2011 1:40 AM
  • Our queues are setup with an overflow queue both on a timeout, and if the number of callers exceed a limit, I've verified that setup and it looks OK and it works. (Most of the time).

    But I don't think the problem is with the overflow queues. Because when this happens the call does not overflow.

    The problem does not happen all the time, just sometimes. It seems like a bug that makes the lync client on the only available consultant to keep ringing when 2 callers are in the queue. He can answer the first caller and start talking and the second caller keeps ringing.

    The consultant can talk to the first caller, but the second one is ringing. The only way to solve it, is to hang up the first call and answer the second one. If then a third caller calls, that caller goes into the queue and the overflow queue works like a charm again.

    So basically I think this is a bug, the lync client don't register that a call is answerd that would make the client belivie that the next caller should ring. (Does this make sense? :))

     

     


    Best Reguards Kim Morgan Ellis Fiva
    Tuesday, June 21, 2011 8:43 AM
  • OK,I have understanded clearly on your scenario.Unfortunately,I haven't seen or heard this problem before, I am afraid I get a loss here.

    Another thoughts,did you set your hunt group "Formal" or "Informal"?If you set Formal  as your Participant policy of your hunt group,this require the agents click a menu item in Lync 2010 to open Internet Explorer and display a webpage console for signing in and out of the group,so please make sure the other agent have signed out the Response Group when he/she close the Lync client or webpage.

    You can check this link for your group setting

    http://technet.microsoft.com/en-us/library/gg398917.aspx

    If still no luck,could you please re-create it again with the following link

    Create an agent group http://technet.microsoft.com/en-us/library/gg398917.aspx

    Create reponse group queue http://technet.microsoft.com/en-us/library/gg412979.aspx

    Create a hunt group workflow http://technet.microsoft.com/en-us/library/gg412827.aspx

    BTW,did your other response groups work well?

    Regards,

    Sharon

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 23, 2011 10:35 AM
  • I'll have my tech guys have a look when they are back from holiday.

    The agents are set to informal, because they are supposed to in the hunt group at all times.

    What we have done as an workaround untill we find the error is to put the telephone numer to a another hunt group in the Lync setup of the agents, that way when this happens they can transfer the call that keeps ringing to another queue.

    We also tried to do this with transfering to the same que that they are calling to, and that works. Problem is that if there is a queue, the transferd call is put in the back of the queue again.

    I'm 99% sure, that this is a bug in either the Lync client, or our Load balancer setup. If we use the default domain setup, calls from the hunt group spends 8 seconds after answering the phone before you are able to talk to the person. If we setup the clients to go directly to our edge servers the call is answerd instantly. (1-2 seconds at the most).

    My Tech guy said that this happend because the Lync server tried to send the reply to the agent on the wrong nic, although all routing setup is correct. He needed to investigate some more, and will do so when he is back from holiday.

     


    Best Reguards Kim Morgan Ellis Fiva
    Thursday, June 23, 2011 11:18 AM
  • Kim,thanks for your feedback.I will do further research if I have any update information I will let you know.

    Regards,

    Sharon


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, June 24, 2011 6:58 AM
  • Any update on this? We are facing the same issue.

    Bob Ausmus, System Administrator
    Blog 
    Twitter @bobausmus

    Saturday, February 25, 2012 7:02 PM