none
Office 365 and MDT 2013 RRS feed

  • Question

  • Does anyone know where there is documentation on how to create an application for office 365 in MDT 2013 update 2. right now it set as a batch file for the quiet install command section and the working directory is a unc path to where the batch file is found and the application type I  picked  was application without source files or elsewhere on the network. Basically we downloaded the office files to a server and created a command file/batch file that calls the configure.xml file

    I see this in the Bdd logs which I don't understand:

    Return code from command = 1 ZTIApplications 3/1/2018 12:07:29 PM 0 (0x0000)
    Application Microsoft Office 2016 Professional 32bit returned an unexpected return code: 1 ZTIApplications 3/1/2018 12:07:29 PM 0 (0x0000)
    Property InstalledApplications001 is now = {7fe0f22c-074f-45f6-902c-215baabd2834} ZTIApplications 3/1/2018 12:07:29 PM 0 (0x0000)

    Here is an article I used as reference. I know its something I am missing or don't understand

    http://renshollanders.nl/2014/02/office-365-automatic-deployment-of-office-365-with-mdt/

    Any assistance would be great.


    • Edited by DeeJay73 Thursday, March 1, 2018 8:21 PM
    Thursday, March 1, 2018 7:59 PM

All replies

  • Hi,

    Is it possbile for you to share the content of your configure.xml file?

    I have a few different Office 365 installations running in MDT with no issues, so it is possible.

    Wednesday, March 7, 2018 8:13 AM
  • I install O365 without any issues with MDT over the network.

    Batch file:

    @echo off
    pushd %~dp0
    echo Installing Microsoft Office 365
    setup.exe /configure install2.xml

    XML file:

    <Configuration>
    <Add SourcePath="" OfficeClientEdition="32">
        <Product ID="O365ProPlusRetail">
          <Language ID="sv-se" />
        </Product>
      </Add>
     
    <Updates Enabled="TRUE" Channel="Monthly" />
     
    <Display Level="NONE" AcceptEULA="FALSE" />
     
    <Logging Level="Standard" Path="%temp%" />
     
    <Property Name="FORCEAPPSHUTDOWN" Value="FALSE" />
    <Property Name="AUTOACTIVATE" Value="0" />
    </Configuration>




    • Edited by Balterz Wednesday, March 7, 2018 12:09 PM
    • Proposed as answer by Kasper Johansen Wednesday, March 7, 2018 12:34 PM
    Wednesday, March 7, 2018 11:38 AM
  • Hi,

    Try adding this to the XML file:

    <Add OfficeClientEdition="32" SourcePath="\\complete_unc_path_to_the_office365_sourcefiles">

    When installing via MDT, you need to specify the complete path to the Office 365 source files.

    Wednesday, March 7, 2018 11:56 AM
  • Nope you don't. Look at my batch file and xml file in my post above you. I install Office365 without any issues.



    • Edited by Balterz Wednesday, March 7, 2018 12:14 PM
    Wednesday, March 7, 2018 12:07 PM
  • Hmm...nice I wasn't aware, I'll have to test it out.

    Thx :)

    @DeeJay73 Listen to Balterz ;)

    Wednesday, March 7, 2018 12:11 PM
  • Hi Kasper

    I have attached the batch file I am using and the configuration.xml file. To make our security team happy I changed the domain name and share name to just say domain and share name in the real file the actually domain and share name is in the file. Also where in your task sequence do you call for the application to be installed. Thanks for your help.

    The batch file looks like this:

    \\domain\sharename$\Global\Office365\ODT\setup.exe /configure \\domain\sharename$\Global\Office365\ODT\configuration.xml

    The Configuration file looks like this:

    <Configuration>
        <Add OfficeClientEdition="32" Channel="Deferred" SourcePath="\\domain\sharename$\Global\Office365\ODT" OfficeMgmtCOM="False">
            <Product ID="O365ProPlusRetail">
                <Language ID="en-us" />
                <ExcludeApp ID="OneDrive" />
                <ExcludeApp ID="Lync" />
                <ExcludeApp ID="Groove" />
            </Product>
        </Add>
        <Updates Enabled="TRUE" UpdatePath="\\domain\sharename$\Global\Office365\ODT" />
        <Display AcceptEULA="TRUE" Level="Full" />
        <Logging Level="Standard" Path="%temp%" />
    </Configuration>

    Wednesday, March 7, 2018 12:55 PM