none
WMDC driver problems

    Question

  • Have Win 7 on a domain / all GPOs have been removed. But when loading WMDC it gives me "driver could not be loaded successfully" have WMDC 6.1 does this when connecting ANY mobile device OR just when running the WMDC install. Have redownloaded WMDC twice, have uninstalled and reinstalled MANY times. have connected mobile device and removed RNDIS driver - no good. I really feel it is a problem loading WMDC not the mobile device! This is a problem on ANY win 7 machines in the building. NOW if I go to ANY win 7 machine NOT on the domain it works great!. There has to be something I am missing in the Domain world that is not allowing the WMDC to load. I have admin rights on the domain and my machine. all other drivers, apps,etc load just fine--any help would be much appreciated! 
    Monday, October 18, 2010 1:27 PM

All replies

  • How does it work on a Windows 7 computer that just exits the domain?

    You may check event log and see if there is any clues.

    If you deploy ActiveSync or other synchronization applications in your domain, please completely remove these applications and check the result again.

    Arthur Xie
    TechNet Subscriber Support in forum  
    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, October 19, 2010 7:03 AM
    Moderator
  • If I remove the computer from the domain -- it does not help. Have removed fom domain,put into a workgroup,have set reg key to disable group policy - still get the message driver not succsessfully loaded.So far have found NO clue in the event logs.again - works GREAT on a win 7 computer hat has NOT been on the domain. ANY compueronthe domain will not lod the drivers with WMDC 

     

    I'm at loss


    gary mcginnis
    Tuesday, October 19, 2010 12:59 PM
  • Which security programs do you deploy to the clients? Do you deploy ActiveSync and other third party synchronization applications? Temporary disable security programs such as antivirus, antimalware and firewall, and remove all other synchronization programs. Then check the result.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, October 21, 2010 6:42 AM
    Moderator
  • No other sync programs are used by our network. plus I disabled all GPO's,stopped all antivirus programs,and made sure the windows firwall was turned off. When I was working with a non-domain win 7 machine i had turned nothing off!

     

    by the way thanks for the replies!


    gary mcginnis
    Thursday, October 21, 2010 7:25 PM
  • Please open registry editor and navigate to:
     
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Svchost\WindowsMobile

    Right click -> Permissions -> Advanced, take the owner ship of the registry key and assign the Users group Full Control.

    Then open device manager, uninstall Microsoft Mobile Remote Adapter and scan hardware changes. It will be reinstalled.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, October 25, 2010 4:14 AM
    Moderator
  • Performed above procedure and still get "driver not installed properly" both when I reinstalled the WMDC and when I plugged in my device!??

    Appreciate the help but still no go!?


    gary mcginnis
    Monday, October 25, 2010 1:29 PM
  • You may refer the following website and check related logs to try to find some clues.

    Windows Mobile Device Center - How to Create Debugging Logs

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    Did you configure any proxy setting for domain clients? Do you have a gateway that blocks domain clients from accessing some websites? When installing WMDC the installation program will download components from Microsoft servers. If the communication is blocked, the installation will not be successful.

    You may completely remove the antivirus from one client as a test, because the engines of the application may still run even after you turn the antivirus program off.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, October 29, 2010 3:12 AM
    Moderator
  • Hi,

    Just want to confirm if the issue is resolved.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, November 03, 2010 9:24 AM
    Moderator
  • We've had the same problem, which I've detailed here:

    http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/f52aa592-574c-4b51-9af0-976078ab8492

    The problem is that the WMDC install has failed and has failed silently.

    We've tried pretty much every combination we can think of the following to get the install working again: the registry permissions changes you suggest, creating a local administrator, removing the PC from any group policy restrictions, running the WMDC installer as Administrator, and giving every account full control permission in the registry. Nothing would return the PC to its previous, working, "pre-group-policied" state where the install succeeded and devices connected.

    The only other thing we've noted is that the "TrustedInstaller" account was removed when the PC became part of the domain and it isn't reinstated when the PC is removed from the domain again. Is that significant? What account permissions does the WMDC installer have if that account's not there?

    We need a solution which our local government customers' IT departments will agree to perform. It would also be good if the installer gave some indication that all did not go well, and there were some written instruction for domain administrators telling them how to prepare a PC for a successful install of WMDC.

    Thanks

    Andrew

    Friday, November 26, 2010 11:59 AM
  • Did anyone solve this problem?

    I think I have the exact same problem with a Windows Server 2008. The RNDIS driver is loaded, but no portable device is present!

    Please help...

    Tuesday, February 01, 2011 9:53 PM
  • We are having this same exact issue, if we reimage a pc off the domain, it installs wmdc, opens, and installs drivers fine, but if i re image on the domain is where we run into issue. Where can i look to check group policies coming from the servers? Anyone else have a solution for this? We've been working on this for 2 years now to find a solution, feel free to call or email if  you want to discuss or brainstorm: jason.hand@cnmec.org 505-803-4944

     

    Jason Hand

    Central NM Electric Coop

    Helpdesk tech

    Moriarty, NM

    Friday, April 08, 2011 3:21 PM
  • We have fixed this problem on our network.

    The key to this was understanding the role of the TrustedInstaller security principal in the Windows Resource Protection feature introduced in Windows Vista. TrustedInstaller is a Windows service with the display name Windows Modules Installer in the Services list. Its full name is NT SERVICE\TrustedInstaller, which is what you use in permissions dialogues and the like.

    The reason we had a problem is because we followed the advice issued by Microsoft in response to the Conficker virus outbreak. See  http://support.microsoft.com/kb/962007

    In this Virus alert, Microsoft do point out that following their advice might cause problems with installing updates. Our implementation of that advice was to create a group policy which modified the permissions on the registry key HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost.

    In order to allow Windows Mobile Device Centre to install successfully we reverted the permissions back to what we think is their default values. On our PCs the key permissions are:

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion

    Owner: TrustedInstaller

    TrustedInstaller permissions: Full Control & Read, not inherited

     

    HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost

    Owner: System

    TrustedInstaller permissions: Full Control & Read, inherited from CurrentVersion

    Microsoft have effectively told us that the Mitigation steps in the advice were only supposed to be applied temporarily. However, if someone doesn’t want to be responsible for removing this GPO, as far as we can tell, once WMDC is installed you can re-apply it without breaking anything WMDC related; devices are detected, drivers installed and connections established as normal.

    • Proposed as answer by GovGirl33 Friday, November 30, 2012 5:29 PM
    • Unproposed as answer by GovGirl33 Friday, November 30, 2012 5:29 PM
    • Proposed as answer by GovGirl33 Friday, November 30, 2012 5:29 PM
    Friday, July 22, 2011 9:32 AM
  • It works for me! 

    I have been days trying a solution and changing the registry key works perfectly.

    Maybe for those one that doesn't work, should add the Authenticated Users of AD in the security permissions too

    Friday, January 24, 2014 2:25 PM
  • This registry edit worked like a charm.  I did have to run regedit with "run as admin", even though I was logged in as local administrator.

    Thank you!

    Tuesday, April 07, 2015 10:54 PM
  • this is what worked for me...

    To enable Windows Mobile Device Center on Windows 10

    Go to Computer Management > Services

    Choose the service properties of Windows Mobile 2003 Device Connectivity

    Choose Logon tab and change to Local System Account

    I also checked allow services to interact with desktop

    Monday, July 03, 2017 3:47 PM
  • this is what worked for me...

    To enable Windows Mobile Device Center on Windows 10

    Go to Computer Management > Services

    Choose the service properties of Windows Mobile 2003 Device Connectivity

    Choose Logon tab and change to Local System Account

    I also checked allow services to interact with desktop

    Works perfectly for me!

    Thanks.

    Thursday, October 26, 2017 4:45 AM
  • Thank you!
    Tuesday, March 13, 2018 2:59 PM