Unable Save Office Files to Network RRS feed

  • Question

  • Since our update to Windows 7 and Office 2007 some our user experience serious problems when trying to save edited office files to a network drive placed on a Windows Server 2008 with File Services role.

    Unfortunately this happens not each time, but many times a day. A user clicks the icon “save”, you can visually see the saving progress, but after a while the whole computer appears to be frozen so that only forced shutdown helps to get it to function again. Each time after the crash Event ID 1005 being logged in the Application log of the client mashine.

    The .tmp file created on the network share is being not cleared so that the next attempt to open the file leads to the message informing about the sharing violation.

    Affected are different users using several different workstations mostly working with PowerPoint presentations and Excel spreadsheets. Files can be saved locally without any problems. I even have no idea, what could be the reason for this behavior, as we have done a major upgrade from Windows/Office XP and Windows Server 2003 to Windows 7/Office 2007 and Windows Server 2008 Standard. I have also posted this question in Office forum but I am not so sure if this would be a server error.


    Thank you.



    Monday, February 7, 2011 4:24 PM

All replies

  • I'm facing similar issues.  You might want to look at this link to see if things develop that will help you.


    Monday, February 7, 2011 6:48 PM
  • Hi Eduard,

    Please try to disable firewall and security programs on client computers to test again.

    Meanwhile, please check if it is caused by permission. For example, whether the users in problem have different permission on the folders other than else.

    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tngfb@microsoft.com
    Thursday, February 10, 2011 7:33 AM
  • Thank you. I will follow your discussion. Hope we get a solution some day :)
    Thursday, February 10, 2011 10:47 AM
  • Hello Shaon Shan,


    Thank you for your reply. Windows firewall in the domain is disabled by the group policy and is not running. Permissions are controlled using security groups. We use Symantec Endpoint Protection to protect all workstations in the domain.

    At the moment I have made a very interesting observation. Two days ago I have moved the whole directory back to our "old"  Windows 2000 server and then configured permissions using the same groups. The problem disappeared magically. Tomorrow I will get the final reports but I think I can say for sure the problem is not present in Windows 2000 environment. This is surely not a solution to leave it there, but probably narrows my search for the solution.
    Could this be connected to SMB version being used?   


    Thursday, February 10, 2011 11:45 AM
  • Hi,

    Whether the issue occurs on a mapped drive? If so, unmap it and test again to see the result. If issue not reoccurs, remap it to see if it will still work.

    Meanwhile please have a test on steps provided in this article:


    Shaon Shan |TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, February 14, 2011 1:20 AM
  • Hi Shaon Shan,


    Yes, this occurs when saving to a freshly mapped network drive on our new Windows Server 2008. Unfortunately it is our production environment and as I mentioned before I have moved the share back to the "old" server. Since then I receive no reports concerning the issue. Our sales guys have never time to play around but I will try to force them to cooperate :)

    Another case where a user had quite often trouble to save a spreadsheet looks to be solved after converting the spreadsheet to the new Open XML file format.

     In the article you suggested is written " The opportunistic locking registry keys are valid only for traditional SMB (SMB1). You cannot turn off opportunistic locking for SMB2" and I do not understand exactly which steps shall I follow? Shall I disable opportunistic locking on server or a client? Will this function even on Windows 7 clients?


    Thank you for your help




    Tuesday, February 15, 2011 3:55 PM
  • The problem is still there. Shortly I received reports concerning the issue form other departments. Our Windows 2000 and 2003 file servers are not affected. What really happens:


    1.    User is working with an Office file opened from a mapped network drive location

    2.    User has full access permission to the folder and correspondingly to the particular file

    3.    User can usually save changes to the file

    4.    User attempts to save ongoing changes either by choosing file – save or by clicking the save icon

    5.    Office application starts the saving process, green process bar is running up to 30% or 50% approximately

    6.    Office application is not responding anymore, client system freezes so that only hard reset using power button is possible

    7.    After the system reset there is an XXXXXXXX.tmp file created in the mapped drive where XXXXXXXX represents a hex number

    8.    User can open the original file he was working with, changes are not being saved.

    9.    Next attempt to save any changes to the file leads to the sharing violation message (file is in use)


    The issues happens to different office files including Word documents, Power Point presentations and Excel spreadsheets (though I have one report about not being able to extract files from a RAR archive)

    Same problem being discussed by Microsoft Answers with 6 more people




    Every help is really appreciated.

    Friday, April 8, 2011 1:02 PM
  • At least at the moment I can say the problem is solved!!! We have tried the following steps which did NOT help:


    1. Disable/uninstall antivirus software on both server and clients

    2. Moved shared folder from external storage to internal hard disks

    3. Installed all patches even slightly concerned to the problem


    What DID help:


    1.  Disable SMB 2.0 using the description here





    a. Run "regedit" on Windows Server 2008 based computer.

    b. Expand and locate the sub tree as follows.


    c. Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)

    Value name: Smb2

    Value type: REG_DWORD

        0 = disabled

        1 = enabled

    d. Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.

    e. Reboot the server.



    2. Download and install newest driver for the server’s network interface controller




    Wednesday, May 4, 2011 2:56 PM
  • We are in the same boat here.  We just recently upgraded from an older server to a windows 2008 R2 file server, and some of our Windows Clients are having this problem.  I know we can solve it by downgrading to SMB1 on the file server, but I've seen a suggestion that there's a fix to this in Windows 7 Service Pack 1.  I can't find any knowledgebase article to prove this, though.  Does anyone in this thread know about such a fix in Service Pack 1?

    I'd rather not turn off SMB2 on the server, but that's the only option I've found that people agree on so far.

    Tuesday, August 30, 2011 6:52 PM
  • I have SP 1 installed on a Windows 2008 server and still have the problem.
    Wednesday, September 7, 2011 11:08 PM
  • Hi.

    Running into the samme issue this week, we migrated from an older 2003server to a new virtual server 2008r2 running on vmware.

    Server and all win7 clients running with SP1.

    The strange thing is, it does not work double clicking the file in explorer but it does work open recent documents, but the user's do not using preview in explorer.

    The .tmp files are also not cleared on the Shared Folder.

    Maybe in the meantime somebody has a solution for this ?





    • Proposed as answer by superneilius Monday, February 13, 2012 3:26 PM
    • Unproposed as answer by superneilius Monday, February 13, 2012 3:26 PM
    Tuesday, January 17, 2012 3:40 PM
  • In my case I was able to determine that a third party application was the cause of the issue. After removing the application Compuware File-Aid the issue of saving to network shares was resolved.
    Monday, February 13, 2012 3:30 PM
  • Hello,

    I am having possible the same issue. 

    Our office has 2 servers, 1 is windows 2000 the other 2011 smb essentials. I have about 8 windows 7 machines in the office. They all access both servers without issue. That was until earlier this week. One of the machines began having issues saving to network shares on the server running windows 2011 essentials. The problem started with excel then spread to all programs. I can access the drives fine, no permission issues or lag. I can copy and paste / drag and drop files to the network shares with no lag or issues. 

    It is only when you try to save a file from a program such as notepad, word, excel, etc. directly to the network share does the process either have incredible lag, ( saving a 1 kb notepad file takes almost a full minute ) or fails completely and reports that the file is already open. I have removed the machine from the domain and re added it. I even went as far as to plug in a new hard drive and re-install windows 7 and rejoin the domain and the problem continues. The problem persisted, I also tried changing the NIC and no change. 

    I am hesitant to go into the registry on my new server to disable SMB 2.0, i feel if this was the issue then other Windows 7 machines would be affected. Does anyone have any ideas? 

    Friday, March 9, 2012 7:19 PM
  • Run compmgmt.msc on the server, navigate to System Tools | Shared Folder | Open Files. Verify that the user in question does NOT have any files open. The files that are showing as locked will be displayed, simply right click and "Close Open File". As soon as the files were closed the user reported that they could again open them for editing.
    • Proposed as answer by theissen612 Friday, October 5, 2012 4:31 PM
    Tuesday, April 3, 2012 3:55 PM
  • Run compmgmt.msc on the server, navigate to System Tools | Shared Folder | Open Files. Verify that the user in question does NOT have any files open. The files that are showing as locked will be displayed, simply right click and "Close Open File". As soon as the files were closed the user reported that they could again open them for editing.
    THIS WORKED. Thanks Larry... 
    Tried removing the owner file from the '\\server\shared' location, and that didn't work. This is a great way to track down which user on your network has the file open by mistake or stuck in their task manager.
    Friday, October 5, 2012 4:32 PM
  • I disabled SMB 2.0 using the instructions, but the issue wasn't resolved. Users can now save more than twice without the problem occuring, but it still rears its ugly head after 3-8 saves. I'm only seeing it on my two Vista clients when connecting to a 2008 server. Any other ideas?
    Monday, November 4, 2013 4:43 PM