locked
Office 365 - Rules not applying to forwarded emails RRS feed

  • Question

  • On Office 365, I have a shared mailbox forwarding emails to my Office 365 account (both on the same domain).  I created a rule to have emails moved to a specific folder.  The rules is not applying when the email is received by my mailbox but if I manually run the rule it will correct filter the emails in my inbox to the specific folder.

    Is there a way to get the rules to automatically apply to the forwarded emails or is that just a limitation on Outlook?

    Tuesday, July 19, 2016 6:19 PM

Answers

  • Hi,

    Does this issue only happen to those forwarded emails, what about your other existing rules?

    This usually indicates a corruption of the rules or the mailbox. It could also indicate a corruption in the Send/Receive settings file (srs-file) of Outlook.

    Please try the following steps to troubleshoot the issue, and see if any of them help:

    1. Reset srs-file by renaming the srs-file of your profile to .old. You can find the srs-file for your mail profile in C:\Users\%username%\AppData\Roaming\Microsoft\Outlook
    2. Have a try with a new .ost file, and see if that works. Just locate the existing .ost file for your mail profile and rename it to .old and then re-launch Outlook client. The default location of .ost file is: C:\Users\%username%\AppData\Local\Microsoft\Outlook

    Hope this helps. Please feel free to post back with any findings.

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, July 20, 2016 5:32 AM

All replies

  • There are a couple of possibilities that I can think of. First, rules that move messages to other folders are "Client Only" rules, and won't work unless Outlook is running. Second, if you haven't tried this already, add "Stop Processing More Rules" to your rule. 

    -Peter

    Tuesday, July 19, 2016 8:29 PM
  • Hi,

    Does this issue only happen to those forwarded emails, what about your other existing rules?

    This usually indicates a corruption of the rules or the mailbox. It could also indicate a corruption in the Send/Receive settings file (srs-file) of Outlook.

    Please try the following steps to troubleshoot the issue, and see if any of them help:

    1. Reset srs-file by renaming the srs-file of your profile to .old. You can find the srs-file for your mail profile in C:\Users\%username%\AppData\Roaming\Microsoft\Outlook
    2. Have a try with a new .ost file, and see if that works. Just locate the existing .ost file for your mail profile and rename it to .old and then re-launch Outlook client. The default location of .ost file is: C:\Users\%username%\AppData\Local\Microsoft\Outlook

    Hope this helps. Please feel free to post back with any findings.

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, July 20, 2016 5:32 AM