locked
Room calendar/Shared mailbox calendar not updating RRS feed

  • Question

  • Hi Experts
    1. some users when they add resource mailbox calenders or shared mailbox calender they see the message could not update. how do i troubleshoot this. even profile is reconfigured. i am using exchange hybrid enviornment, all my users are exchange online users they have been migrated from onprem, 
    room mailboxes and shared mailboxes are also on cloud i.e they have been migrated to cloud. in these cases how do i troubleshoot. is there any way to sync or update?

    2. I have two resource mailboxes and below are their permissions. What is the difference between Limited Details and Availability Only. for room1 i dont want my users to see who has booked meeting room., for room2 i want my users to see who has booked meeting rooms.What privileges do i need to assign for room1 and room2. what is free/busy?

    When I check for permissions with: Get-MailboxFolderPermission -Identity room1@contoso.com:\Calendar
    FolderName           User                 AccessRights
    ----------           ----                 ------------
    Calendar             Default              {LimitedDetails}
    Calendar             Anonymous            {None}
    Calendar             MyFirstDelegate       {Editor}
    Calendar             MySecondDelegate      {Editor}

    When I check for permissions with: Get-MailboxFolderPermission -Identity room1@contoso.com:\Calendar
    FolderName           User                 AccessRights
    ----------           ----                 ------------
    Calendar             Default              {Availablity Only}
    Calendar             Anonymous            {None}
    Calendar             MyFirstDelegate       {Editor}
    Calendar             MySecondDelegate      {Editor}
    Thursday, December 19, 2019 6:18 AM

Answers

  • Hello Glenn,

    1. After you migrated to Exchange Online did you set the permissions again for all Room/Shared mailboxes. After a Exchange Online migration all the calendar permissions are gone. Do you use Shared Folder caching? This works poorly with Exchange Online. Could you try to disable this?

    2. Limited Details = here you can see who booked the room. AvailabilityOnly = Free/Busy.

    • Marked as answer by Glenn Maxwell Sunday, January 26, 2020 11:55 AM
    Thursday, December 19, 2019 7:16 AM
  • Hi Glenn,

    1.It is recommended to remove and re-add the permission to the resource/shared mailbox to see if the issue persists.

    Remove-MailboxPermission -Identity Test1 -User Test2 -AccessRights FullAccess -InheritanceType AllAdd-MailboxPermission -Identity Test1 -User Test2 -AccessRights FullAccess -InheritanceType All

    2.LimitedDetails means availability data(free/busy information) with subject and location can be viewed. AvailabilityOnly means only availability data can be viewed.

    If you don't want your users to see who has booked meeting room1, set AccessRights from Editor to LimitedDetails/AvailabilityOnly.
    If you want your users to see who has booked meeting room2, set AccessRights from AvailabilityOnly to Reviewer.

    Set-MailboxFolderPermission -Identity Room1@contoso.com:\Calendar -User delegate -AccessRights AvailabilityOnlySet-MailboxFolderPermission -Identity Room2@contoso.com:\Calendar -User delegate -AccessRights Reviewer

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Friday, December 20, 2019 9:25 AM

All replies

  • Hello Glenn,

    1. After you migrated to Exchange Online did you set the permissions again for all Room/Shared mailboxes. After a Exchange Online migration all the calendar permissions are gone. Do you use Shared Folder caching? This works poorly with Exchange Online. Could you try to disable this?

    2. Limited Details = here you can see who booked the room. AvailabilityOnly = Free/Busy.

    • Marked as answer by Glenn Maxwell Sunday, January 26, 2020 11:55 AM
    Thursday, December 19, 2019 7:16 AM
  • 1. I did not set the permissions again.

    2. What is shared folder caching. How to disable it.

    Friday, December 20, 2019 4:48 AM
  • Hello Glenn,

    You can disable Shared Folder caching by GPO:

    https://support.microsoft.com/en-us/help/982697/by-default-shared-mail-folders-are-downloaded-in-cached-mode-in-outloo

    If you use Intune you can use choose to disable Shared Folder caching via a Configuration Profile with ADMX templates.

    Regards,

    Niels

    Friday, December 20, 2019 7:55 AM
  • Hi Glenn,

    1.It is recommended to remove and re-add the permission to the resource/shared mailbox to see if the issue persists.

    Remove-MailboxPermission -Identity Test1 -User Test2 -AccessRights FullAccess -InheritanceType AllAdd-MailboxPermission -Identity Test1 -User Test2 -AccessRights FullAccess -InheritanceType All

    2.LimitedDetails means availability data(free/busy information) with subject and location can be viewed. AvailabilityOnly means only availability data can be viewed.

    If you don't want your users to see who has booked meeting room1, set AccessRights from Editor to LimitedDetails/AvailabilityOnly.
    If you want your users to see who has booked meeting room2, set AccessRights from AvailabilityOnly to Reviewer.

    Set-MailboxFolderPermission -Identity Room1@contoso.com:\Calendar -User delegate -AccessRights AvailabilityOnlySet-MailboxFolderPermission -Identity Room2@contoso.com:\Calendar -User delegate -AccessRights Reviewer

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Friday, December 20, 2019 9:25 AM
  • Hi,
    I am writing here to confirm with you how the thing going now?
    If you need further help, please provide more detailed information, so that we can give more appropriate suggestions.

    Regards,

    Beverly Gao


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 25, 2019 1:17 AM