none
Database auto-protection failed RRS feed

  • Question

  • I installed Update Rollup 6 (KB4456327) for SCDPM 2016 and ever since then the database auto-protection has stopped working:

    I tried running the "mofcomp sqlmgmproviderxpsp2up.mof" command that a few sites recommend, but it has not helped. When I run the "AutoProtectInstances.ps1" script from DPM Mgmt Shell I get the following error:

    I dont think it's a problem enumerating the databases because I'm able to see those when I go to modify the protection group:


    Thoughts? 


    Shaun

    Friday, November 16, 2018 2:07 PM

All replies

  • Hello Shaun,

    Sorry to hear about your issue, have you updated the DPM agents on the protected servers after updating to the Update Rollup 6?


    Could you also check the DPMCurr.errlog on the protected server for any clues? It's located in
    C:\Program Files\Microsoft Data Protection Manager\DPM\Temp\DPMCurr.errlog


    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, November 16, 2018 3:36 PM
  • I'm not having an issue with protected servers, only with the DPM database auto-protection. I thought maybe I needed to update the DPM agent on the DPM server itself, but when I tried to install I got a message that I can't install the agent on the DPM server. 

    I checked the DPMCurr.errolog on the DPM server but nothing really stood out. 


    Shaun

    Monday, November 26, 2018 6:39 PM
  • You only need to install the dataprotectionmanager2016-kbXXXXXXX_GUID.exe on the DPM server.

    What versions of SQL Server are these that you have protected?

    Also how is this SQL Server set up?

    PS: I have also written a blog post about installing an update rollup for DPM 2016.

    DPM 2016: How to install an Update Rollup and how to update the DPM consoles

    https://thesystemcenterblog.com/2018/11/13/dpm-2016-how-to-install-an-update-rollup-and-how-to-update-the-dpm-consoles/


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, November 27, 2018 2:39 PM
  • Thanks, not having any issues installing the update rollup...it's installed and agents on protected servers have all been updated without issue. I just receive this "database auto-protection failed" message each night ever since installing the latest update rollup. 

    Looking more closely, I just noticed that the error always happens just after midnight, but I don't have anything scheduled for that time in any protection groups - Recovery points happen at 7PM, online backup to Azure happens at 10PM. If I look at the protection group status for my DPM server, replicas are good and I have numerous online recovery points going back a month. So now I'm not sure what this error is referring to...

    SQL is installed locally on same machine as DPM, version 2014 SP2 (KB3171021, version 12.0.5000.0). 


    Shaun

    Friday, November 30, 2018 6:37 PM
  • Same problem here, couple days after installing UR6 this popped up. I've ran AutoProtectInstances.ps1 with the same result as Shaunm001.
    Saturday, December 1, 2018 11:02 AM