locked
child domain computers fail to install client with error 2147944122 RRS feed

  • Question

  • I am migrating from SCCM 2007 R3 to SCCM 2012. The SCCM 2012 servers are in the parent domain. Installing the client on computers in the parent domain went well. However install the client computer in the child domain is failing. The computers are running Windows 7 and Windows 2008 R2. The SCCM server connects to the computers and I do not find any security audit failures in the in the security log. The SCCM 2012 console states error 2147944122.

    Anyone have an idea?

    Friday, June 29, 2012 9:47 PM

Answers

  • I created a boundary group and after that everything seem to work correctly.  It seems that the only problem was a lack of the boundary group.

    • Marked as answer by Carl M5646813 Wednesday, July 18, 2012 12:45 AM
    Wednesday, July 18, 2012 12:45 AM

All replies

  • How did you try to install the client? Client push? If so: what's in ccm.log on the siteserver?

    Torsten Meringer | http://www.mssccmfaq.de

    Monday, July 2, 2012 7:05 AM
  • I am using client push.

    What I found in the ccm.log is an WMI error.

    The Configuration Manager server can resolve the name of the client and the firewall is disabled.

    ======>Begin Processing request: "2097152352", machine name: "SERVER"  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.846+300><thread=5216 (0x1460)>
    Execute query exec [sp_IsMPAvailable] N'COD'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.861+300><thread=5216 (0x1460)>
    ---> Trying each entry in the SMS Client Remote Installation account list~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.861+300><thread=5216 (0x1460)>
    ---> Warning: no remote client installation account found  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.877+300><thread=5216 (0x1460)>
    ---> Attempting to connect to administrative share '\\SERVER\admin$' using machine account.~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.877+300><thread=5216 (0x1460)>
    ---> Connected to administrative share on machine SERVER~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.908+300><thread=5216 (0x1460)>
    ---> Attempting to make IPC connection to share <\\SERVER\IPC$> ~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.908+300><thread=5216 (0x1460)>
    ---> Searching for SMSClientInstall.* under '\\SERVER\admin$\'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.924+300><thread=5216 (0x1460)>
    CWmi::Connect(): ConnectServer(Namespace) failed. - 0x800706ba~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.955+300><thread=5216 (0x1460)>
    ---> Unable to connect to WMI on remote machine "SERVER", error = 0x800706ba.  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.955+300><thread=5216 (0x1460)>
    ---> Deleting SMS Client Install Lock File '\\SERVER\admin$\SMSClientInstall.COD'~  $$<SMS_CLIENT_CONFIG_MANAGER><07-02-2012 11:21:57.970+300><thread=5216 (0x1460)>

    Monday, July 2, 2012 6:51 PM
  • 0x800706ba = The RPC server is unavailable. Is the firewall enabled? Have you configured the exceptions according to http://technet.microsoft.com/en-us/library/gg682180.aspx?

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, July 3, 2012 6:58 AM
  • The firewall is disabled. i used Wbemtest and was able to query target from the server.

    Thursday, July 5, 2012 10:22 PM
  • Do a test with 1 or 2 client computer in the child domain, try to install SCCM 2012 agent manually and check if its works.

    try install manually by your Client push account as well and another by your domain user account (should me local admin of the client).

    do this test once.


    Regards, PBC

    Tuesday, July 10, 2012 9:15 AM
  • Manual install fails with the below errors

    ']LOG]!><time="16:20:58.466+300" date="07-10-2012" component="ccmsetup" context="" type="0" thread="3612" file="util.cpp:2205">

    <![LOG[Sending message header '<Msg SchemaVersion="1.1"><ID>{D89A4EA7-E8A8-4FBC-99D3-FCB1CEC9FEC6}</ID><SourceHost>PC3558</SourceHost><TargetAddress>mp:[http]MP_LocationManager</TargetAddress><ReplyTo>direct:PC3558:LS_ReplyLocations</ReplyTo><Priority>3</Priority><Timeout>600</Timeout><ReqVersion>5931</ReqVersion><TargetHost>server.domain</TargetHost><TargetEndpoint>MP_LocationManager</TargetEndpoint><ReplyMode>Sync</ReplyMode><Protocol>http</Protocol><SentTime>2012-07-10T21:20:58Z</SentTime><Body Type="ByteRange" Offset="0" Length="1100"/><Hooks><Hook3 Name="zlib-compress"/></Hooks><Payload Type="inline"/></Msg>']LOG]!><time="16:20:58.466+300" date="07-10-2012" component="ccmsetup" context="" type="0" thread="3612" file="util.cpp:2286">

    <![LOG[CCM_POST 'HTTP://server.domain/ccm_system/request']LOG]!><time="16:20:58.466+300" date="07-10-2012" component="ccmsetup" context="" type="1" thread="3612" file="httphelper.cpp:802">

    <![LOG[Failed to receive ccm message response. Status code = 403]LOG]!><time="16:20:58.482+300" date="07-10-2012" component="ccmsetup" context="" type="2" thread="3612" file="httphelper.cpp:1689">

    <![LOG[GetDPLocations failed with error 0x80004005]LOG]!><time="16:20:58.482+300" date="07-10-2012" component="ccmsetup" context="" type="3" thread="3612" file="util.cpp:2487">

    <![LOG[Failed to get DP locations as the expected version from MP 'server.domain'. Error 0x80004005]LOG]!><time="16:20:58.482+300" date="07-10-2012" component="ccmsetup" context="" type="2" thread="3612" file="ccmsetup.cpp:9542">

    <![LOG[Next retry in 10 minute(s)...]LOG]!><time="16:20:58.482+300" date="07-10-2012" component="ccmsetup" context="" type="0" thread="3612" file="ccmsetup.cpp:7554">

    If I browse to ccm_system/request I do get a 403 error; however, no certificate error.

    On the server, the folder ccm_system is empty.

    However if I manually install the agent with no configuration, the install completes fine.

    After the agent is running, it discovers the site code and site servers. Then everything seems ok; so how does that work?

    Tuesday, July 10, 2012 10:34 PM
  • I created a boundary group and after that everything seem to work correctly.  It seems that the only problem was a lack of the boundary group.

    • Marked as answer by Carl M5646813 Wednesday, July 18, 2012 12:45 AM
    Wednesday, July 18, 2012 12:45 AM